Layout (SU Pro 2016) will not convert files to PDF

When I duplicate this on my laptop… it converts just fine.

Thanks Anssi good point, Hey John, what Windows version are you running?


I’m running 7 Pro on my desktop, 8.1 on my laptop, both 64 bit. Interesting though, when I check LO properties\compatibility on my PC, it shows Windows Vista. My laptop shows Windows 8. I have tried changing the compatibility mode to Windows 7 on the PC, and it still doesn’t work.

Thanks John,… I will continue to look into this… I am not sure yet why this is happening.


I certainly appreciate your effort. I’m suspecting an interface problem with Windows 7 pro. I have tried removing and reinstalling SU 2016. However, when I reinstalled it, I couldn’t get the setup.exe program to run until I installed the MSI silent version… if that’s any clue.

Arrrrrrrrrrrrrrgh! Now when I try to reinstall SU Pro 2016, I get the prebootstrapper error. I tried downloading the SU 2017, and same thing. This is frustrating.

I had the same message. I found nothing in this thread that assisted me. I was able to print to a .pdf printer but was unable to achieve the correct format. What did shed some light on the problem was when I turned of one layer at a time and tried to export and choose .pdf as the option. Eventually I was able to identify the corrupt layer through process of elimination. I have a separate layer for text and the problem is somewhere in that layer since every other layer will export. At least this will keep me from recreating the entire drawing. I will re-post if I discover anything further.

Thanks for sharing. I haven’t had any time to revisit the issue on my PC, but will try an elimination process based on your experience.

I’m not sure that post will be of any help. What I ended up doing was using
Windows to select Adobe PDF as my default printer, setting up the paper
size, and printing to the PDF printer and that worked. In my case I needed
Arch D which is available in Acrobat. The interesting thing is I only had a
problem with one of two sheets that were in the same file for whatever
that’s worth. It still remains a mystery and it still remains a problem
that SketchUp needs to take a look at and remedy.


That’s what I was doing was using a PDF printer program. I only have the problem using windows 7 Pro. If I take the same layout file, save it to a thumb drive, import it to my laptop which is running windows 8.1, it creates PDF’s just fine. Weird.

Have any of the Sketchup programmers bothered to figure this dilemma out?

(FYI, Moved to the new Technical Problems > LayOut category.)

Same issue here. LayOut will not export to PDF using the File > Export command.

Here is a workaround that works for me. Go to File > Print, select Adobe PDF in the printer drop-down, click Preferences then Adobe PDF Settings tab. Set your parameters (paper size, etc.). Only a few paper sizes are available. If you need an outlandish one like Arch D, you can click Add and enter your own because, like, who in the world uses Arch D construction documents?

Caveat: I have Acrobat Pro installed on my system and I am unsure whether this works if it is not installed.

Note to dev team: I bet 99% of Pro users fork the big bucks for LayOut. Wouldn’t you think then that bringing it up to par with SU should be considered a priority?

You seem to think that exporting to PDF from LayOut doesn’t work for anyone. That’s not true. I use LayOut regularly and I’ve never had any problem with PDF exports. I know many other LO users who also make PDF exports with no problems.

I was specifically referring to the Windows 7 pro interface.

Adobe has a habit of setting itself as default…

if so, that could prevent the pdf writer used by LayOut from working…

IMHO: LayOut usage by Pro users would be less than 25% currently…


@DaveR I am sorry, I was unclear. The PDF export issue is a minor one; as you rightly point out it does not affect everyone, and workarounds seem to exist. My point was that LO is, in general, fraught with bugs, UI inconsistencies, absent features and extreme slugishness that make it one frustrating app to use. Try editing text in a callout, for instance. Ctrl+C doesn’t even work!!

The trouble is that LO sits on the critical path that leads from Sketchup model to real-world output, the kind by which folks earn a living, like presentations or construction docs. The one amazing feature of LO is the Sketchup viewports, but why is it wrapped in a desktop publishing program that would have been subpar in 2005? Sketchup is a fantastic app, but what good is that if you can’t easily get what you need out of it?

@Novurba… Exactly! These “work-arounds” cost me time and ultimately money.

1 Like

I have seemingly the same issue with SketchUp Pro 2017 and 2018 on one of my laptops. Seems to export with no problems from another, far more basic, laptop that I have SU2018 installed on. I’ve detailed the problem and steps in the link below and have had quite a few spaced out responses from the SketchUp Pro support team, though no information of value or resolution progress yet.

Even just opening layout, drawing a single line (ie. no links to SketchUp models) and I get the ambiguous “There was a problem exporting to this file” error.

Layout 2018 can’t export PDF error “There was a problem exporting to this file”