Layout 2018 upgrade install and export issues


#1

I am not new to SketchUp or Layout, having started long ago on skp v3.0 when many people refrained from using it. However later versions are becoming more complex for good reason but installing and migrating upwards has its problems, here is mine…

The main office PC refused to load 2017 with the prebootstrapper issue, I got round that by removing the setup file and installing directly the *SketchUp2017-x64.msi file with admin rights etc. All was good with Skp 2017 including layout until the 2018 upgrade…

Install had same prebootstrapper issue (so same work round used) - 2018 loads well now, all good until exporting pdf’s after a couple of weeks with the usual message “There was a problem exporting to this file.” What triggered it I do not know, but its affected all the sketchup versions on that pc (versions 2015/16/17 ) if you open any of them and try and make a pdf.
I have changed pdf readers to Abobe just in case the fall version of Win 10 Edge may have caused the issue but as it works on the laptop then thats not it.

Using the exact same LO file on another pc / laptop and there is no problem, even on 32bit XP ( if you convert back to 2014 file). Then I also find out that converting files from LO 2018 to earlier LO versions is causing intermittent bug splats, Some earlier imported LO files are bringing in the yellow triangles into LO 2018 likes of which I have not seen for years…

The issue has to be in this pc and a conflict somewhere can anyone help or give direction to a link that is similar, I have followed a few but no real answers… I dont want to have to use the laptop as the main computer but looks like I may have to…

WIN 10 pro 64bit fall version
32Gb RAM
Xeon E5 2630 v3, 2,4 Mhz 8 core
Nvidia quadro K4200
Dell 7910 tower

The laptop that it all works great on is Dell 5510 same 2018 upgrade same files


#2

Hi chaz_plan, sorry you are having issues exporting and this is a strange case. It sounds like you are exporting and not printing so are you exporting with ‘Show Export in PDF Viewer’ option checked?

If so could you try unchecking this option?

Trent


#3

Hi Trent, I have tried this earlier, I have checked and unchecked all boxes in various combinations, copied the settings that work on my laptop and it always returns the same ‘there was a problem exporting this file’ message only on this pc though. The 2018 upgrade has refused to export pdf’s although all other formats do( jpg png dxf dwg etc).

This event may be of help though…earlier in skp 2017 (probably during a win 10 update) the pdf would not return a pdf preview even though requested, it did export the pdf though. That said I do prefer skp2014 use of control of the exported image as cleaner and easier.

Chaz


#4

Hi Chaz…could you try a couple of things? you may have tried this already and if so I apologize.

Export a blank sheet to .pdf to your desktop.
if that passes
Draw a square then export .pdf to your desktop.
if that works …
Import a SketchUp model export to .pdf to your desktop.

Trent


#5

Hi Trent, good point about exporting a blank, I tried it but same issue so I dont think its the file or its size etc, more a conflict within the program.

I have re-installed it, repaired it (all under admin rights) also run separate .exe files for InstallPrerequisites and vcredist_x64 with no improvement to export. I dont know how SKP merges with earlier version as it has affected all other earlier version of sketchup the same way so I cannot export in earlier versions either on this machine now…stumped

Thanks again have you any further work rounds that may unlock this Chaz


#6

Chaz,

I just encountered an error exporting to PDF on a floorplan design. Thought it was corrupted file or bad link as this was the only model and layout producing this error. So, I copied the elements page by page to a new file as standard procedure to debug a corrupted layout file. Removed and purged any 2016 version scrapbook items to check for that being an issue. Didn’t help. Here’s what fixed it: I went sheet by sheet, and found the offending sheet. On a hunch, I tried changing render mode of my floorplan (with wiring done in dashed lines via Layout 2018) from Hybrid to just Raster. Bam. That resolved it. So now I know: a mild mannered model in Hybrid with markup in Layout can cause it to return an error exporting PDF. Easy fix (workaround), but honestly, not satisfactory in view of potentially grainy output if the end user tries to scale it up.

For what it’s worth, I saved a backwardly compatible copy as 2016 Layout, and got the same results. So, whatever it is about my model and hybrid, they don’t get along regardless of the version.

I suggest trying this debug on yours, simply because it’s easy, and it worked for my problem. All the other 2016 files I have tried have converted to 2018 ok, no hybrid render problems yet but the list sure isn’t exhaustive as of this post. At least I know to watch for it. Hopefully if debugging’s moving forward, this will be addressed before the next upgrade to Sketchup. All in all, loving the new features in 2018 so far. Improved inferencine and render engine are nice. I do get a lot more bug splats with 2018 than 2016 though. I’m a compulsive “save that file every change you make” person, but it still gets me and wastes some time.

Does anyone know if any particular extensions have been tagged for causing this PDF output issue? You could try disabling all your extensions, and trying your PDF export. If it goes off without a hitch, start enabling them one at a time to find the offender.

For what it’s worth, I had a model do this once in SKU 2015, refusing to output PDF thanks to hybrid selected as rendering option. Going Raster fixed it right away.

BTW, I’m running XP Pro, and a generic PDF program, Foxit PDF which has done great with all prior iterations of Sketchup and Layout.


#7

Really? Still Windows XP?

Maybe you should see this: https://help.sketchup.com/en/article/36208

It could be a combination of unsupported Operating system and possibly outdated graphics drivers.


#8

My bad, I’m running Windows 7 ultimate, not XP. That said, if you’re
telling me the key to getting my hybrid render setting to export PDF’s is
likely my older Windows version, I would definitely consider the upgrade. I
just hate how Windows tends to just bloat to consume the resources
available to it in each new edition, so running the older version kept
system was to reduce learning curve and keep footprint lighter. Still, if
10’s not a pain, and given the 3D type updates MS has been working in, it
may just be time to bite the digital bullet and upgrade. Any caveats you
know of to steer me right? Thanks for the feedback. Always learn from and
enjoy your comments. Also, if you’re clocking fewer bugsplats with newer
Windows, that’d about clinch it for me. I’ve had a plethora of them with
2018 so far.


#9

The first thing I’d do then is make sure you installed SketchUp correctly by right clicking on the installer file and choosing Run as administrator. Then choose the Repair option. Next, make sure the graphics drivers are up to date.

I was reluctant at first to go to Windows 10 Pro but one morning when I got to my computer I found that Microsoft had installed it without my permission. It hasn’t caused me any problems since then. Evidently some users of Windows 10 not pro have had difficulty when Microsoft pushes software updates because the updates reset the on-board Intel graphics as default. If it happens you just need to go back and make the Nvidia the default for SketchUp and LayOut.


#10

Ah yes. Those sorts of things are the other reason I’ve avoided Win 10.
"Resistance is futile, you will be updated."
I’ll look into the fix option. It’s proving a consistent glitch refusing to
export hybrid render items. Thanks.


#11

Dave, are the man. The “fix” mode of the installer seems to have resolved
it. Whew. Still wondering how on earth I had a glitched install first go
round, but nonetheless, hybrid render setting is back in action. Many
thanks!


#12

I had this issue with 2017 so installed 2018. Am getting the same issue and have tried the steps above. I installed as admin. I had a PreBootstrapper error and installed using the steps in this post -

This allowed me to install. However I’m now getting an error whenever I try to export (same one I had in 2017)

I’ve tried doing a blank PDF with a short name saved to the desktop but still no dice! Does anyone have any suggestions. Checked my graphics driver which is up to date - am at a loss for what to do. I have clients waiting for drawings and can’t put them off any longer. Am exporting Jpgs for now and stitching together into PDFs but the quality is poor and its just not a great alternative. Any help much appreciated.

Thanks

Sam


#13

I have just completely uninstalled and then reinstalled 2018 but its still not playing ball. I have however found a temporary work around from an older thread on a similar issue. If I go to

File>Print> and select Adobe PDF as the printer then the PDF will export. However I don’t get any of the controls that are shown in the File>Export>PDF option, I have to select the page size for each document and the export takes longer.

Any help or advice on how to reinstate File>Export>PDF very much appreciated. I’m not sure what else to do as my drivers are up to date and the MSI I installed from was set to ‘run as administrator’.

Thanks

Sam


#14

Does anyone have any pointers on this issue? Would really like to find a solution but am stuck for what to try next.
Thanks
Sam


#15

Sad to report that this only seemed to fix it. Some models export fine, others return the PDF error. I think it has to do with the complexity of the SKU model, namely the dimension strings. It seems as if Layout 2018 is not coping with my SKU based dimensions. I always use SKU for dim’s as it’s way more accurate and faster than Layout, so this is one I dearly want resolved.

I have an emergency “plan z” workaround, namely using the print function in Layout, and choosing to “print to PDF” which is great for looks, but the files are no where near as honed and compact as the “high” quality output setting in Layout. I could spend a couple hrs tweaking in the PDF output settings, but I was sure hoping for a fix in Layout 2018.

The quest continues, as does the frustration.

So, being a tweaker, I tried layering a non dimensioned copy of the floorplan in both raster and again in hybrid for nice wall lines under a vector rendered dimensions layer only copy of the floorplan to no avail. It hiccuped it every time.

If anyone’s got a fix, I’d love to know it. Is this a Win 7 issue, or what? I’m running an Nvidia GeForce… could that be the problem? Not techie enough to make headway yet. Any input appreciated.


#16

Im on win 10 and am getting the error even with a totally blank layout doc - the template I’m using is one of the std templates that you get when you install LO / SU and I haven’t put an su model into it. I just go to export pdf and get the error msg I show a screen grab of above.

Personally I do 99.9% of my dimensions in LO - it gets too cluttered in SU and is just not presentable IMHO, but each to their own. Having tested in a blank doc I’m very doubtful that the issue is related to dimensions in SU but perhaps someone can shed some light on this.

The print to pdf is a work around but is not ideal - it’s strange that the error just popped up one day in su 2017 and still persists despite a full uninstall and reinstall (as admin). Anyone there from Trimble? @trent, @Marc? Throw me a bone will ya? :thinking:


Layout 2018 can't export PDF error "There was a problem exporting to this file"
#17

Is this a bug or have I done something wrong? I’d really like to fix this or at least find out if its something that Trimble are trying to resolve. I haven’t been able to export as PDF in the usual way since December 2017 (same goes for @chaz_plan and @ArtWorksI guess) and while there is a work around its not the prefered method of export.
Any help very much appreciated…


#18

Very sad to say Layout and Sketchup 2018 are on the fritz this week. Simple rotate and copy within a 5" circle with 18 facets crashed it every single time. Never had this issue once in 2016. It would run the array fine if not within the confines of the circle, so it seems it was trying to reconcile the intersecting geometry and couldn’t. Strange. Making gears, spokes etc require this for smooth workflow at times.

The other very persistent and hard to live with glitch is paste in place crashing it if I try pasting in place into components, which is a quick way I’ve populated components in a model where, say, a client just needed a different shade on a lamp–just place it where it goes on a single instance of the old one and copy/paste it into place with the component open. Alas, this is frying Sketchup’s mind lately, again never had once such crash in 2016.

Layout’s consistently not liking to export sketchup models with Sketchup native dimension strings at times. It depends on the model–some it handles several such dim strings, others it won’t export a PDF if the model’s got even one dim string in it. Weird.

And worse, now it’s taking 10 min at a whack to do even basic move/copy functions with a mere 20 meg model that runs great in Sketchup. It does us Flextools window and door components–has anyone reported issues with those in Layout? They’ve been running wonderfully for me far as I know.

Any advice would be appreciated. I just tried run install fix as admin and Layout’s as recalcitrant as ever.


#19

I haven’t heard anything like you describe here. Today I did two sets of furniture plans from start to finish in LayOut 2018 including PDF exports on my PC with no problems whatsoever. I’m not using Flextools so perhaps that has something to do with it.

Are you really using Windows XP as your profile indicates? If so, that might be the problem. SketchUp and LayOut haven’t supported XP for a few versions.


#20

Thanks for the reply. It has to be something inherently goofy in my set up,
as so many report no issues. I know Justin from Sketchup Essentials has
encountered crashes with rotate and copy–he’s always warning followers
save before trying it, so I must not be alone. To correct my profile–Win 7
Ultimate is actually what Windows edition I’ve been running. Just updated
the drivers on my Nvidia. Been running (and thoroughly enjoying) Enscape’s
latest update edition. They added materials editing for Sketchup users. Was
thinking maybe the updated Enscape tweaked some registry stuff, or
something in the Open GL, but even after a fixit as admin, no change. SKU
and Layout both booted up faster after housecleaning, which is great. I’d
loaded Fusion 360 to learn for modelling mechanical items quickly, but
uninstalled it just in case it’d be behind the sudden glitch-fest. No
difference noticed though. Either way, I’m seriously ready to upgrade
Windows regardless. Any recommendations?

I might try “bombing” the flex tools dynamic components on a one-off of my
model to see if that resolves it. I did recently upgrade Flex tools, so
perhaps that’s behind it. Any other flextools users out there? Fastest
parametric window plug-in I’ve found. Sure hope that’s not the culprit.
Hate to be without it.


Layout 2018 can't export PDF error "There was a problem exporting to this file"