2020 Layout Issues - Can't export PDF

Just recently had trouble exporting PDF’s from Layout 2020. It’s worked fine since I installed it in January up until a few weeks ago…Tried repairing, but got stopped at the inability to save a .msi file. What do I need to do to make Layout work properly again? Will uninstalling and reinstalling help? Thanks!

What do you have in the LO file? We’ve seen reports of certain components from the 3D Warehouse causing problems as well as certain text fonts. Can you share the LO file so we can examine it and see if it’s something related to one of those things?

Jones Barn 4-19-20.layout (10.2 MB)

If there is a problem extracting the MSI file from the regular SketchUp installer, you could try the MSI version instead:

https://www.sketchup.com/sketchup/2020/SketchUpPro-msi

OK. Looking at your file now. So far I’ve figured out there’s a problem on page 6. All the other pages export fine. So now to find the problem child. I think it’s something to do with the model viewport.

More to report. The problem is related to the dimensions on Page 6. If I delete the ones shown selected below the page exports as expected but I can’t find any one dimension to be the culprit.

I’ll keep looking but I wonder if @trent or someone might be able to look at it. Of course it’s Friday so they may be done for the week.

It might be that deleting the dimensions and putting them in would take care of it.

Edit: I did end up deleting those dimensions and replacing them with new ones and it exported the page just fine. in fact it exported the whole document just fine.

FWIW, I did a little clean up of your model. Purged unused stuff.
Screenshot - 4_24_2020 , 4_47_37 PM

Notice there are still a lot of styles in your model. Based on your LO document you could get by with 3 or 4 or at the most.

And then ran CleanUp3
Screenshot - 4_24_2020 , 4_47_56 PM

Thank you Dave for helping me troubleshoot this! Cheers

1 Like

I hope you got it all sorted. By the way, I was looking at your file some more as I was curious about the file size. I discovered your logo is created as a SketchUp model and for the way you are using it, it’s huge with a lot of unneeded stuff in it. For example, the In Model styles is full of unused styles.

I purged all but the one in use. I also purged a bunch of unused components and materials.
Screenshot - 4_24_2020 , 10_54_34 PM

I found more stuff that was hidden and removed it as well. Cleaning up the logo model reduced the file size by better than 3Mb. Then in LO, I rendered it as vector, exploded it, and purged that .skp from the file which reduced it about another Meg.
Jones Barn 4-19-20 cleaned.layout (6.1 MB)

How about fonts?

I thought about the font when I figured out deleting the dimensions fixed the problem but didn’t find any dimensions using a problematic font.

Sorry to revive this, but just so everyone knows this is a bug in LO. It is random for me, but it is in fact a dimension issue that causes the error as Dave stated above. Duane Addy and I also are experiencing this with different files. We’ve sent this issue directly to the team in hopes they can isolate the issue and fix it. If you have multiple pages it can be a bear to track down the offending dimension, especially on a completed set of CD’s. Let’s hope this goes away soon with the next update.

If you happen to still have 2019 loaded on your machine you can save as to 2019 version and it will export the pdf. That is what I do for now when I run into this error.

1 Like

Same here, Nick. I have been Dr. Frankensteining my model and LayOut files to try to find the miscreant, but am at a loss. I ended up printing out of LayOut rather than exporting, but looking forward for this bug to get squashed soon.

1 Like

Hi Nick

Having recently switch to Windows PC, I have just experienced this problem too.

I have a Layout file with three pages, and none of them Export. Layout reports an error everytime on all three pages.

I found that when I Released the Clipping Masks, it worked fine. The downside is that I need the Clipping Masks, so this is not a solution for me. Deleting all the Dimensions made no difference.

I can Print to Adobe PDF, but the alignment is slightly off with the Sections Hatches for 3D Views of Sections, (I use Skalp for Sections). Exporting the PDF from Layout is fine in this respect.

I really hope they fix this soon as, at the moment, I am enjoying Sketchup and Layout on the PC.

Mike

Hi All
I have recently experienced the same issue when trying to export to LO. Having tried a bunch of things suggested here I had an inkling that it was a recent Windows update that was at the root of the problem. So, I restored to before the update and hey presto normal LO to PDF exporting resumed! If you can identify the date when you started having the problem with the Win Update History it’s definitely worth uninstalling the update. Hope this helps.

1 Like

Hi Mike, I just had the same thing happen on a file with clipping masks and no dimensions. Oddly enough I closed the file and reopened and it worked fine.

Blu Beam is an excellent pdf program that every architect should have. Anytime I’ve had this issue come up I print to Blu Beam and it never fails.

Hi Nick

My work around at the moment is to not use Clipping Masks if I don’t need to. I can just use a shape filled with white and no border to hide anything I need to. If I do have to use clipping masks, I can export if they are set to Raster, which for the times I do, should not be a problem. Not ideal, but acceptable for the time being.

I can print to Adobe Acrobat with Clipping Masks although it does throw off the Skalp alignment slightly if printing a Perspective section.

I’ve briefly tired Bluebeam before, but might have to look into it again.

Still, fingers crossed it gets sorted soon.

Mike

I use clipping masks only when the viewport has to be non-rectangular which is seldom. Otherwise I just crop the view with regular viewport borders, checking the “Preserve scale on Resize” box