Layout export to PDF error

Hi there.
Not sure what the issue I’m having is, I’ve never experienced this problem before.
When I go to export the layout file to a pdf, it says there’s a problem, and it doesn’t export.
Thoughts?

Cahill Guest Bath Towel Niche 8.26.2020.layout (5.1 MB) Guest Bath Niche 8.26.2020b.skp (4.8 MB)

I haven’t figured out what exactly is the problem, yet but I see the same problem exporting in LO2020.2. Are you using 2020 or still 2018 as indicated in your profile?

I don’t know why but the problem is caused by the two viewports on the left being rendered as Hybrid. I changed them to Vector and the PDF exports fine. Thinking it might have something to do with either the toilet component or the textures I deleted those in the SU model and tested the export. It still indicated a problem.

Maybe @adam will have some time to take a look.

Thanks for looking at this, Dave.

I’m using 2020 (20.1.235 64 bit to be exact).

The tile material and the toilet component were imported from SU Podium. Interesting that tweaking with the rendering type yielded positive results.

I’ll do some tweaking to explore this more.

Still would love to have a concrete solution, so if anyone else has any thoughts, please share.

Be well!

You might go ahead and update to 2020.2 to stay current.

I tried removing all the materials and the toilet, separately and together but no joy. I did not try to explode the nests in the model although I doubt that has anything to do with it. I might try a little more when I get time but since @adam is on the LO team, he probably has access to tools I don’t that might help pin point the problem.

Nice work by the way. Wish I’d known. I was in your neck of the woods almost a year ago. Could have dropped in on you.

Hello,

I took a quick look at this file, and it seems to export without problems on mac. It seems like the library we use on Windows to export to pdf is getting tripped up for some reason. Thank you for sharing your file so that we can test potential fixes to this problem. Unfortunately I cannot give an estimate on when this issue will be resolved.

Sorry for the inconvenience,
Adam

2 Likes

Hi there.
Dave, thanks for the attempt to help, much appreciated.
SketchUp folk, this is a strange problem that needs some attention, please.
I have modeled this from scratch three times now in an attempt to resolve the problem. I thought perhaps it was a problem with a material or the toilet component, and the problem persists.
The most recent file attempts are attached.
Please help!

Cahill Guest Bath Niche 8.31.2020.layout (881.2 KB) Cahill Guest Bath Niche 8.31.2020.skp (195.5 KB)

I didn’t look at your LO file but I downloaded your .skp file and made a quickie LO file from it. I didn’t have any trouble with the export to PDF. The files are below.

I did make a couple of changes to the .skp file but they should have any impact on this. I moved the yellow material on the studs from the instances to the faces, reduced the FOV slightly and changed the camera position for the “Modeling” scene.

I added a few dimensions just add something else to the LO document, too.
Cahill Gues Bath Niche.layout (173.4 KB) Niche.pdf (14.3 KB)

@adam any ideas as to why I have no problem creating the a LayOut file that successfully exports? Is this possibly an installation thing?

@sayerdesign, this is a long shot but until we hear something else, maybe try repairing the installation of SketchUp/LayOut. It won’t hurt anything, at least. First make sure both SketchUp and LayOut are closed. Find the downloaded installer, right click on it, and choose Run as administrator. If you are presented with options to uninstall or repair, choose Repair. If you don’t have the latest installer, go to sketchup.com/download/all and get 2020.2 to install. That one shouldn’t give you the repair option if you are updating from 2020.1.

p.s. please update your forum profile. It still shows 2018. :wink:

I was wondering if it would be fixed by 2020.2, but his file goes wrong in 2020.2 as well.

Interesting thing, it only fails in his version of the inserted model, and only if it is set to hybrid. Deleting the existing viewports in his LayOut file, and inserting his model, even set to hybrid, does not fail.

But wait, there’s more… If I copy the existing inserted model into a new LayOut file, I get the same problem. If I delete all existing geometry and material, and attributes (it has Medeek things in there), purge unused until the model is down to four edges and one face, and the export still fails.

Running out of things to try.

Yes. I saw that when I was working with it last week. Otherwise I would have suggested more insistently updating to 2020.2.

Got close to the answer. It’s failing in hybrid because it has a clipping mask. Now checking to see if there are particular settings, or if all clipping masks will show the error when set to hybrid and exporting to PDF.

Mine doesn’t fail with Hybrid rendering.

Thanks again for the help.
I updated my profile, Dave.
And I also ran the install/repair per your suggestion earlier, no change in results.
I have been working with other files today and there haven’t been any issues exporting.
I have no idea what this is about.
I’m happy to provide any other info people may want and/or connect over goto meeting or something if folk in the know want to see my system for themselves.

1 Like

Hi all, yes this does appear to be a result of the clipping mask, this is most likely why Dave was not seeing the crash with Hybrid exporting a file he made from scratch. Because of the way we render the 3D model to 2D linework, LayOut can at times experience problems when rendering. Exporting to pdf is one of those cases.

To fix your file do the following.

  1. Select the left most SketchUp viewport, rt click and select ‘Release Clipping Mask’
  2. Deselect all
  3. Select the SketchUp viewport
  4. From the SketchUp Model inspector, select ‘Preserve Scale on Resize’ from the Camera tab
  5. Scale the viewport by pulling the edges of the viewport to the rectangle used for clipping
  6. Delete the rectangle you had used for clipping.

you should be good.

Sorry for the inconvenience.
Trent

Hi @trent

Just to add that I am also experiencing the problem.

  1. If I released all the Clipping Masks it worked in Hybrid, although of no use as I need the Viewports to be Clipped.
  2. Tried making the viewports larger than the Clipping Masks. Did not work.
  3. Changed all the Viewports to Raster, with the Clipped Masks in place and active. Worked, but the quality is not what I need.

So, it does appear to be a problem with Clipping Masks and Hybrid, which is a proverbial pain in the you know what, as I use them alot :wink: Many of the Clipping Masks I use are not straightforward rectangles.

I’ve attached a Dropbox Link to one of my Layout files.

It would be good to know when this will be fixed.

Kind regards

Mike

I agree Mike. I use clipping masks for elevations (both interior and exterior) and sections which have multiple points and are never a simple square.

Same goes for split level designs that require splicing two different views to maintain a section cut at an appropriate height above the respective floor level.

This absolutely needs to be addressed.

2 Likes

Hi there,

Has this issue been resolved?? Please let me know as its not working.

Thanks

@adam @DaveR any suggestions/updates to this error? Thanks

What version of SketchUp/LayOut are you using? Please complete your profile. If you are no longer using Windows 7 and the graphics card listed in your profile, update that information, too.

Your screen shot appears to show that you are trying to insert a PDF file into LayOut on a PC. That’s not a supported file type on Windows machines. Only Macs currently support inserting PDFs. This is also different than the export error referred to by the OP of this thread.

The supported insertable file types for LayOut on Windows are shown below.
Screenshot - 2_4_2021 , 12_30_30 PM

1 Like

Sorry to jump in on a thread but I have been having the same issues. After doing a lot of head scratching the error only appears when I try and export a hybrid file with a clipping mask. As soon as I lose the clipping it works fine. I have tried to use Raster but I lose so much quality. Anyone else have any ideas?

I am not sure but I think that the clipping mask problem was fixed in version 2021.