Issue exporting pdf from Layout

Hello there,

As the title suggests, I am encountering a problem when trying to export pdf from a Layout file. On export I get the generic “There was a problem…” pop up, which is not the most helpful in terms of assisting in identifying the problem!

After turning things on and off and trying test exports, I found the culprit to be 3 viewports in which I use clipping masks.

The clipping masks are needed, can anyone please provide some guidance on how to achieve a pdf export with problematic clipping masks in place?

I have thought of a possible solution as I am writing this, getting rid of the clipping masks and using white fills to block out what the clipping masks are covering. I have stepped away from the laptop to get a breather (Not being able to produce something that the programme is practically made for is rather frustrating) and will give my own solution a go later today BUT if anyone else has experienced this issue themselves or has another possible solution, I’d be glad to hear from you.

Many thanks


Are you still using SU/LO2020 as your profile indicates?

This clipping mask was a problem in 2020 although it has been fixed in 2021. I did have some success in 2020 in getting around it by making a new viewport and clipping mask and getting rid of the old.

1 Like

It has been discussed before. Are you using the latest maintenance release of v.2020? Have you tried if the problem persists with version 2021? I am not quite sure if something was fixed in the latest releases.

1 Like

Yes, I am still using the latest version of SU/LO 2020. I am yet to transfer over to 2021 (although I may do it sooner than later is the LO performance is better).

I tried what I theorised in my original post by releasing the mask and just manually blocking out what I wanted masked and it worked just fine.

Thanks for posting

1 Like