SketchUp Layout 2020 PDF Export Issues

Since my company upgraded to Layout 2020 we have had issues exporting PDF files from Layout. Around half of the layout files we make have this issue. At this point we have to save all of the files we want exported down to 2019 and have to open and export them in 2019. Don’t know if anyone else has had this issue and how we can fix it. I probably am missing something really obvious. Any thoughts?

It would be helpful if you describe the issue and if possible show us what you are seeing. so far you’ve only indicated there’s an issue. It would also help if you shared a LayOut file that exhibits this issue so we can see if we get the same result.

Here’s a drive link with a video of the issue and the files.

https://drive.google.com/drive/folders/1jpdjtOilfAWUGEAZkPrEL3gfExxcLKTU?usp=sharing

I don’t know why it is but it is the clipping masks that are preventing the successful PDF export. I use clipping masks frequently in LO 2020 and have no problem so I don’t know why your cause the problem.

Actually there’s no need for the clipping masks in your document. I was able to create the views of the SU model easily enough by simply dragging the edges of the viewports.

Here’s what it looks like in LO after I eliminiated the clipping masks and moved the edges of the viewports.

And in Adobe Reader.

FWIW, you might want to do some editing and deal with the overlapping logos. And since the LO file contains some client info and other information you might not want to have out there in the wild.

Thanks Dave! It worked. Really appreciate the help.

1 Like

Glad that helped. It would be nice to know why your clipping masks caused a failure in the PDF export while once I create don’t but at least you can keep moving ahead.

I use clipping masks all the time. We’ve been discussing the export issue and it appears to be dimensions that can cause the problem

The dimensions were my first thought, too. I’ve see this issue with them. I tried deleting the dimensions straightaway in this file but it still wouldn’t export to PDF. I also looked at images in the file because I’ve seen problem. It wasn’t until I released the clipping masks that I was able to get the export to go successfully. Very odd and something I’ve never run into before.