Layout 2018 can't export PDF error "There was a problem exporting to this file"

export

#21

The best suggestion so far comes from Charlie_v. Some Windows process is taking possession of your files or folders. It might be a security software issue, a network issue if you are writing to a network drive, If your harddisk is filling up you should see it in other ways too. Has exporting with a very simple filename directly on your desktop already been suggested? Do your user, file or folder names contain non.ASCII characters, especially "forbidden"ones?


#22

Im having the same issue and Im using 2016 Pro …unsure what the issue is but i like to find out please Trimble !!


#23

Hello,
I just got the Windows 10 update & no change. I Still cannot export to PDF. But I did notice that other dialog boxes flash up before the final “There was a problem” one.
I have uploaded the jpg’s of these dialogues.
Does anyone see any logic in whats happening & why
Dave

4-There%20was%20a%20problem
3-PDF%20export
2-PDF%20export
1-export%20options


#24

I’ve just updated my windows 10 software and now I can’t export to PDF from Layout either. I can print, which doesn’t have the same quality. Any fixes for this yet?


#25

Hi Anssi,

I have tried all of the options listed in your post but still no dice. I can’t even export a completely blank PDF file created with a standard un-edited LO template (the ones that are built in to the install) with a simple name eg. ‘test.pdf’ - no ASCII / forbidden characters. My test files have had nothing in it, its totally blank A4 page and I am exporting to my desktop so no network / security issues.

I’ve completely uniinstalled and re-installed twice and have scoured the web and tried several other suggestions but to no avail.

It only seems to be impacting a few users but it’s very frustrating :rage: that having paid for Pro there is no support for this issue. I’m on Pro too @ValinHawK and am fully up to date with drivers and OS. I raised a ticket but haven’t really had much help with it and just gave up in the end…

Come on Sketchup Team - throw us a bone here…


#26

Just for general information … LayOut 15 … 17 use PDFlib GmbH a commercial library.
The version used by these LayOut versions is 9.0.2.0. (For reference, 8 … 14 used ver 7.0.3.)

Visiting the https://www.pdflib.com/ website the first thing we see is that the current release version is 9.1.2


Are all the users here having problems running Windows 10 ?


#27

I recently spoke with a PC service engineer about this issue. He was quite sure the problem would be a Windows 10 registry problem. His suggestion was to format my main drive & reinstall the PC from scratch. So I will be using printing to pdf for a while yet.
I did use a Norton Utilities cleanup program about the time the pdf export stopped working. I guessing that it could probably was the original cause.


#28

Ok, so now its not allowing me to export PDFs on either of my two system! I just got into work and went to export a PDF and am now getting the same error message on both systems! There was a windows update that ran on Friday and the issue has only started occurring on my office system since then - before Friday the PDF export error only occurred on my home system.

This is SO frustrating - people have been posting about this issue for in excess of 6 months and so far there has been nothing useful from the SU team in terms of resolving it. From what I understand from this thread and other threads, every support ticket has been closed with no resolution offered.

This is POOR customer service / technical support to say the least…

Come on SU team, pull your bloody finger out and help your paid users to be able to easily export a PDF of the documents that we work hard creating. While the ‘Print PDF’ function is a work around, its far more click intensive and the settings are not retained for each document / session - it’s just not a suitable work around and I for one was not expecting to have to use it for 6 months with no news from Trimble that you are looking to resolve this issue.

Does the PDFlib version issue that @DanRathbun highlighted have any bearing on the problem - thanks for highlighting this Dan? @DanRathbun, Im a windows 10 user with two systems - one at home and one at office. Until today (:rage:) I had one system worked fine (Office one) and the other had an issue exporting to PDF - now both systems have the issue.

@dmyimcuk, I don’t doubt your PC engineer friend but I sincerely hope that I won’t need to format my main drive and run a full reinstall - that seems pretty extreme! FYI (if Trimble are actually there and paying any attention to this whatsoever) I have norton on one system and Avast on another but haven’t run any kind of clean up in a while. I did have a windows update run on Friday and now have this issue on both systems.

What else to we need to do as users to get some help resolving this!!! Over the past 6 months I’ve contributed to at least 3no separate threads on this issue, I’ve scoured the web looking for solutions and have tried all the ones that are relevant to me and I’ve raised support tickets and have got diddly squat back! Come on Trimble…


#29

I would think that the latest version of PDFlib was released before the most recent Win10 update.
So I cannot say, and have not seen the release notes for the latest version. Perhaps they have a forum or a contact that could be asked ?

Win10 updates have been reeking havoc with mouse speed and power management settings that interfere with applications. (I am not looking forward to having a new computer with Win10. Seriously considering downgrade to Win7.)

It is (extreme) and it does not make any sense.

I would first try creating a new test user account (which will create a new default user hive in the registry.) Then log onto this new “test” account, and try printing to PDF from this account.

Just make sure beforehand to put a test SKP in the Public documents folder so the new account can access it.


#30

@samyell I got your Support ticket and I’ve submitted a bug report for this recently as well. Three people contacted us at once saying that after a recent Windows Update, suddenly they can’t Export > PDF anymore. The bug number is LO-12866, if you’d like to reference it at any other time.

I’m being told to ask for some information from whoever has been affected by this:

  1. Does reinstalling SketchUp (which reinstalls Layout) help?

  2. If you try to save the PDF to your desktop, does it make a difference?

  3. Can you try running CheckUp and send me the results? Either from a Help ticket or in a private message on the forum. So far the 2 people who ran CheckUp had really strange results - the computer wouldn’t allow CheckUp to run completely, which makes me think this may be some kind of security release by Windows that is hampering permissions somehow. We’ve only had systems documentation from 2 people so far, though. Having your CheckUp results would be super helpful. A screenshot of the user interface results would be helpful, too. Please visit help.sketchup.com/en/sucheck for this tool. Please download and run Checkup.exe and send us the log file, “SketchUpLog.sulog”, created on your desktop.

  4. Could you (or anyone else) post which Windows Update happened right before this issue started? It would help us figure out what is causing this if we knew exactly what update was causing it.

Thank you for helping us help you (and others).


#31

Hi Katya,

REALLY GREAT to hear something from the SU team on this! Results from my tests are as follows:

  1. No - same issue having reinstalled twice on one system. Haven’t reinstalled on the second system that the issue has recently (in the last 2 days) materialised on. Issue first occurred on system 1 back in December 2017.

  2. No, same result no matter where you save. Have opened a blank file from a built in (part of SU Pro Install) LO template and exported a totally blank doc to my desktop / documents with a simple name (eg TEST.pdf) but same error.

  3. Error message saying access denied - see below. Report also uploaded…

2018-06-12_2218SketchUpLog.sulog (3.9 KB)

SketchUpLog.sulog (3.9 KB)

  1. Error first occurred on system 1 (Windows Bootcamp partition on macbook pro, see image System 01 Spec) in late December or very early Jan 2017.

System_01_Spec

Will upload spec for system 02 tomorrow.

Very much looking forward to hearing some news on this. Its been an issue for me, and others for a long time now so would be great to get it resolved. As I (and others) mentioned the print PDF is a work around but far from ideal as no settings are saved.

Thanks

Sam


#32

Hi Sam, thanks so much for running that. 3 out of 3 users with this LO > Export > PDF issue also couldn’t run CheckUp, which I’ve never seen before, so that’s beyond the coincidence stage into the “significant” stage. Somehow that access issue is connected to the PDF saving issue. My gut tells me there was a security update that is interfering with permissions for some users.

I couldn’t actually open the .sulog, there was an encoding error for me, which might be another clue.

Any chance on you being able to find out which specific Windows updates were installed right before things went awry?

Also, one of our engineers asked this:

Could you ask the customers to provide the output to the following commands (run them in a Command Prompt window)

systeminfo | findstr /B /C:“OS Name” /C:“OS Version”
wmic qfe get description,installedOn /format:csv


#33

Also, did you install SketchUp as an administrator?


#34

… and what happens if you right-click Checkup.exe and choose “Run as administrator” ?


#35

Answers to Katya questions

  1. Reinstall SU does no make a difference
  2. Saving to the desktop fails
  3. Checkup fails – see attached JPG & *.sulog
  4. Last time the export worked was around 17 November 2017
  5. The output to the following commands (run them in a Command Prompt window) jpg attached
    SketchUpLog.sulog (4.2 KB)

command%20prompt%20request


#36

C:\Users\Sam Morris>systeminfo | findstr /B /C:“OS Name” /C:“OS Version”
OS Name: Microsoft Windows 10 Pro
OS Version: 10.0.17134 N/A Build 17134

C:\Users\Sam Morris>


#37

Node,Description,InstalledOn
SAMMORRIS,Security Update,6/8/2018
SAMMORRIS,Update,6/8/2018

C:\Users\Sam Morris>


#38

@Katya, my command prompt reports from my system 2 machine are above - I’ll run this on my system 1 when I get home. Also I’ve attached the sketchuplog.sulog for system 2 (my office laptop).

SketchUpLog.sulog (3.2 KB)

and the spec for my system 2 is below

System_2_spec

I installed Sketchup on both systems as admin.

I’m afraid I can’t be any more definite about dates for the issue occurring on system 1 than saying that it was mid Nov to mid Jan. On system 2 it started to occur on monday 11th June 2018.

@DanRathbun - I installed checkup.exe as admin and ran as admin but got the same errors (only run checkup.exe as admin on system 2 not system 1 so far).


#39

I found this topic as I too have the same issue. I exported with no issue about two weeks ago, which thereafter I believe I had a windows update. Now I cannot export.


#40

Those “cleanup” programs have given me a lot of issues in the past. I quit using them 15 years ago.