Layout 2018 upgrade install and export issues


I just encountered an error exporting to PDF on a floorplan design. Thought it was corrupted file or bad link as this was the only model and layout producing this error. So, I copied the elements page by page to a new file as standard procedure to debug a corrupted layout file. Removed and purged any 2016 version scrapbook items to check for that being an issue. Didn’t help. Here’s what fixed it: I went sheet by sheet, and found the offending sheet. On a hunch, I tried changing render mode of my floorplan (with wiring done in dashed lines via Layout 2018) from Hybrid to just Raster. Bam. That resolved it. So now I know: a mild mannered model in Hybrid with markup in Layout can cause it to return an error exporting PDF. Easy fix (workaround), but honestly, not satisfactory in view of potentially grainy output if the end user tries to scale it up.

For what it’s worth, I saved a backwardly compatible copy as 2016 Layout, and got the same results. So, whatever it is about my model and hybrid, they don’t get along regardless of the version.

I suggest trying this debug on yours, simply because it’s easy, and it worked for my problem. All the other 2016 files I have tried have converted to 2018 ok, no hybrid render problems yet but the list sure isn’t exhaustive as of this post. At least I know to watch for it. Hopefully if debugging’s moving forward, this will be addressed before the next upgrade to Sketchup. All in all, loving the new features in 2018 so far. Improved inferencine and render engine are nice. I do get a lot more bug splats with 2018 than 2016 though. I’m a compulsive “save that file every change you make” person, but it still gets me and wastes some time.

Does anyone know if any particular extensions have been tagged for causing this PDF output issue? You could try disabling all your extensions, and trying your PDF export. If it goes off without a hitch, start enabling them one at a time to find the offender.

For what it’s worth, I had a model do this once in SKU 2015, refusing to output PDF thanks to hybrid selected as rendering option. Going Raster fixed it right away.

BTW, I’m running XP Pro, and a generic PDF program, Foxit PDF which has done great with all prior iterations of Sketchup and Layout.

Really? Still Windows XP?

Maybe you should see this: SketchUp Hardware and Software Requirements | SketchUp Help

It could be a combination of unsupported Operating system and possibly outdated graphics drivers.

My bad, I’m running Windows 7 ultimate, not XP. That said, if you’re
telling me the key to getting my hybrid render setting to export PDF’s is
likely my older Windows version, I would definitely consider the upgrade. I
just hate how Windows tends to just bloat to consume the resources
available to it in each new edition, so running the older version kept
system was to reduce learning curve and keep footprint lighter. Still, if
10’s not a pain, and given the 3D type updates MS has been working in, it
may just be time to bite the digital bullet and upgrade. Any caveats you
know of to steer me right? Thanks for the feedback. Always learn from and
enjoy your comments. Also, if you’re clocking fewer bugsplats with newer
Windows, that’d about clinch it for me. I’ve had a plethora of them with
2018 so far.

The first thing I’d do then is make sure you installed SketchUp correctly by right clicking on the installer file and choosing Run as administrator. Then choose the Repair option. Next, make sure the graphics drivers are up to date.

I was reluctant at first to go to Windows 10 Pro but one morning when I got to my computer I found that Microsoft had installed it without my permission. It hasn’t caused me any problems since then. Evidently some users of Windows 10 not pro have had difficulty when Microsoft pushes software updates because the updates reset the on-board Intel graphics as default. If it happens you just need to go back and make the Nvidia the default for SketchUp and LayOut.

Ah yes. Those sorts of things are the other reason I’ve avoided Win 10.
"Resistance is futile, you will be updated."
I’ll look into the fix option. It’s proving a consistent glitch refusing to
export hybrid render items. Thanks.

1 Like

Dave, are the man. The “fix” mode of the installer seems to have resolved
it. Whew. Still wondering how on earth I had a glitched install first go
round, but nonetheless, hybrid render setting is back in action. Many

1 Like

I had this issue with 2017 so installed 2018. Am getting the same issue and have tried the steps above. I installed as admin. I had a PreBootstrapper error and installed using the steps in this post -

This allowed me to install. However I’m now getting an error whenever I try to export (same one I had in 2017)

I’ve tried doing a blank PDF with a short name saved to the desktop but still no dice! Does anyone have any suggestions. Checked my graphics driver which is up to date - am at a loss for what to do. I have clients waiting for drawings and can’t put them off any longer. Am exporting Jpgs for now and stitching together into PDFs but the quality is poor and its just not a great alternative. Any help much appreciated.



I have just completely uninstalled and then reinstalled 2018 but its still not playing ball. I have however found a temporary work around from an older thread on a similar issue. If I go to

File>Print> and select Adobe PDF as the printer then the PDF will export. However I don’t get any of the controls that are shown in the File>Export>PDF option, I have to select the page size for each document and the export takes longer.

Any help or advice on how to reinstate File>Export>PDF very much appreciated. I’m not sure what else to do as my drivers are up to date and the MSI I installed from was set to ‘run as administrator’.



Does anyone have any pointers on this issue? Would really like to find a solution but am stuck for what to try next.

Sad to report that this only seemed to fix it. Some models export fine, others return the PDF error. I think it has to do with the complexity of the SKU model, namely the dimension strings. It seems as if Layout 2018 is not coping with my SKU based dimensions. I always use SKU for dim’s as it’s way more accurate and faster than Layout, so this is one I dearly want resolved.

I have an emergency “plan z” workaround, namely using the print function in Layout, and choosing to “print to PDF” which is great for looks, but the files are no where near as honed and compact as the “high” quality output setting in Layout. I could spend a couple hrs tweaking in the PDF output settings, but I was sure hoping for a fix in Layout 2018.

The quest continues, as does the frustration.

So, being a tweaker, I tried layering a non dimensioned copy of the floorplan in both raster and again in hybrid for nice wall lines under a vector rendered dimensions layer only copy of the floorplan to no avail. It hiccuped it every time.

If anyone’s got a fix, I’d love to know it. Is this a Win 7 issue, or what? I’m running an Nvidia GeForce… could that be the problem? Not techie enough to make headway yet. Any input appreciated.

Im on win 10 and am getting the error even with a totally blank layout doc - the template I’m using is one of the std templates that you get when you install LO / SU and I haven’t put an su model into it. I just go to export pdf and get the error msg I show a screen grab of above.

Personally I do 99.9% of my dimensions in LO - it gets too cluttered in SU and is just not presentable IMHO, but each to their own. Having tested in a blank doc I’m very doubtful that the issue is related to dimensions in SU but perhaps someone can shed some light on this.

The print to pdf is a work around but is not ideal - it’s strange that the error just popped up one day in su 2017 and still persists despite a full uninstall and reinstall (as admin). Anyone there from Trimble? @trent, @Marc? Throw me a bone will ya? :thinking:

Is this a bug or have I done something wrong? I’d really like to fix this or at least find out if its something that Trimble are trying to resolve. I haven’t been able to export as PDF in the usual way since December 2017 (same goes for @chaz_plan and @ArtWorksI guess) and while there is a work around its not the prefered method of export.
Any help very much appreciated…

Very sad to say Layout and Sketchup 2018 are on the fritz this week. Simple rotate and copy within a 5" circle with 18 facets crashed it every single time. Never had this issue once in 2016. It would run the array fine if not within the confines of the circle, so it seems it was trying to reconcile the intersecting geometry and couldn’t. Strange. Making gears, spokes etc require this for smooth workflow at times.

The other very persistent and hard to live with glitch is paste in place crashing it if I try pasting in place into components, which is a quick way I’ve populated components in a model where, say, a client just needed a different shade on a lamp–just place it where it goes on a single instance of the old one and copy/paste it into place with the component open. Alas, this is frying Sketchup’s mind lately, again never had once such crash in 2016.

Layout’s consistently not liking to export sketchup models with Sketchup native dimension strings at times. It depends on the model–some it handles several such dim strings, others it won’t export a PDF if the model’s got even one dim string in it. Weird.

And worse, now it’s taking 10 min at a whack to do even basic move/copy functions with a mere 20 meg model that runs great in Sketchup. It does us Flextools window and door components–has anyone reported issues with those in Layout? They’ve been running wonderfully for me far as I know.

Any advice would be appreciated. I just tried run install fix as admin and Layout’s as recalcitrant as ever.

I haven’t heard anything like you describe here. Today I did two sets of furniture plans from start to finish in LayOut 2018 including PDF exports on my PC with no problems whatsoever. I’m not using Flextools so perhaps that has something to do with it.

Are you really using Windows XP as your profile indicates? If so, that might be the problem. SketchUp and LayOut haven’t supported XP for a few versions.

Thanks for the reply. It has to be something inherently goofy in my set up,
as so many report no issues. I know Justin from Sketchup Essentials has
encountered crashes with rotate and copy–he’s always warning followers
save before trying it, so I must not be alone. To correct my profile–Win 7
Ultimate is actually what Windows edition I’ve been running. Just updated
the drivers on my Nvidia. Been running (and thoroughly enjoying) Enscape’s
latest update edition. They added materials editing for Sketchup users. Was
thinking maybe the updated Enscape tweaked some registry stuff, or
something in the Open GL, but even after a fixit as admin, no change. SKU
and Layout both booted up faster after housecleaning, which is great. I’d
loaded Fusion 360 to learn for modelling mechanical items quickly, but
uninstalled it just in case it’d be behind the sudden glitch-fest. No
difference noticed though. Either way, I’m seriously ready to upgrade
Windows regardless. Any recommendations?

I might try “bombing” the flex tools dynamic components on a one-off of my
model to see if that resolves it. I did recently upgrade Flex tools, so
perhaps that’s behind it. Any other flextools users out there? Fastest
parametric window plug-in I’ve found. Sure hope that’s not the culprit.
Hate to be without it.

Well, I found the culprit: poly heavy shrubs that’d not given me grief
before, but 2 vs 4 of them must’ve been the tipping point for Layout’s
patience. It’s working like a champ now. I’d never had issues with Flex
Tool equipped models before, even with many such components, so this makes
sense. It was just the poly count, not the meg size. Good to know.

1 Like


I also have the same problem, at home I work with sketchup on a Windows 10 home edition and int’s ok to export to pdf. In the office I use skethup on Windows 10 Pro edition and it gives export error.
Is there a solution?

I have the same issue and have had for several months now. Same as you I have a very similar set up on a PC at work and another at home and its the home one that I have the error on. There are some solutions suggested in the posts below, have you tried them? None of them worked for me but it’s worth a shot.

@daniel.fisher seems to have run through this issue with @DaveR (in the thread below) with the SU team but it doesn’t sound like they have been able to resolve it.

I’ve been experiencing this issue since December but haven’t found a fix, am just having to use file>print>pdf at the moment which is not ideal as there is less control over the output. I’ve started my own thread here as I wasn’t sure if any of the ones above were still active or being looked at.

Hope one of the suggestions in the threads above works for you - if you find any info on this please let me know.


1 Like

Hello everyone
Thank you for all the responses, sorry I have not been around to reply but I am back now.


I have tried the above and nothing seems to work so in desperation I decided to buy a new HDD and instal a clean version of Windows 10, then install only Sketchup 2018 in the proper manner (admin etc).

This now works on my Dell Precision, BUT I have left the default PDF viewer as the microsoft version shipping with WIn 10 not altering to Adobe reader etc. This has solved the pdf issue and I have upgraded to the latest update of Windows…

I hope this helps someone else out there as I was going nuts with the conflict, I feel that something on the old HDD must have upgraded and caused a conflict my gut feeling is Adobe clashing somewhere.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.