White Screen on startup..Graphics card?


#1

Each time I start SU Make 2017 I get a blank white screen but all the tools are accessible and work. I drew a couple rectangles and hit print preview and they are there (along with Carl). When I close the print preview screen, the preview is still there and I can’t get rid of it. I’ve checked compatibility with Windows 10 and even tried installing with Windows 7 & 8 settings with the same result. I am not very computer savvy but I have noticed little graphic nuances with other programs (Photoshop, AutoCAD) that only happen every so often. Could my graphics card be bad? (Intel ® HD Graphics 2000). I have tried to update it through Windows but it said the drivers are up to date.


#2

Not “bad” per se, but out of date. I checked the Intel page on that card and it lists drivers for XP (1st indication of age) and doesn’t list drivers for Windows 10 (2nd indicator of age).

It wouldn’t surprise me if it doesn’t support OpenGL 3.0 - which is a requirement for SU 2017.

What is surprising is that you can get it to work at all!

Are you able to run the SketchUp Checker without error?


#3

Yes, I was able to run the SU Checker and there were no issues reported (Open GL requirement has been met). The weird thing is that I have used SU Make '17 on this machine as recently as last week with no issues.


#4

Well, that exhausts stuff I know about. :frowning2: Since I’ve never had graphic card related problems, I haven’t bothered to pay attention to the problems others are having (and the solutions proposed by the forum). Hopefully, someone else will chime in soon.


#5

OK. Thank you.


#6

@Archie1119 Could you post a screenshot of SU Make when it loads? Are the tool palettes visible?


#7

Here is the screen shot when it first loads.


#8

Here is another of the print preview after I drew a few shapes.

All the tools & buttons work, I am just drawing blind, basically.


#9

Thanks, @Archie1119 – I’ll dig into this.


#10

Hi @Archie1119, Intel HD 2000 (and 3000) graphics is an interesting GPU family for SketchUp. On the one hand, it supports OpenGL 3.0 which is good for SU 2017. On the other hand, it is no longer officially supported on Windows 10 which is unfortunate.

We have been able to work around this issue in SU 2017 by running in compatibility mode on Windows 10 which allows Windows 10 to use a legacy driver for this GPU. Even though this works for the time being, the lack of official support from Intel indicates that HD 2000 will continue to be a problematic GPU for any 3D application (not just SketchUp).

Could you grab your SU undo log* for one of these sessions? I’m interested to see if SketchUp is reporting OpenGL errors when you’re seeing these rendering errors.

* At c:/users/<your_user_name>/AppData/Local/Temp/SketchUp-YYYY-MM-DD-HH_MM_SS.log. Note that this file is deleted when you successfully exit SketchUp so you must make a copy of it while SU is running.


Very Slow Sketchup
#11

Let me know if this is the right file

SketchUpLog-2016-12-06-11_04_25_copy.txt (20.0 KB)
.


#12

Update: It seems to be working fine today. Not sure what happened yesterday but thank you everyone for your time and assistance.


#13

Did the problem ever reacure Archie?
I have the same problem. SU starts up fine And i can draw for hours but if i leave it alone for Some time my screen turns white. I can safe mij wrok but when i start SU again my splashscreen and wirkspace turns white.
When i shut down my PC an then start it up again SU Seems to be fine.
Very frustrating.


#14

I had a student hit “Save As Template” once when his view of the axis was a little off screen, creating a white screen effect whenever he opened up SketchUp fresh. Is there any chance you’re using a strange style or template?

Are your lines literally not visible as you draw them? If so, then… this is beyond my expertise.


#15

That problem has not reoccurred. I have since purchased SU 2017 Pro so, I am not sure if that resolved the problem or not. I do think part of it is my graphics card. It is out of date and a few of the tools get real sluggish while performing. I tried on another machine and it works fine.


#16

Since I have a brand new PC and Sketchup 2017 Pro I do not think it is a hardware issue. It all started when I touched some overclocking settings. Stupid me…
I get this message ITBM driver not present exiting application.
That driver refers to Intel Turbo boost 3.0


#17

Isn’t overclocking just the thing to do if you want to create hardware issues?


#18

Yes Anssi! Stupide me!!!


#19

I have exactly the same problem which Archie1119 reported in Dec’16, yet I have Windows 10 on a Surface Pro. Please HELP!!!

Thayer, you requested a file from Archie in Dec’16, so I thought to send you my equivalent.

SketchUpLog-2018-07-28-18_00_06.log - Copy.txt (26.2 KB)

Can you help?

I set out to solve the ‘Slow Select Tool Problem’ earlier today by updating the Display adapters driver. This appears to have worked, as It I ‘Zoom Extents’ and then click on the location where I think STACY is in the screen, the component propertied appear immediately. The only problem is that STACY is invisible.
Just as Archie reported, if I Print Preview, STACY appears on the print.

If I ‘Roll Back Driver’, all remains the same.

Regards, Mark


#20

If you disable hardware acceleration (Preferences → OpenGL → Use hardware acceleration), the drawing elements become visible or not? If so, this could be a work-around but you probably want to find a solution to the problem in order to have better performance.