SketchUp not working - blank modeling area graphics problem

Hello! I have been using the 2017 version of sketchup make for some years now, and today all of a sudden for some reason the software stopped working properly. The 3D view space for some reason now appears completely blank, evend though the rest of the tools and options work fine. I tried to run the sketchup checkup tool and in the error summary it says that my intel hd graphics card only has 1mb of memory and therefore the software cannot run properly. How do I solve this issue? Other applications that I have such as Autocad and revit dont work as well and I cannot see the modeling space either.

I have an Intel HD graphics 630 and an NVIDIA GTX 1050 GPU.

The 1 Mb thing is no big deal. It’s just CheckUp exposing a bug in the Windows application that reports information about the GPU.

While your integrated Intel graphics are not recommended for use with SketchUp, you can probably squeak by. The reason it has recently quite working is almost certainly due to broken graphics drivers pushed with a Windows update. Go directly to the Intel site and download their latest drivers for your card and install them. Also in SketchUp, go to Window>Preferences>OpenGL and turn off Use Fast Feedback.

What you really should do is set the Nvidia graphics to be used for SketchUp. Do that in the Nvidia control panel.

Be aware that the next time there a Windows update, you could find yourself back in the same position. They have a history of pushing broken drivers for integrated GPUs.They also have a tendency of changing the default GPU back to the integrated Intel GPU.

Thanks for the reply, Im going to try to reinstall the driver and see if that works.

I have repaired the intel graphics, and noticed that the real problem is in my nvidia GPU. Whenever I use the 1050 as my grapics processor in sketchup or autocad, it does not work and everything looks blank or non functional. If I decide to use the intel, it seems to work. I already updated the NVIDIA driver and ckecked out everything in the control panel, yet there seems to be no solution to my problem…

What happens if, in SketchUp you go to Window>Preferences>OpenGL and untick Use Fast Feedback? I mentioned that before. Did you do it?

Did you install SketchUp correctly? That is, did you right click on the downloaded installer file and choose run as administrator or did you just double click on the installer to run it?

Did you download the new driver from your laptop manufacturer or from the Nvidia site? Or did you let Windows update the driver “automatically”?

This indicates a deeper problem at system level. Autocad uses a totally different graphics pipeline than SketchUp (DirectX vs. OpenGL) so if both are dysfunctional there might even be a hardware problem, or your driver might be seriously outdated.
I would first try installing the latest driver from the Nvidia website.

I have the same problem but just on sketchup, my gtx1050 driver is updated. I don’t think he had the same problem in autocad, it was a misconception. My screen is just blank in sketchup make 2017 and in sketchup 2019 the start up screen is also blank. I can use sketchup only with the intel hd graphics

Rightclick on an empty spot of the desktop and open the Nvidia control panel.
Add SketchUp to the programs that must use the strong video card.

Oh I already did that and still do not working. I can only open the SketchUp aplication with a rightclick in SketchUp Shortcut and using Intel Integrated Graphics to open it. When I use Nvidia the start up screen is blank. I roll back my nvidias drivers to a 2018 version and the SketchUp make 2017 worked (still blank at 3dwarehouse screen and extesions manager) but my SketchUp 2019 start up screen still blank…

When you use the Nvidia driver with SketchUp, is Fast Feedback turned on in the Window menu>Preferences>OpenGL dialog? If it is on, what happens if you turn it on, or vice versa?
(Note that chenges only take effect after you restart SketchUp)

In the Nvidia control panel 3D settings, are Antialiasing and Anisotopic filtering set to “Application controlled” or equivalent?

When you installed SketchUp, did you right click on the downloaded installer and choose Run as administrator? Or did you just double click on the installer to run it?

Hey Dave, yes, I uninstalled SketchUp 2019 and I did right click and choose Run as adm on the Installer. But after that it still blank.

1 Like

About the blank scene, after i rolled back nvidias drivers to a 2018’s versions and deleted webcache the 2017’s version of SketchUp worked. But I still can’t open SketchUp 2019.

Sorry about the duplicated thread.

Did you add both 2017 and 2019 to the list of programs in the Nvidia panel?

I did had that problem in autocad and every other product from autodesk, or anything that used my Nvidia graphics card. Nevertheless, I already solved the issue by reinstalling an older version of windows 10. This worked perfectly and proved that indeed, the last windows update somehow screwed my Nvidia graphics.

Hey Mike, yes I did add both of them in the Nvidia Panel

Hey, thanks! How can i reinstall an old version of windows 10?

I found that even with the blank start up screen at SketchUp 2019, I can click on things But I still can’t see them

Honestly, I am not sure. A friend of mine took care of that and reinstalled everything and formatted my laptop. So far, everything works fine. If you are not sure how to do this procedure, I recommend you that you take your computer with someone that knows how to do this (a trustworthy friend or a repair shop).