Can't see my work on sketchup. Only white space

Hi, I just installed a trial version on my laptop of Sketchup 2021. When I tried opening my file, all I can see is white space. Even when I open a new file, still white space. No lines or anything. I’ve tried unticking fastfeedback but still the same. I also installed and ran sketchup 2021 checkup. The only error i’ve got is this:

“Warning: SketchUp has detected you are using a “Intel(R) UHD Graphics 620” graphics card when your system is capable of using an AMD or NVIDIA graphics card. SketchUp will likely perform better if you change your system to use the AMD or NVIDIA card.”

So I changed my graphic settings to High Performance but I’m still having the same problem.

What else can I do?

It is likely that the integrated Intel(R) UHD Graphics 620 card is used by SketchUp and is causing the problem.

You can easily check which video card is used by SketchUp via the Preferences.
Window menu >> Preferences >> OpenGL >> Now click on the button “Graphics Card Details”.

I expect you have to set the MX150 graphics card as the default for using SketchUp.
You can do this via the NVIDIA Control Panel.


I have that on the Graphic Card Details.

BTW, I tried sketchup make 2017. I thought that would work, but it still don’t.

This is what I see.

Do you have the Axes turned on in the view?

View menu >> Axes

Yes. I also can’t see the man model. I can’t see when I draw a line or rectangle or anything. None at all.

The second thing to do after trying the Fast feedback option is to update the graphic card driver.
Go to the manufacturers site and download from there, do not trust windows to tell you it is up to date.

1 Like

Ok. Will try that.

Your driver seems to be quite old. The current version is 471.68, released on the 10th of this August.

Yes I just downloaded that from the manufacturer’s website. Trying to update now.


Updated my driver still the same.

I’ve downloaded the latest driver from the website but still the same.

I can’t even see the instructor at the right tab.

I’m assuming you have rebooted your computer.
Have you now tried turning on or off the fast feedback feature now that it is using the updated driver?
Is there anything else you haven’t told us, like the laptop is running on a dock, you have two screens plugged in ?

1 Like

Yes sir I’ve rebooted my laptop.

I’ve also turned the fast feedback on and off.

I only have my laptop running with it’s screen. I don’t know what else there is to tell.

The only opened programs is this browser, documents folder and sketchup make 2017. When I install sketchup 2021 and run it, it’s just all blank now.

That looks like you may be having issues with the connection to the internet, it looks like you aren’t getting passed the welcome window which would probably be asking you to sign in.
I’ll just ping @colin incase he has some insight on this.

1 Like

Don’t know if this will help but when I’m on autocad, I need to turn off hardware acceleration to view my drawing. Maybe that is the same with sketchup?

And I can view and edit my drawings in sketchup web.

I can see my scene on the right but that’s it.

Current Sketchup Checkup.