Startup with white workspace on my new pc

Just bought a new high tech PC And installed Sketchup 2017.
It worked fine for a few days but now I get Sketchup on screen with all tools available but my workspace stays white. Please help!
Core I7 processor 32 Gigs of ram Nvidea GTX 1080 TI 16 Gig ram.

Can you provide screenshots so we know better what you’re seeing?

First I would try updating the Nvidia driver, if an update is available. New PC-s often ship with outdated drivers.

1 Like

Thank you for replying. Drivers are up to date.
I will provide a screenshot.

As you can see. The workspace stays empty.

Is it possible you have the axes turned off? Is there a tick next to Axes in the View menu?

You seem to have some plugins installed. Were they added recently?

Thanks for replying guys. The axes are fine. I can draw but nothing shows.
Everything is new installed but they are all known extensions that I used on my old PC.

Maybe this helps:

I ran Sketchup 2017 checkup.
My Videocard has 11 Gig onboard. Not 1 MB…

Have you tried installing (or repairing) SketchUp as an administrator? Try reinstalling by right (context) clicking to perform the install. Select “Run as Administrator” when the dialog box appears. No guarantees, but this may help.

Edit: It may be wise to remove the extensions before performing the reinstall or repair. Once you get the program to a reliable state then you go back and add them again. Also,. as an experiment, select a different template or style to observe if your workspace shows up without the white space.

If this approach does not work, then you should track down the reason for the inaccurate analysis of your graphics adapter from SketchUp 2017 Chec

Thank you for your advice.
I will do a clean install of Sketchup today but I do not think the problem is related to the plugins. I noticed (later) that the white workspace is already there on the introduction screen (screen print)

Could it have anything to do with Open GL drivers or something like that?
I cannot find these in mij Nvidea settings screen.
Also the report from the Scetchup checker is curious…

Today when I started my PC I had access to my Sketchup so I went on drawing for a couple of hours on one of my projects. After rendering it in Twilight for some hours my Sketchup screen went white again. Very annoying… I suspect it is either the Intell driver or the Nvideo driver causing the problem. Anyone has experienced this before? Help would be greatly appreciated.

The latest Nvidia driver, version 382.33 has been released today. You might try that.

I would also perhaps try disabling Twilight to test whether it has to do with your problem.

Problem not solved. Very frustrating

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.