Blank screen display

opengl
graphics
driver

#1

In the last few days, sometimes but not always, when I open a Sketchup 2016 (latest free version) file, all I see is the tool/menu/tray bars. The workspace is blank and white. When I get this, sometimes it fixes itself after awhile or if I reboot. Changing scenes doesn’t help. I’m not having any other computer/software related issues and have been told by my technical help that this is a software issue.

As I was typing in this problem, I followed one of the suggested threads that led me to a solution. I opened WINDOWS/PREFERENCES/OPENGL and unchecked USE HARDWARE ACCELERATION. That brought back my workspace.

Now I’m curious. Will doing this affect any other software or just SU? Does this mean that I need to leave this option unchecked all the time or just when I have a problem?

Any thoughts will be appreciated?

Thanks,
Ron


#2

It sounds like your graphics card and/or its drivers aren’t up to handling OpenGL. Deselecting Hardware Acceleration in SketchUp won’t affect other programs but the issue with the drivers might.

Please complete your profile with graphics card, operating system and SketchUp version.


#3

Thanks for updating your profile, Ron.

The Intel HD graphics cards are well known for their less than satisfactory support for OpenGL. You might check to see if there are any new drivers for it but you may be stuck using the CPU for graphics with SketchUp on this computer. I don’t know what other programs might be impacted by this graphics card that you would have installed but there could be some.

FWIW, if you are using SketchUp for projects for your clients, you should have SketchUp Pro. Make is not for commercial use.


#4

DaveR, I updated the driver and then switched back the SU setting to USE HARDWARE ACCELERATION. The image held ok. We’ll see what happens but at least now I have a fix.

The only other CAD program I use is SOLID EDGE by Siemens. This is a huge pc of free 2D software that is a spin off of their highly associative 3D program. I’ve had no problems with it. I went looking for the option re OPENGL in SE and it isn’t available. But I did fine technical info that leads me to believe that there is an option available in the 3D version.

Thanks
Ron


#5

Good luck with it.

OpenGL is used for creating the 3D appearance on screen so a 2D application is unlikely to need it. Might be other things such as games that would be impacted but that may not be an issue for you.


#6

Turning off hardware acceleration in windows/preferences/openGL worked for me. ( sketchup 2015 pro on x64 win10 pro with NVIDIA geforce go6150 graphics)
This seems to be an extremely annoying facet of the open GL3.0 problem that is requiring me to buy a new pc to update to sketchup 2018 to compensate for loss of google earth functionality.
I am sick to my gut of the enforced obsolescence the IT industry seems to think is acceptable business practice…and I’d thought sketchup was one of the good guys…more fool me…


#7

Just another data point for SU support, this is still an issue.

Brand new Lenovo Thinkpad X Yoga with Corei7 and UHD620 graphics, new install of SU 2018 Pro (18.0.16975), Open GL 4.5, and I get nothing but empty models (white screen) when “Use Fast Feedback” is turned on.

Not sure what good that UFF even does, but this is NOT a capability thing as I am moving from a 2011 MacBook Air that can run fine with it on…


#8

Actually, it is. Intel graphics are well known to be lacking in adequate OpenGL support. And according to the various benchmark sites, the 620 is a rather low performing GPU.

What version of SketchUp were you using on your McBook Air?


#9

Mac drivers are written by Apple. The problems with Intel graphics mostly affect Windows PCs.


#10

Um, I understand being an integrated vid card that it is ‘low performing’ compared to many out there, but compared to a 7 year old also-integrated vid card, it is quite a bit better:


https://www.notebookcheck.net/UHD-Graphics-620-vs-HD-Graphics-3000_8098_1956.247598.0.html

On the Mac was also the most current version of SU 18.


#11

Thanks, that explains why older hardware IS working… still bit mystified why this continues to be a problem so many years later, but that’s another forum elsewhere :wink:

I turned mine off and things seem fine, so really just wanted to give the feedback and refresh the page for anyone else running into this.