View port appears blank(black) when opening new or existing model file

intel
opengl
2016
hd4600
graphics

#1

Hello,

The past couple days I have been experiencing issues when opening existing model files as well as starting new files.
When the window opens, the viewport is blank/black.

I tried using drawing some things, orbiting, panning, etc… but the screen just remains blank. I even change style settings to see if something got switched around.

Not sure what else to provide for information. If you’ve had a similar issue, let’s talk! Screnshot below

Thanks.


Black screen when starting up SketchUp_not able to do anything
#2

It could be a Graphics Card issue…
Have you recently upgraded SketchUp ?
If so update your GC’s driver…

Or, if you have recently upgraded your GC’s driver, then try rolling it back to the last good version…

Also try adjusting the Preferences > OpenGL settings…
Does that change anything ?


#3

A simple check would be to disable Hardware Acceleration in Window/Preferences/OpenGl.
If things start to work that shows it is a graphic card issue.


#4

Thanks Box. I disabled Hardware Acceleration, restarted, and that seamed to be the issue.

TIG, I went into Windows Device Manager to roll back the driver, but the Roll Back Driver button is grayed out.

Any other method for doing this?

Thanks for your help guys!


#5

Your profile lists an Nvidia Quadro graphics card, but the image you uploaded is for an Intel integrated 4600. Those Intel integrated graphics are notorious for OpenGL problems. So which is it? If you have both, you need first to make sure the system is set so that SketchUp will use the Nvidia not the Intel. And once that is done, if you still have issues, check for updates to the Nvidia drivers.


#6

Thanks @slbaumgartner,

I have both the Intel® HD Graphics 4600 and the NVIDIA Quadro K5100M on the machine
How do I assign which card SU is using? Is this through SketchUp settings or through Windows settings?
Do I simply disable the Intel card?

Thanks.


#7

I believe you do it via the Nvidia Control Panel. I don’t have that, as I’m on a Mac, but if you can’t sort it out I’m sure one of the Windows gurus will chime in.


#8

Try disabling the Intel GC and ensure the Nvidia GC Control Panel is set up yo recognize apps, like SketchUp, and that they are allowed to choose their own settings…


#9

I have made sure all my drivers are up to date. I have tested settings, Ensured SU only runs with GPU and I’m still having a black screen problem.

If I go into Windows>Preference and adjust the Open GL settings, the screen with flash normal and straight back to the black screen again.

I have even tried running it in compatibility modes. No change.

More help is required please.


#10

Luke you have SketchUp Make, not SketchUp Free. (Please correct forum profile.)

Can you please pots an image of the dialog:
Window > Preferences > OpenGL > Details
by using ALT+PrintScreen (keys) when the dialog has focus …
… then in a forum post CTRL+V (keys) to paste.

You can also run the CheckUp utility and it will create a .sulog file on the Desktop that you can paste (drag and drop) here into a forum post.


#11

Apologies for the mistake on the profile. Fixed that straight away.

SketchUpLog.sulog (82.8 KB)

I have played with with settings in the Open GL box, When I adjust the setting the screen flashes normal and straight back to black screen.


#12

I just re-ran the check up application. Please see the attached updated log
SketchUpLog.sulog (84.2 KB)


#13

Your Nvidia driver is rather old. I haven’t updated mine for a while, and I have 388.something. Windows updates tend to break things, so it is a good idea to try to keep things up to date.

Note that when you change settings in the SketchUp OpenGL dialog, you have to restart SketchUp for them to take effect.


#14

I agree with Anssi. A search on Nvidia site shows the latest is 390.65, released only 12 days ago …

http://www.nvidia.com/download/driverResults.aspx/129085/en-us


Bookmark this Nvidia driver search form for checking for newer drivers in the future …

http://www.nvidia.com/Download/index.aspx?lang=en-us

(Change the language if you wish.)


#15

@lukejevo, and also make sure you’ve installed the latest available version of SketchUp Make for your platform.

It’s 17.2 for MS Windows, and 17.3 for Mac OSX …


#16

Thanks for the help so far, I downloaded the latest and it seems that is what I already had. I ran the Repair option and check all the setting with the graphics card, the Open GL settings and gave it a test run. Same result. I can load up a saved drawing as soon as I start to do anything it blacks out.

SketchUpLog.sulog (83.7 KB)


#17

As said, 385.54 is not the latest Nvidia driver. Besides downloading, did you also install the latest?


#18

Apologies @Anssi, I did not even see you comment initially. I have now updated the Nvidia Driver and all seems to be well again.
Thank you all for you help. It is greatly appriciated by this hobby designer.


#19

Hi! I have the same problem as him. My entire SU screen turns black. Tried deselecting the hardware acceleration and it worked. What do I do next? I’m using Lenovo legion Y720 ( GeForce GTX 1060 ). PLEASE SEND HELP.


#20

Update your Nvidia driver for the 1060, and check to be sure that SketchUp is using the Nvidia GPU and not the integrated Intel GPU. Within SketchUp,
WIndow > Preferences > OpenGL > Details

If it using the integrated Intel GPU, then exit SKetchUp, and use the Nvidia Control Panel to change what SketchUp.exe uses. REstart SketchUp.