Problem using Sketchup - Blank Screen

I bought a license for educational use of Sketchup a while ago (October 2018), and it was working just fine until recently. When I open sketchup, there’s a blank screen and I can’t model anything. Does anyone know how this is occuring?

likely Windows updated your GPU driver and broke your app

check your GPU settings in SU (probably uncheck fast feedback)

possibly reinstall intel driver

Lots of reports of this sort of thing from other users with integrated Intel GPUs like yours. For them, going to Window>Preferences>OpenGL and unticking Use Fast Feedback has fixed it.

Omg thank you so much I’ve been looking for this for a long time now, Thanks a lot

Hello, i have tried to going to Window>Preferences>OpenGL, but my works still blank… What should I do?

What did you do once you got to the OpnGL panel?

What is the graphics card? Your profile shows it as ‘8’ which isn’t helpful.

You could try updating the graphics drivers.

i unchecking the use fast feedback
I use NVIDIA GEFORCE and interl i7
how to updating the graphic drivers?

Which model? Please correct your profile.

Go to the Nvidia site, download and install the latest drivers for the model of card you have.

Also make sure that the Nvidia card is set to display SketchUp. Right click in empty space on the desktop and open the Nvidia control panel.

I’m using 8.1.956.0… can I send my model to you? because I just can’t open this file. But when I try to open new file it doesn’t blank.

What does that number refer to.

Upload your SketchUp model file so we can take a look. If it’s only this one file that is causing you problems, that’s different than the topic of this thread.

The number refer to my version. I can’t upload my file, it just stop at 14%. Should I use Drop Box?

Version of what?

Yes. And share the link.

my Nvidia version…

That’s not the link to the file.

sorry, I have copy the link but when I upload it, it became like that…

The camera was messed up in your file. Try this:

Thankyou so much! How to make my camera be right again? I’m afraid it will be like that again in another model.

I used a bit of Ruby to check the camera:

      cam =
      puts "Camera eye #{cam.eye.to_s}"
      puts "Camera target #{}"
      puts "Camera up #{cam.up.to_s}"
      if cam.perspective?
        puts "Perspective"
        puts "Parallel Projection"
      end #if

Then if it is a mess (yours was), this resets it:

eye = [-50.m, -50.m, 50.m]
target = [0,0,0]
up = [0,0,1]
cam.perspective = true

What is Ruby? Is this a extension?