Blank Screen on 2020 Sketchup Pro

Hello,

First, when I tried to open a document that I was using this past Sunday (three days ago) It said the following:
image

I thought that the file was corrupted, but when I tried to open a new file, even the toolbars and icons seem to work, I have a blank screen, and nothing shows up in the modeling area.

Reading the forums I tried all the possible solutions, I unchecked the fast feedback box, set to 0 the MSAA, and when tried to see which graphic card it’s trying to use its the one I have the: GeForce GTX 150 Ti (Window> Preferences> OpenGL>Details)

I also changed to a High-performance Nvidia processor in the Manage 3D settings (right-click on the desktop) and on the graphic settings (the one from the control panel) changed to High performance.

I Updated both drivers from Intel and The Nvdia graphic cards, I know that all of this was triggered from the last windows update. I am quite desperate since I already tried all these things and nothing it’s working

Please I need help

At first, the message about file version above nothing to do with the blank screen, it is just warn you, that the file you are opening is an earlier version of SU, and if you save it in SU2020 format, you (or anybody else) will not be able to open it in older SU application…

Secondly, the card: GeForce GTX 150 Ti does not exist! I guess it is GTX 1050 Ti (or GTS150 or GTX 550Ti).
Make sure you identified your graphic card properly and update its driver from Nvidia site.

Make sure you have been restarted your computer after update of driver.

When you uncheck-check the fast feedback box you also need to restart Sketchup to take effect.
Normally - for Nvidia cards - fast feedback box should be checked.

The current windows update is really very ruined up the settings… If you use multiple screens and/or docking station. Disconnect all and use only one screen.
(If you have a docking station unplug it from a wall.)

Make sure all windows update installed. Update Nvidia driver from Nvidia site.
Restart your computer.
Check again if all windows update installed.
Power off your computer. Unplug it from the wall for a minutes.
Start again and see if Sketchup works… then you can switch of again, reconnect your docking station/ other displays and see if still working…

Thanks for the response, I do appreciate it,

You are right, I had a typo error, it is the GeForce GTX 1050 Ti, I double-checked and reinstall the drivers for this graphic card, I download the GeForce Experience app to make sure I downloaded the correct driver.

I was hoping that Windows will repair their bugs, but unfortunately for me, I downloaded the whole update according to my Device Manager and Panel Control.

I uninstalled Sketchup and installed it again but without any success.

I have an Acer Aspire VX Laptop, and I don’t use more than one display.

I notice that the cursor changes icon when I select a tool (I assume that Sketchup its working), also when I maximize and minimize the screen it kind it freezes (please review the image)

I also use Creative Cloud, and I have an issue similar, but the day after Adobe updated their software and it’s up and running, the Issue according to Adobe was that the Program couldn’t find the graphic card. So most likely it’s happening the same thing with Sketchup but so far I ran out of ideas.

If you have an idea or maybe I am overlooking something please let me know.

Again, thanks!

Update I downloaded the Checkup app from Sketchup and the analysis came back with this result

So far I understand that Sketchup is having a hard time finding the Nvidia card, but when I go to Preferences>OpenGL>Graphic card details It shows the following image

So even I know that this is the mistake I have no clue on how to solve it (When I go to graphic settings Sketch up is set up to High performance)

What is the status of the “use fast feedback” feature in Window>Preferences>OpenGL? If it is Off, you should try turning it On. or vice versa. Restart SketchUp after making changes.

Thanks Anssi for your response.

I’ve tried Off and On fast feedback. close and open it again, even I uninstall Sketchup and reinstalled it but with no success