BLANK SCREEN, I can't Use Sketchup

make
sketchup
opengl
bug
blankscreen

#1

Hello,

When I Launch SKETCHUP, i Have a Blank Screen. Sketchup Up can’t detect my GPU or my RAM from the utility to test my system.

With the blank screen of SKETCHUP, i can use it, i can’t access of menu.

Please can you help me.

I try to use SU MAKE 2017.
My GPU is a radeon RX480 8 GB from Sapphire.
I have 16 GB of RAM.


#2

Laptop? Try r-clicking on SU desktop icon. Do you have an option to choose your AMD graphic card for SU from the context menu?

Have you updated your graphics driver?


#3

Yesterday, i upgraded my driver to the latest optionnal.
I have a desktop pc, i have only one GPU, so i haven’t the option what you said.


#4

I have uninstall it and the 2018 pro version for test.
I rebooted the PC.
I reinstall it
And now, there seems worked


#5

Where you using Checkup? In SU, can you go to Window > Preferences > OpenGL and see what it says under Graphics card details?

When you installed SU, did you r-click on the installer and choose Run as administrator?


#6


OpenGL
Distributeur ATI Technologies Inc.
Moteur de Radeon ™ RX480 Graphics
Version GL: 4.5.13506 Compatibility Profile Context

Format de pixel
DBL RGBA:8-8-8-8 Depth:24 Stencil:8 MSAA:4F:1

Avertissements OpenGL
(blank, nothing)


I just launch the installer with right clic and “run as administrator”.

I launch Sketchup from desktop icon with double left clic.
But i try to launch Sketchup from a 3D model and i have blankscreen for the new window, but the old other still works


#7

So you can have something in the workspace area. Many starting SU templates can look quite blank. Maybe just an axis. Is that the case, can you draw anything in the workspace? Can you upload a screenshot of what you are seeing?


#8

No, in blank screen i just see toolsbar, and space object is white, i can use anything, the window of SU don’t responds


#9

In SU, go to Window > Preferences > OpenGL and set anti aliasing to 0x. Any change?


#10

Apparently it seems to work, I was able to open 3 3D models correctly at the same time.


#11

A higher anti aliasing looks a lot nicer: the lines won’t look jagged.

You still have a driver issue. To try older and/or new drivers for your card, get them from the AMD website instead of relying on Windows Update.


#12

SU have a problem from AMD driver ? I use others softwares and i have never this issue type.


#13

The OpenGL function calls SU requires come from the graphics driver. SU require some of the lesser used OpenGL functions which other programs do not use. Historically AMD driver developers have been known to leave out some of the less used OpenGL functions.

For a nice looking lines, shoot for 4x anti aliasing. You can go higher, but 4x looks nice and is less demanding on the graphics card. Different drivers can provide a different set of OpenGL functionality depending on the developer’s mood.


#14

Other things to try for better performance:

  • In SU > Window > Preferences > OpenGL, disable Use fast feedback. This doesn’t kick in until a model gets a lot larger anyway, and you can live without it.
  • In SU > Window > Preferences > OpenGL, do not enable maximum texture size unless you really need it for something like ray tracing rendering.
  • Go to your graphic card control panel, the 3D Settings. You should be able to customize settings for individual programs. For SU, both anti-aliasing and anisotropic filtering should be set to application controlled. But you can try tweaking things here too.

#15

Ok, i do anything you recommanded for me.

If the problem Come back i will reply to this forum.


#16

I have the same problem with Sketchup 2018 pro all of a sudden too.

I have an Intel HD graphics 630 card.

Can anyone help


#17

If you open SketchUp, and go to Window > Preferences > OpenGL, try turning off Fast Feedback and/or setting MSAA to 0x.


#18

Thanks it is working now!!!


#19

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.