Sketch Up 2020 & 2017 Blank Screen Issues

Sketch Up Pro loads but a blank screen is visible, disabling fast feedback within preferences does not resolve issue. Application in the past has worked without any issue.

Nvidia Quadro M2000 GPU (4GB RAM)

Tried multiple drivers versions
Driver 21.21.13.7783 | Driver Date: 01/13/2018
Driver 23.21.13.9125 | Driver Date: 03/16/2018
Driver 23.21.13.8816 | Driver Date: 10/30/2017
Driver 21.21.13.6909 | Driver Date: 08/01/2016

Sketch Up Pro 2017 is licensed - application will load but design area remains completely white/blank. If I print preview the project it does show up. I tried installing Sketch Up 2020 (Trial) to see if a newer version would help but that also refuses to load and remains at a blank white screen when launched.

Sketch Up Viewer also tested but same blank/white screen issues continue to occur.

Full system specs
Windows 10 Pro
Intel Xeon e5-2630 v4 @ 2.20Ghz
32GB RAM
Nvidia Quadro M2000

try if installing the latest driver version 442.92 from 16.04.2020 helps.

@SketchUp3D_de
Thanks, I’ve tried the 442.92 package as suggested, unfortunately same result across all 3 (2020 Trial, 2017 Pro, & Viewer)

I also tried another older version I can add to the list - updated driver test list:

  • Driver 21.21.13.6909 | Driver Date: 08/01/2016
  • Driver 23.21.13.8816 | Driver Date: 10/30/2017
  • Driver 21.21.13.7783 | Driver Date: 01/13/2018
  • Driver 23.21.13.9125 | Driver Date: 03/16/2018
  • Driver 24.21.14.1216 | Driver Date: 12/17/2018
  • Driver 26.21.14.4292 | Driver Date: 04/07/2020

install the OpenGL-wise less demanding SU Make version 2016 and see, if the issue vanishes. If yes, the OpenGL support of the Quadro drivers is faulty or at least incompatible… what has already happend in the past.

Rule of thumb, don’t buy Quadros for SketchUp resp. only if another 3D CAx application demands for it, the GeForce consumer series is (much) faster at a comparable price point. If nothing helps and if you don’t need the Quadro for another application, drop the Quadro and buy a GTX 1660 Super or GTX 1660 Ti (or better).

Bummer, I did test SketchUp 2016 Make and it “did” load however I cannot work on any of the current project files since they were created in the 2017 edition.

I wonder if there’s an older build version of the 2017 Pro I could roll back to and see if it works. I know the Quadro series is not ideal but we do have a few apps that required it. This is also for commercial projects so I don’t want to use the make edition - current SU17 Pro build is Version 17.2.2555.

you can.

will probably not help because the enhanced OGL capabilities (advanced shadow) were included from the very beginning, thus the removal of the OGL option for deactivating the hardware acceleration (= GPU) too.

I am going to lean towards the replacement GPU with the hopes we can continue with the currently licensed SU17 Pro without any hiccups once the new GPU has been installed. Sadly it’s been running perfectly fine on the machine with the Quadro until recently but it’s not worth the headache any longer.

Thanks again!