Graphics Card good enough? SkU 2019 opens a blank/white window

Hi there,
I’ve been stumbling over this blank/white screen problem all day. Everything I have read points me to graphics cards or proxy/firewalls?
Does anyone have some advice for this noob?
NVIDIA GTX 1050 ti 4GB, WIndows 10, SkU 2019, Q-core i5 2.5ghz
Thanks!
Eric

Does disabling Fast Feedback in Preferences>OpenGL change anything?

Hi Dave,
I don’t know where that is located. I can’t seem to find Fast Feedback or Open GL on my PC. Are those setting on my computer or in the SU2019 app itself? Do you run mac or PC?
Thanks

Within Sketchup itself.
OpenGL

1 Like

Thats not even an option. As soon as the application is opened, it presents a blank, featureless window.

So no menus at all?

When you installed SketchUp, did you right click on the downloaded installer file and select run as administrator? Or did you do something different?

Could you post a screenshot of your whole monitor, while that white window is showing? The first thing that appears when you have installed SketchUp and open it for the first time is a terms and conditions screen, that you have to agree to the terms before you can use SketchUp. If for some reason that window is failing to draw, you won’t be able to click on the I agree box or the continue button.

Or did you manage to get the terms window the first time you opened SketchUp 2019? If you did, was the Welcome to SketchUp window blank?

Just seeing the size and shape of the white window could help us know what it was supposed to be showing.

Here’s how the terms window looks:

1 Like

It’s after the install has been completed. I go to open SU 2019 desktop app and this window appears.

It! seems to be an initial startup page. Similar to the 2018 page which looks like this, but obviously no options.

Just to repeat this important question that you have not answered.

No, not to my knowledge. I don’t think I goofed anything up. Uninstalled and reinstalled 3 times with the same result.

You should have used Run as administrator for the install. If you didn’t, you need to.

1 Like

Have you had problems with 2018 today? I have, where the Learn panel was empty like you show. When that happened I would click Start using SketchUp, and it would lock up, a document would never appear.

If you do see that, a work around is to open the Template section, and pick a template (even if your default one is already selected). Then it would open ok. It is possible that picking the template wasn’t important, and it’s just that I had collapsed the blank Learn section.

Edit: I removed my request for the 2019 screenshot, after noticing that you had posted it already!

1 Like

I checked the size, and it’s definitely the welcome screen, as the title suggests.

That screen is just a web page, and there are files that get installed that are loaded into the screen. This is the path to where those files should be:

C:\Program Files\SketchUp\SketchUp 2019\Resources\en-US\welcomescreen

If that folder is empty, or any of the path isn’t there, that would cause the problem. It most likely ends up needing the install as admin thing that the others suggested, the installer may not have had the rights to add files to that location.

1 Like

if this is a notebook: do you have an external monitor connected or running SU on a virtual screen?

if yes, rip off the external monitor resp. configure to run SU on the main screen #1 of the notebook.

1 Like

Also check in the 3D application settings of the Nvidia control panel (right click on your desktop) that SketchUp is using the Nvidia card instead of a possible Intel chip that might also be present in your system. It is also a good idea to install the latest Nvidia driver from the Nvidia website.

1 Like

No dice. Thanks for the thought though!

Thanks Anssi. I was able to locate the NVIDIA Control Panel, but alas, it did not fix the blank screen. Handy panel to know about though, so thanks! And I updated my drivers just the other day, and there are no updates since.

Roll your nvidia driver back a version or two and see if that helps. Has 2019 ever worked on this machine?

I have the same problem. My computer is i7-7300HQ, GTX1050, 8GB RAM with Windows 10. if I resize the window, it work, but ever in a different size from full screen. I notice that the same problem happen in homescreen of Simulink from MATLAB, maybe it help to diagnose .