Windows 10 Blank Screen

I’ve been using 2021 Sketchup Pro for several months on a Windows 10 platform. Today Windows did an automatic update and now Sketchup does not load properly. I have the sketchup icon on the task bar at bottom of the screen, but no matter what I try to open, it shows a blank screen on the task bar. I get nothing on the screen.

Windows updates tend to mess with the graphic card drivers, which is one of the reason we ask for it in your profile.
Go to the site for your specific graphic card and get the most up to date driver and install that.

That’s just the point. My computer is a Dell laptop with Intel HD 520 GPU. Yesterday’s windows update also included the latest graphics driver. BTW, I also tried re-installing 2021 Pro. It did not change anything.

Windows update tends to break a lot of graphics drivers. Go to the manufacturors website and download your models latest driver like @Box told you. This should fix it!

The point is that “windows update also included the latest graphics driver” is not necessarily equal meaning that you get latest graphics driver. (unfortunately this is an experience).
Go to manufacturer web site and try update driver from there.

Thanks. I’m not trying to be difficult, and I know this sounds like a Microsoft/Intel problem. I went to the Intel site and installed their recommended drivers. The problem persists. Any suggestions what to try now?
ScreenCapture

Share your .skp file so we can have a look at it to make sure it isn’t something with your model.

I have multiple models and all have the same behavior. Here’s a simple one for you to try.
BackSupport_Lower.skp (90.3 KB)

Just for future reference, Intel recommends OEM drivers be updated from the manufacturer’s site, not the Intel site. They are concerned they might break something proprietary.

That may be but from long experience, we know it’s common for the Windows-supplied drivers to be broken as far as OpenGL support goes.

Also note that integrated Intel GPUs have never been recommended for use with SketchUp.

I didn’t have any trouble opening and seeing your model so I’d say it’s the graphics drivers. You might try turning off Fast Feedback in SketchUp’s Preferences>OpenGL and see if that changes anything.

Thanks. I’d like to try your suggestion about Fast Feedback, but I can’t open Sketchup. Is there another way?

You can’t open SketchUp at all, now?

what happens after a cold reboot of the computer?

I’ve tried the drivers included in the Windows update, the drivers supplied by Dell, and the drivers supplied by Intel. All have the same behavior. I’ve not had any problems in the 2 years of using this laptop until this Windows update yesterday.

Don’t you have or had other screens connected?

Sketchup tries to open. I get the taskbar icon with a popup mini-view of the model window - see below. That’s as far as it will go. Selecting the model on the taskbar does nothing useful. It does, however, cause there to be a ‘ghost’ rectangle on the screen where the Sketchup window should be.
ScreenCapture

Try repairing the installation of SketchUp. Get the installer from sketchup.com/download/all then right click on it, choose Run as adminstrator and then, if prompted, choose Repair. After that shut the computer down completely and restart it. Then try reopening SketchUp. Not sure this will have any effect but it certainly won’t hurt anything.

I’ve used external displays on other laptops, but never had one for this computer. My device manager does not show any monitor accept the generic that’s built into the laptop.

Thanks. I tried the repair installation twice already - before and after GPU updates.

Can you roll your computer back to before the Windows update when things did work?

Interesting idea. I’ll try that now and get back to you. Thanks.