Blank model space, SU unresponsive


#1

Hi - wondering if someone can give me some pointers on troubleshooting a problem:

Problem:
On a fresh SU 2016 install, opening SketchUp2016 from the installed desktop shortcut gives me the splash screen, toolboxes, and menu bar, but the model space loads a blank white space and SU becomes unresponsive, requiring shutdown by the OS.

Solutions attempted:
-fresh install
-running SU through the nVidia GTX970M (SU’s system default option, all drivers updated, no card level alterations have been made to how the card handles SU, eg. forcing anti-aliasing etc.)
-running SU through the integrated Intel Iris Pro
-ensuring I am running as admin
-check SU Knowledgebase, can’t find anything that seems to fit the bill.
EDIT - run with shift held down
EDIT - checked OpenGL compatibility
EDIT - checked for errant plugins (none ever installed)
EDIT - uninstalled all VisualC++Redistributions, reinstalled latest, uninstalled and reinstalled SU2016
EDIT - tried disabling openGL via OpenGL Config v.1.07; no options selectable (“apply” greyed out, for all combinations of enable, disable, all SU versions)
EDIT - verified SU2016 is in registry
EDIT - installed and ran SU2015 - Works!
Computer:
i7-5700HQ @2.7gHz w/Iris Pro
16GB ram
nVidia GTX970M 3GB
Su installed to the OS SSD, plenty of room to spare


#2

You could try holding shift when you launch it. If I remember correctly this opens it fresh to avoid any previous start up issues.


#3

Same result. Thanks for the tip though!


#4

if disabling “Window > Preferences > OpenGL > Use Hardware Aceleration” fixes the issue, try the following:

  • download latest video driver
  • uninstall the recent one
  • restart Windows
  • check that there is no nVidia GeFroce driver left in the Windows software uninstallation control panel (otherwise uninstall again)
  • install recent driver by launching the setup routine with “Right click > Run as Admin…”

do the installation and first launch of SU with admin. rights too.

and ensure, that no plugins of old SU program installations are running.


#5

I think you are jumping to a stage that has yet to be reached.


#6

Thanks for your response.

“Window > Preferences > OpenGL > Use Hardware Acceleration” is unfortunately unselectable, because all parts of the SU window are unresponsive on load.

GeForce driver has been updated as you suggested, and no SU plugins have ever been installed on this machine.

I checked my OpenGL compatibility:

This knowledge base article states I need OpenGL 1.5 or higher for SU to work:
http://help.sketchup.com/en/article/36252

These are the specs of my card from the manufacturer, stating the card is compatible with OpenGL 4.5:


#7

Again, to be clear, I am making sure to run SU through the nVidia card, not the integrated graphics chip.

EDIT, tried VisualC Redist reinstall, no luck, realised I’ve been at this for 4 hours, realised its NYE, remembered I should go outside and get a life. Thanks for your help. Have a happy new year all!


#8

you may want use our free ‘OpenGL Config’ support tool (Windows only) for disabling the OGL hardware acceleration setting from outside SU (download to e.g. desktop > launch).


#9

I downloaded OpenGL Configv1.07f SketchUp for windows from the link provided. Running that program with SketchUp2016 checked, Apply is greyed out and unselectable for both enable and disable options. SU2016 is definitely installed on my system. Does this information suggest anything about the cause of my problem?

I also checked all other SU versions within the OpenGL config, with both enable and disable checked, and Apply is always greyed out.


#10

Anyone have any further thoughts on this? I’m out of ideas.


#11

until the status column shows “n/a” (= not available) the SU settings concerned cannot be found in the Windows registry and obviously neither enabled nor disabled.

• installation and first launch of SU done with admin. rights?
• installation done with the same Windows user account which is used to run the application?

which Windows version?


#12

Thanks for sticking with me.

Verified in Regedit that SU2016 is indeed present.

Only one user on this machine,though still unistalled, restarted, installed forcing admin rights through right click, same result.

But, did install SU2015 – works fine!!

Checked SU2016 again, still does not work


#13

if “\HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2016…” is avail and accessible w/ user rights our OGL config would show something…

first launch of SU done with admin. rights too?
SU x32 or x64 version?
which Windows version?


#14

There is a registry entry with that path that has “full control” permissions assigned to the “System” and “Administrators” principals. There is a principal called “Restricted” that only has Read access.

Windows 10 x64, current build (10586.36). There is only one user account on this machine, which has admin privileges.


#15

first launch of SU done with admin. rights too?
SU x32 or x64 version?


#16

x64 SU installer, with admin rights

(installer labelled: “SketchUpPro-en-x64.exe”)


#17

Try 32-bit installer?


#18

again, not the setup but SU itself launched w/ admin rights?