SketchUp Extremely Lagging w/ High Power Graphics Card

lag
advice
graphicscard

#1

Hi SU Community.

I need some help solving an issue I’m having with SU lagging with my high powered graphics card. I’m currently running SU 2018 on Windows 10 with an i7 processor and an Nvidia GeForce 1080Ti graphics card w/ 11 GB memory.

It would seem that every 3-4 commands or so my Sketchup freezes for about 3-4 seconds, and then comes back. This has been happening as I’ve slowly been adding components to my model, however I’m not creating a very large file. As it stands right now my file size is only about 70kb. This isn’t making sense to me, seeing that I’m able to run other programs like Revit and Lumion with absolute ease. Why is SketchUp having an issue?

If it helps the troubleshooting process, I ran SU’s CheckUp diagnostic on my computer before typing this. The only issue that arose was an error message saying that there is only 1MB of graphics card space available to run SU with. Apparently SU needs a minimum of 256MB to run smoothly. Maybe my problem starts here…

Any thoughts from the BRILLIANT SketchUp Community?

Thanks!


#2

First stop would be to make sure SU recognizes the GPU - SU - window - preferences - Open GL

If not, go to your Nvidia control panel.

Option 1 - 3D settings - manage 3D settings - global settings tab -
Should read high-performance Nvidia processor.

Option 2 - choose program settings tab, choose SU 2018 from the drop-down list, then choose high-performance Nvidia processor.

Make sure you save settings. I don’t think a reboot is necessary.

With 11GB of graphics ram, the global setting will generally be ok.


#3

There is a known issue with some ‘Monstermachines’

I do not know how ‘tech-savy’ you are, but could you try the following:
Stop SketchUp.
Make two copies of the PrivatePreferences.json file and rename the original to PrivatePreferencesBackUp.json.
This file is located at a hidden location:
C:\Users…\Appdata\Local\SketchUp\SketchUp 2018

(… = your username)

After renaming the original, open the first copy and remove everything from “Extensions: {“ till the end.
Rename this file to PrivatePreferences.json.

The idea is to let SketchUp regenerate the lower parts of the file and to determine which parts of the file causes the delay.

Start SketchUp and check if this speed things up!

If things are the same, stop SketchUp and delete the newly created PrivatePreference.json file and edit the second copy, but now, delete everything before “Extensions: {“ and rename the file.

Start SketchUp and check!
Pls report back!
@JamesE


#4

Sketchup recognizes my GPU. The settings in the Nvidia Control Panel seemed ok to me as well. I’m not sure how this information helps me…


#5

If SU recognises the GPU and your Nvidia control panel are correct, then it seems to be a more complex issue as @MikeWayzovski has indicated. On some level, SU does not recognise your 11GB of graphics memory.


#6

Basic checks also include whether you have the latest Nvidia driver for your GPU and SU is right up to date.


#7

Got it. I will look further into this.


#8

Di you need help with editing the PrivatePreference file?
@guz


#9

Yes, would you be able to walk me through it?


#10

Hi, I have the exakt same problem on a dual xeon,2.5 64gb ram, Nvidia gtx 1080 and M:2 disk for the prodjekt, so I have overflow of power, and it still lagg. When I work on may MAC book age 2006 it works perfect….


#11

Questions for you @gabalicious47

Where is the SKP file located?
• Drive C:
• USB thumb drive
• Drop Box, Google Drive or other cloud storage service
• Other external drive

Reason I ask is that working in a file which resides in external storage is both risky and slow.


An empty model containing only the 2D figure ‘Stacy’ is already ~100kb
Perhaps you meant your file size is 70MB, which isn’t huge, but certainly not ‘small’.


#12

If you actually read the instructions on the page where you downloaded the Checkup utility, it will explain the results of the test and why you saw what you saw (re 1MB.)

Do you have autosave switched on ?


#13

The SKP file would be located on our external server in our office. It’s not something directly on my desktop or machine.


#14

Thanks for the reply, Dan. I went back and read the page you linked me. Somewhat helped, somewhat didn’t. I may have to adjust my autosave settings as well.


#15

Try keeping the file on your local hard drive instead of on a network drive. At least part of your delay is likely due to access time on the network. The generally accepted best practice is to work on a file locally and sync it to your network drive when you are finished with it for the time being. The same applies to files stored in the cloud.


#16

Thanks, Dave. I will definitely try this.


#17

Please report your findings. Might help someone else.


#18


iI only have dutch language