Slow running and freezing



I have just purchased sketchup pro 2018 and it was working fine yesterday as I went through the ‘getting started’ tutorials. Today it keeps freezing and is impossible to work with because of how slow it is (getting stuck and freezing).

I used the check up tool to check if my hardware was sufficient to run sketchup and it passed. I have a 2.7 GHz Intel Core i5, 8192MB RAM PC running windows 10 with 5379MB available hard disk space. The only thing I can think it could be is the graphics card. When I check on my computer, the info on Graphics card says it is an Intel HD Graphics Card with 32MB VRAM, and 1792 Total memory, and direct 3D accelleration enabled. (Direct X version (whatever that is?)) I know that it should support ‘open GL’, which is not described in my PC diagnostic box, but it is described within the ‘preferences’ settings within sketchup when I view the graphics card details. It has the details for my Intel graphics card and it says it has Open GL 4.0.

I read a help topic which said you can disable the hardware acceleration option within these settings so that you are using your software and operating system, not the graphics card. It said this allows you to troubleshoot what is causing the freezing/ slow running by doing this, but how??

  • Will getting a new graphics card solve this issue (freezing and slow running)? If so- how do I do that? What do I buy and how do I physically install the thing??


While having a graphics card certainly helps with anything 3D related, my most common experience with freezing generally occurs when too many resources are being used. If you are getting abrupt hard-freezes, such as your mouse cursor stops moving for a second or two and your system is unresponsive, that could indicate CPU throttling due to the CPU getting too hot. If you are getting soft-freezes such as SketchUp is being unresponsive but other application are working fine that may indicate that you may want to consider getting a graphics card, especially if the web based version of SketchUp has the same issue. If you have user interface delays in all apps when running SketchUp this could indicate you maybe hitting swap space and since the free space on your disk is less than your total amount RAM, the OS is probably using compressed I/O which is very very slow, especially if you have a traditional HDD as opposed to having an SSD.

There are many factors that can lead to having these issues so take what I said with a grain of salt.


I think I would describe it as ‘soft freezes’ based on your description. Other programmes (eg. Autocad LT) are working fine, its just sketch up that is completely unresponsive. The mouse moves but the viewport freezes and it does not respond when I try to select a new tool or select anything in my model. I have been trying to ‘use’ the programme all day and have drawn a rectangle…that’s it!!!

I had the same issue when I was trying to use my free trial of it before purchasing it yesterday, but the online version did allow me to work with it…really strange…any ideas what i can do? I am completely stuck!

I have tried updating all my drivers and they are already all up to date. The only thing that appears to be wrong is that a windows update keeps failing. It just returns an error report every time I try to do install it. It can’t be the CPU as it is easily powerful enough and i have nothing else running except my email.

What on earth can I do with this??? Please help!


Right click on the desktop, select the Intel graphics. In the app there will be a place to link SU to the graphics 3D. This should get things going.


Hi Dave,

Thanks for your response, really appreciate your help but- I have attempted to do what you have suggested and have managed to access the intel graphics control panel, where I went into the settings for 3D and chose ‘balanced’ as this was the recommended setting for performance (which I assume is better for speed?). I was unable to see anywhere that allowed me to ‘link sketchup with my graphics card??


I think the advice will be you need a dedicated graphics card , usually a Nvidea GTX or Radeon card, did you check your PC met the hardware requirements of SketchUp?


Hi Gsharp,

Thanks, that was my initial thought aswell…but I was pleasantly surprized when I ran the check up tool provided by sketchup and found that the Intel HD card did infact meet the requirements, although the written list of hardware requirements says that sketch up do not recommend Intel HD graphics cards.

It seems strange to me that the card meets the requirements but yet it actually doesn’t in reality?! If that is what the problem is? Very frustrating that I have lost a whole days work today and will now have to get a new graphics card and don’t even know if that will fix it?!

Do you know which Nvidia graphics card will be enough? At a glance, I can see they vary a lot in price from £40 - £400!!! How much do I need to spend?


I’m not sure that I would put a lot of stock in the report from the CheckUp utility. It’s mostly looking at what Windows reports and there are some known bugs in Windows that show incorrect information.

What sort of computer are you using? Is it a notebook or desktop? Before you get too concerned about exactly what graphics card to purchase, check to see what your computer will take.


Hi Dave,

It’s a desk top pc, i5 processor, windows 10, about 8GB RAM. I have never had to upgrade a graphics card before so dont really know what or where to start…do you plug it in the back of pc tower? Image below-


The graphics card would install inside the case. It would be plugged into the Motherboard and power supply. The monitor connections would be visible where one of those narrow horizontal covers is now. If you aren’t familiar with working with computer hardware, I would suggest you take the computer to a shop that can install it and make sure everything works. Adding a graphics card will put additional load on the power supply so you may need a new power supply as well. It all depends on what is in there.


Oh😟 ok…thanks for the info. Do you think that it is the graphics card?

It puzzles me why it still freezes imdediatly when I start to try working in a new file aswell though. Surely it shouldnt be an issue in an empty file with nothing to generate mutiple views of yet ( cos its empty)? If you understand what I mean? (Thats if I even have the right idea how a graphics card works?)

Ive noticed it is mainly the selection tool/ function that initiates the freezing, if that helps diagnose the issue? There is such a long delay that the ‘triple click’ you would use to select all connecting geometry, cannot work. Neither will a ‘click and drag’ to make a selection window.


The freezing you describe seems to be common with Intel graphics drivers. We can only guess at the problem in your case but it seems likely. Another thing that goes along with this is that you might find a driver that results in better performance from the integrated Intel graphics but the next time Microsoft pushes an update that includes Intel graphics drivers, you could find yourself back in the same boat.

You might also want to give some thought to replacing the entire computer. You could purchase a higher end notebook computer with a good Nvidia card or you could have a desktop machine built with the right card. Maybe it’s just time to start fresh.


How old is your PC and what is the model number? When you open the Intel control center is there a mention of 3D. This is where the link to SU is made. If your box is several years old it may be time to get the latest and greatest. Something with Nvidia graphics. @DaveR gives good advice.


This isnt sounding good for accounts…are you saying that the cost of a suitable graphics card will be comparable to a new PC?! :tired_face:

This is not good at all!


A new Nvidia-based graphics card is to be recommended, but your particular SUPro issue might be fixed by applying the patch issued by SketchUp in the first post of this thread:

(BTW, the Knowledge base should offer an easy route to finding this, now, I think, this forum post is the only way to access it)


:raised_hands::pray:I really hope that works, I will try it first thing on Monday, thank you for the suggestion, I am hopefull it will work, fingers crossed.


At Microcenter a suitable card starts at $280. Prices and specs vary widely depending what you want to spend and where you look… Installation in your box should not be hard. One thing, a large enough power supply is critical. This is the reason a new pc may be the best route if the lag issue cannot be corrected with the tool.


I would say that ANY current Nvidia card is better than an integrated Intel chip. SketchUp is very CPU intensive (and single-threaded) so an ultracool whizbang card will usually not perform noticeably better than a mediocre one. My small models run OK with my old QuadroFX 1800 that doesn’t meet even the recommended specs, and the GT 620M in my ultrabook. The situation changes if you have other uses for the graphics card, for instance GPU rendering. In our parts, cards that should be OK for SketchUp can be had with about 100€.


The patch is also mentioned in the release notes:


I have the exact problem. Running sketchup pro 2018 on windows 10 pro 64bit intelHD 4GB RAM Intel i5-2467M.
But I think I just found the solution. Simply disable all your extension (on Window-Extension Manager). If that still didn’t work, Set you graphic to best performance and download to check your system. Hope that helps