Fast in integrated card, slow in dedicated graphics card


#1

This is my first time to use sketchup, and by default it is running in integrated graphics card which is Intel HD graphics 620. By the way I’m using a laptop, everything is smooth not until I try to restart and run using high-performance NVidia processor(which was the labeled name) a Geforce 940mx. I though it would run much smoother, but it turn out to be freezing. When I rotate the camera view it hang for a moment and then it moves to the other view/angle. I though I mess with wrong settings I even uninstall and reinstall the sketchup but it still the same. when I try to run using integrated graphics card which is hd 620 it runs smoothly. Can some help me to figure what’s wrong, is my driver or something. Thank you for all the help anyway.

Specs:
i5-7200u 2.5ghz
Geforce 940mx 2gb
Windows 10 home
4gb ddr4


#2

Before I say anything, understand that I don’t know the ins and outs of graphics, so if you want someone who can diagnose and give the technical answer, don’t listen to me. These are just some suggestions of things I’ve done; I’m also an integrated Intel + dedicated Nvidia user.

Could be driver.
Could be NVIDIA settings. See NVIDIA control panel and tweak the preferences for SU.

The most effective for me has been to go to the top menu in SU, Window>Preferences>OpenGL and uncheck Use hardware acceleration. Just opened SU on a different computer this week, and fixed the exact problem you have.


#3

This option was removed in SU 2017. Unless you are using SU <= 2016 it won’t work and you will have to resort to the Nvidia tweaks and/or driver updates.


#4

Always a good idea to update your graphics drivers:

http://www.nvidia.com/download/driverResults.aspx/116348/en-us

There have been some Microsoft updates lately for Win10 that cause slow operation.

See:


#5

I just updated my NVIDIA driver, and was able to re-engage Hardware acceleration with no issues.


#6

Disabling hardware acceleration on pre-2017 versions of SU means you are not using the dedicated graphics card (and its driver). Instead the integrated graphics chipset (and its driver) is being used. It indicates an issue with the dedicated graphics card driver not being fully OpenGL compliant as required by SU.

Nice to read that the driver update fixed things.


#7

Your really right dan, after I update my NVidia driver every is so smooth not just in sketch up as well as other programs. Thank by th way :grin:


#8

Thank you for all the replies it really helps a lot. I just need to update my driver, everything is now smooth. Thank very much. :facepunch:t3::facepunch:t3::facepunch:t3::grin:


#9

This topic was automatically closed after 91 days. New replies are no longer allowed.