Sketchup Lagging / crashing

Hi All,

For some reason Sketchup keeps crashing and lagging really easily on my work machine. Granted the graphics card for this PC isn’t very good (nvidia quadro p400 2gb) the task manager whilst running Sketchup shows that the system isn’t being pushed hard at all with CPU / GPU below 20 / 30% yet I’m getting constant moments of lag, especially when copying / downloading from the 3D warehouse etc. The PC has 16gb of RAM.

This is for Sketchup 2019.
Many thanks.

Someone more techie than me will give you a better answer but I can say that I have a nVidia card in a late 2012 Mac and that works fine.

I do know that you sometimes have to make sure that SU is actually using the video card you have installed.

It’s worth putting nVidia or video card into the search box and reading up about other people’s experience.

BTW, you have not filled in much of your profile which will really slow people down trying to help you.

I have a much older graphics card than you (Quadro FX 1800 with only 768 Mb of memory, well below the SketchUp minimum spec) and it works OK with my models (that are usually small).

Are you running resource-hungry plugins, like renderers?

Most lags in otherwise working systems are caused by model bloat (growing number of faces and edges). When edge/face count runs in the millions, SketchUp slows down in all, even the fastest computers.

2 Likes

I have the Intel HD Graohic card but mine crashes still

Intel graphics are well known to be problematic. You can try updating the drivers directly from Intel. Also make sure SketchUp is installed correctly by right clicking on the downloaded installer and selecting Run as administrator.

Thank you I will try that. I have tried downloading later versions of the graphic card but they’re not compatible with HP running windows 10

You do not state what your hardware specifications are. It is very possible that your hardware does not support the newer software.

That’s a very telling statement. Sounds like it’s time to upgrade your computer.

The more complex the model gets the slower Sketchup gets, and the slower it gets the higher the chance of crashing. Sketchup isn’t very good in handling large models.

To improve the performance try the following tips (if you haven’t already):

  1. Turn off shadows (turn them on only when you need them)
  2. Turn off Profiles (View > Edge Style > Profiles) (Leave only “Edges” on)
  3. Make sure that your components aren’t more detailed than they need to be (including those downloaded from the 3D Warehouse)
  4. Place different types of components in different layers, and turn off the visibility of those layers when they are not needed (e.g. trees, furniture etc)
  5. Purge regularly (Window > Model Info > Statistics > Purge Unused)
  6. Disable Auto-Save and instead get used in manually saving often (Window > Preferences > General > Auto-Save)
  7. Keep only the extensions you actually use
  8. When it slows down don’t push it. Let it finish what its doing. If you try to do more things at that point you increase the chance of crashing.
1 Like

Thank you! that is good information to know but have you guys had any issues with the auto save?

My issue with auto save is that when the model gets bigger it takes several seconds for the model to be saved, and it can stop me from working while I am in the middle of something. So I prefer to save manually.

1 Like

To me it doesn’t matter whether it’s save from the beginning because it continues to keep doing it.