White Screen on startup..Graphics card?


#21

Thank you Aerillius !!! Yes that works. You walk on water!
If I untick “Use fast feedback” the graphics appear like magic, and if I select it again, STACY goes invisible again.

I can certainly live with this work-around.

Thanks again, Mark


#22

with much less display output performance of course, i.e. a workaround nothing for at least high-poly count models.


#23

True, this is not a permanent solution.
What do I do to ensure someone works at this problem?
Is this a SketchUp issue or an ITEL Driver issue?


#24

it’s caused by the sub-par OpenGL support of the integrated and thus slow intel HD series never made nor thought to be used in connection with 3D CAD modelers but for office/video/internet etc. only.

If you wanna solve this issue by yourself only, use a system adhering to the SketchUp system requirements, especially in regard to the video card annotations (= use a dedicated GeForce GTX and you’re fine).


#25

If anyone else has this blank screen problem, please fill out this form, as we are trying to collect data on what kind of graphics cards and computers are being affected: https://goo.gl/forms/RQEr2Au1KGdW8smD2


Sketchup pro trial not working
#26

Hi, I am too facing the same problem since 2 days.
I tried with OpenGL settings…updating my graphics.
What shall I do?


#27

Hi, I just got a similar issue. When I open SketchUp I got all the menus and panels as they are supposed to, and they seem to work fine, but the work area is just showing a blank light grey empty window.
I think I got a graphics card driver update pushed yesterday, so it might be related to that…
IT doesn’t matter if I open an old model or start on a new, it is just showing nothing.


#28

Not too surprising with Intel integrated graphics. Did you go to the OpenGL settings in SketchUp and untick Use Fast Feedback?


#29

Thanks DaveR,
I have just tested that and then my model and the background went visible again.
Do you think it affects the performance in any significant way, or could it be left unticked without any noticable difference?


#30

Well, considering that unticking Use Fast Feedback fixed the problem, it would appear you need to leave it as is. Evidently the performance is improved with it unticked. You could test it the next time a graphics driver gets pushed and see if it has fixed it.

You could check with Intel directly to see if they have a new driver. It might be better than the one Microsoft pushed.

If you are really concerned about graphics performance you should look into upgrading the graphics to something more appropriate for 3D modeling. Or maybe it’s time for a shiny new computer with a proper graphics card. :smiley:


#31

Fast feedback is an OpenGL optimization that will improve speed in some display operations. It is hard to say whether you would notice a difference, as it depends on the SketchUp model and what you are doing to it. But if SketchUp tries to use fast feedback (the default), you will get display issues unless it is implemented correctly in your graphics hardware and its drivers. Intel Integrated Graphics and the drivers pushed out by Microsoft are notorious for such errors. SketchUp provides a preferences setting to turn off fast feedback in an effort to at least make it possible to run on graphics whose support is lacking.