Sketchup pro trial not working


I just downloaded the trial version and and the software to make sure my Surface laptop was compatible. All green check marks but when I try to start modeling, the file won’t work, e.g. the tools aren’t functioning. Very frustrated. I uninstalled and reinstalled the program and even created a file in the Free web version and opened it but nothing worked. Also, I watched the tutorial videos to make sure I wasn’t missing a step but still no success. To be specific, I choose a tool - say a rectangle shape - and click it but it doesn’t work.


Two things come to mind.

One: To correctly install SketchUp you must right click on the installer file you downloaded and choose Run as administrator. If you didn’t do that, it isn’t installed properly. Not, logging into your computer as the administrator is not the same thing. You must log into Windows under your normal user ID and you must right click on the installer and select Run as administrator.

B: Once you have SketchUp installed correctly, open it. Go to Window>Preferences>OpenGL. Untick the box for Use Fast Feedback. Does that help?


YES! That totally did it. I needed to unclick the use fast feedback option under the open gl settings.
Thanks so much!


Did you install SketchUp correctly with Run as administrator? You should do that anyway if you didn’t do it before.

Since unticking that box fixed the display problem, it’s safe to assume you have an Intel graphics adapter. There’s a thread with a link to a survey regarding this display problem and Intel graphics. I’ll hunt up the link. Please take a few moments to fill it out.

Here’s the link: White Screen on startup..Graphics card?