The problem with (display) windows in the new version 2024

I think there are just lots and lots of variations - I know that when we purchase our laptops here at work we have to pay special attention to their video/display capabilities as several pieces of software we work with are particular about it. When it comes to connecting multiple display , It often ends up being the difference between the professional models and the consumer models.

Update the chipset drivers and the drivers for both graphics cards - many machines have 2.

I do not think you will buy a new laptops for every release of SketchUp.
All of the previous release of SketchUp as well as any other software can properly handle my current hardware. For me it is more than enough to prove that the problem is with the SU 2024 and not my laptop.

I’m not suggesting you do, I’m just commenting on multi screen setups, which often have multiple devices involved are often finnicky - especially on Windows, which is quite frankly incredibly poor at various kinds of display management ,whether that is hiDPI scaling or color management.

The new UI framework or the switch to DX12 has clearly had big impacts on how things worked compared to how they were, hopefully those teething issues will be sorted and we can feel more of the benefits that those bring.

I really hope that you will be right as soon as possible.

Until then, unfortunately, the fact remains as fact: the SU2024 is useless to me. :disappointed_relieved:

1 Like

I was in a class today and I couldn’t show the big toolbar. It seemed as it was the first time I was using SketchUp

The patch release ( 24.0.553 ) does not resolve the issues with my dual screen laptop ( Asus Zenbook Pro 14 Duo OLED; UX8402)

Still an issue:

  • SU 2024 still starts at the secondary (half height ) monitor - even after repositioning and closing the main window
  • After repositioning SU to the main monitor all the menus (including right click context menus) displaying at the secondary monitor
  • After repositioning SU to the main monitor the undocked toolbars are jumping to secondary monitor

A little improvement:

  • previously when SU was positioned to main monitor it has been crashed when the tooltip being displayed. It is no longer the case, SU still run however there is NO tooltip appears.

The application ( SU 24.0.553 ) still useless for me.

Hello,

I have the sames issue with my 3 screens and i have updated sketchup, no change.
I have noticed also the cell for texture size is too small and it’s embarrassing.
image

Another issue, there are blue squares instead of pins (except move pin).

Thanks

Is your display scaling larger than 150%?

No 100 % for my 3 screens

Hi was hoping the latest update would solve this problem since it’s been going on for at least a month… I’m tired of having to change my monitor settings when I need to use SketchUp

Is global text scaling set above 100% ?


Win 10

Start > Settings > Ease of Access > Display > Make text bigger


Win 11

Start > Settings > Accessibility > Text size


FYI: The Qt GUI framework, that SketchUp uses on Windows, needs each display set to its recommended resolution and display scaling.


All my screens are in recommended resolution.
Text size set to 100%.


For demonstrate pins problems

One thing people might want to try is if using
AMD - try “eyefinity” mode combining your screens into 1 “virtual” screen

or nvidia - try “surround” mode (nvidias version of eyefinity) which will be in the nvidia control panel (right click on empty part of desktop) - configure surround, physX - span displays with surround.

Both options essentially fool the OS into believing you are using only 1 large monitor that just happens to span all your actual physical monitors.

Both also have options on how to manage the taskbar in this mode as well so you can choose to let the taskbar span all your monitors or confine it to 1 monitor.

Unfortunately it is not possible for me.
And I do not want to use one monitor, but 2 (or several).

I have no problem with other programs (including earlier version of SU), so the problem is with the SU2024 and not with my computer.
It is more than clear for me that SU 2024 does not properly handle multiple monitors and resolution/scaling.

Do you not have an nvidia or amd card? Why is it not possible?
Why don’t you just revert to the old engine then?

I have Nvidia card.Zenbook Pro 14 Duo OLED (UX8402)|Laptops Für Content Creator|ASUS Deutschland
There is no such a settings you mentioned.
Revert to old engine, doesn’t help.

I have tried 100000 different settings and combination of drivers whatever you can imagine (yes, that one you just think about right now…) and non of them helps.
The only thing is working to disable the “half” display at the keyboard plane.
That I won’t do.

Recent Fix driver is same issue for me.

The problem still occurs with the dual monitor.