The problem with (display) windows in the new version 2024

Hello!
This problem is only on the new version of SketchUp 2024.
I have a laptop with two monitors. SketchUp runs on a secondary monitor. When I move the window to the main monitor, the menus open on the second monitor.
I tried reinstalling the program, deleting SketchUp 2023, nothing helps.

4 Likes

I guess you get a bugsplat e.g. when you wan to draw a line or use other Tool. The crash will happen when the program try to display the Tooltip beside the mouse…

You are not alone. They know it and working on a solution…

(Currently the only way to use it on a “half height” screen or attach an external monitor.)

1 Like

Yeah, unfortunately, this is a known issue and we have been working on a fix for it. I cant say when a patch for this will happen but I promise we’re tryin’ to get a solution for this one!

4 Likes

Thank you

Good! I’m really looking forward to the update!
Because the new features are very impressive

1 Like

Is this the same with anyone with more than one monitor (as in not integrated in like a laptop with two screens…) ?
Is everyone experiencing difficulties with a dual monitor setup?

My two monitors seem to be behaving as normal, now I am trying out SU24

It shouldn’t be, but there were reports regarding multiple monitor setups sometimes having issues. Please report it if you see that behavior. We are working on a solution for all multi monitor issues like this but at the moment it seems to be environment specific. For example I’m running dual 2K monitors with a 1080P drawing tablet screen (win10) and don’t see the behavior so not every computer setup that has multiple monitors sees this behavior.

I did not see this particular bug with my setup, (external 28" UHD, internal notebook 15.3" FHD.)

I usually had incorrect display scaling issues when I was running SketchUp on my external monitor as the secondary Windows display. Those issues went away when I finally got around to designating the external display as the primary Windows display (which now hosts the virtual desktop origin.)

i’m having the same issue. i have a msi ge66 raider with a 3080ti connected to a 32" msi monitor. when working on the large monitor, everytime i right click it goes to the laptop monitor.


Continuing the discussion from The problem with windows in the new version 2024:

Having similar issues here with a dual-monitor (+ Laptop Display) setup.

I originally installed the update with both monitors plugged in and realized the program would only start on my portrait monitor. Moved the tab over thinking nothing of it until I realized all menus continue to pop up on the right-side monitor.

Uninstalled 24 and unplugged both monitors before re-installing. Messed around with the new features for a moment before trying the monitors again and was met with a mess of a layout with toolbars being misaligned / all over the place as well as default tray not wanting to close or move. Closed program and restarted with monitors plugged in and found same result as when I first opened, welcome page opens on right screen and when moved over menu drop downs stay there. Tried a few other troubleshoots between display settings, graphics, software and driver updates… no luck.

Not an IT guy here, but proficient enough to follow basic instructions from other forums. Hope we can get a patch soon, loving the Ambient Occlusion feature, but have to resort to 23 for the time being.

Could you say what monitors you have, what resolution, which one is the main display, and what scaling value they are set to. Also, what arrangement are they?

all working fine with my:
Display 1 iiyama PL2760Q 2560x1440 @ 144Hz
Display 2 Asus VP278 1920x1080 @ 75Hx
connected to AMD Radeon RX 6800XT
no scaling

perhaps a separate thread for dual display issues is needed ?

This is a thread about dual monitors. The new laptop that two of the posters are using is unusual, in that there is a half height display between the keyboard and the internal laptop screen. We don’t have any of those to try! I’m hoping someone with two regular screens can get into a combination that shows the same problem, and however we fix that will also help the new laptop.

For anyone else giving their figures, for scaling I mean what is the setting, not how much is it scaled. For example, the screen may have an entry of 150% (recommended). I still want to know that it’s on 150%, even if you didn’t change anything.

asus zenbook pro duo laptop
My monitor settings:

1 monitor main - display resolution 3840X2160 (recommended)
Scale 200% (recommended 250%, but it doesn’t solve the problem)

2 monitor, the half monitor - display resolution 3840X1100 (recommended)
Scale 150% (recommended)

I also connect sometimes an additional 3 monitor - resolution 1920x1080
Scale 100%

When the 3rd monitor is disconnected, SketchUp runs on the 2nd monitor.
When the 3rd monitor is connected, it starts on the 3rd monitor. It’s as if SketchUp wants to run on a lower resolution.

monitor arrangement
изображение_2024-04-07_201003079

I’m using 2 2560x1080 ultrawide monitors. SketchUp 2024 insists on displaying on the secondary monitor whenever launched or after being minimized and maximized again. However, if I make the secondary monitor the primary monitor in Windows 10 setup, SketchUp starts to display on the primary monitor for some reason. That is, if the primary monitor is configured as the primary monitor, SketchUp will be displayed on the secondary monitor. This is stopping me from working.

How are your displays connected?

Using HP - Envy 16 Laptop - Intel Core i9 - 16GB Memory - NVIDIA GeForce RTX 4060 - 1TB SSD

J5 Create Dock - USB type C - Dual HDMI

Monitors are used/older and FHD (1920 x 1080?)

Dual monitors never had issues with SketchUp 23’
Always used SU on the laptop display and had V-ray and other apps on monitors
Tried rearranging monitors, main displays, and scale

My current layout with same issue of SU opening and displaying menus on the right portrait display only (Screen 1 is now laptop monitor on left):

I have same problemm too. And I realize that;
If my third screen selected as a Main Display all menus open on my Notebooks own display. But If I select Notebooks own screen as a main display everything work good on also second and third display. And doesnt matter which Screen I select the sketchup start first. Its always start on Notebooks own display. I hpe Its will be helpfull for you on solution phase.

My setup:

Monitor 1(Left)
Monitor 2(Right)
Multiple Displays is set to “Extend these displays”

What I’m experiencing:

When opening the Sketch App, It always is visible on Monitor 2. Keeping Sketchup located on Monitor 2, everything seems to work fine…clicking on a menu heading will then show the sub-menu directly below and to the right of the main heading.

When I drag Sketchup window to Monitor 1 and perform the same above scenario, the sub-menu is “stuck” and displays on Monitor 2.

If I change the Multiple Displays setting to “Duplicate these displays” the Sketchup window appears on both monitors at the same time and the sub-menu appears in the correct location on both monitors.

If I change the Multiple Displays setting to “Show only on 1” or “Show only on 2”, Sub-menu location is in the correct location.

It seems that the “Extend these displays” setting is the issue for me.

Hope this helps.

1 Like

same here. :frowning: