System requirements for launching my.sketchup

Hi,

I just tried launching with chrome Version 51.0.2704.84 m and got this

Config : Win7 64 bit OS, 8GB RAM, Graphics card : Intel® HD Graphics 3000, Total graphics memory 1696 MB

Is this supported?

probably WebGL hardware support cannot be enabled with your browser in connection with your integrated graphics system.

if the issue is caused by an incompatible or missing WebGL support of the used driver, e.g. WebGL Earth should fail too. Check if there is a more recent driver version for your intel HD 3000 avail… which probably won’t help.

For enabling WebGL in Chrome or Firefox see this wiki post.

1 Like

Hi,
WebGL is supported and enabled on my browser. and WebGL earth works too.
I think its something with the graphics card. Thanks!

WebGL is a suite with lots of function calls, not every driver especially of the integrated graphics solutions might support all of them resp. the calls required by my.SketchUp.

offic. WebGL test page
WebGL Browser Report
WebGL Report

If someone has a similar configuration, please test and let us know the behaviour.

@yogesh Does my.SketchUp detect and run on older systems under SwiftShader ?

:thumbsup: Chrome 51.0.2704.84, Mac OS X 10.11, 4GB RAM, Intel® HD Graphics 3000 384MB – works great

@Kanthimathy we are looking into a few issues related to Chrome and various video cards. Can you do us a favor and try out the latest version of Firefox and see if you get the same incompatibility message. Thanks!

I am having the same problem on one of my machines, and the system configurations on this machine are:
Chrome Version 51.0.2704.84 m, Win 7 64 bit, 16GB RAM, Ati FirePro V 2GB Graphics card

But works perfectly fine on another machine with the configurations below:
Chrome Version 51.0.2704.84 m, Win 10 64 bit, 40GB RAM, Nvidia 4GB Graphics Card

Hi Jon,

Yes, it works with FF 47.0 version. :slight_smile:

FYI, i also tried with FF 43.0, 39.0 , they didnt work.
Same case for a colleague of mine, it works with FF 47.0, but didn’t work on Chrome latest, with Intel ® HD Graphics Family 4000 (total available graphics memory 1696 MB).

Thanks for looking into this for me @Kanthimathy and I am glad that you are able to get it up and running. I wouldn’t expect the 43.0 or 39.0 versions to work due to some of the functionality that we require. I am adding your setup details to a test pool for work related to this Chrome and Video Card combo issue. We will update the community once we have a new version to try out.

Thanks again for confirming this!

Jon

FYI: Chrome Version 51.0.2704.103 m has been released.

If you go to the About page, Chrome will check for updates. Navigate to
chrome://help
… or menu > Help > About Google Chrome

Do not now if this will help, but may be worth a try.

I had tried that earlier today i.e. updated Chrome and tried to re-launch my.sketchup, but no luck :frowning:

OK, thanks, it was worth a try.

Reporting: No Launch.
System: Dell Inspiron 5305, Intel G33 appears to be the graphics adapter
OS: Ubuntu ‘Trusty Tahr’ variant "Zorin-OS"
Browser: Firefox 47.0

Error message says it’s the WebGL. Not disabled in Firefox, but I think I do not have a specific driver (maybe using a generic one for Linux?) This may mean that it will not work on my Linux box.
(works great on my Windows 10 box)

All good here , all my.sketchup systems are GO!

No surprise. The G31/G33 series support OpenGL to v1.4 only. This does not even meet the desktop SketchUp’s minimum requirements.

See this Intel page under “Older Graphics Products”, 4th row in the table, for stats on the G33:


Other Intel users can check the newer generation tables above this “Older Graphics Products” table.

In December of 2011, an Intel employee (named Diego) answers a question, in the Intel forums, by a G35 chipset user:

Currently only the drivers provided for newer platforms like the Intel® HD Graphics 2000 and 3000 are optimized to support WebGL.

So at this point, [2011] the latest drivers that have been provided for the Intel(R) 3 series chipset controllers, like the Intel(R) G35, are not validated to properly handle WebGL and there is no estimated time to know when a new driver will be released to implement support on this over older platforms like the Intel(R) 3 and 4 series controllers.

We can “read between the lines” that there is no money in it (so no impetus) for Intel to update any of the drivers for legacy products. They would rather that the desire for WebGL support drive endusers to buy newer machines from OEMs, which drives computer OEMs to buy newer chipsets from Intel.

So generally for Intel, end users need a 2nd Generation CPU / chipset minimum (with HD 2000/3000 graphics or better,) which supports OpenGL 3.1 minimum.

Looking at the Khronos WebGL 1.0 Specification:

WebGL™ is an immediate mode 3D rendering API designed for the web. It is derived from OpenGL® ES 2.0, and provides similar rendering functionality, but in an HTML context.

So, also looking for a card that says it supports OpenGL ES 2.0 (or better) wouldn’t hurt.

Windows 7, NVIDIA GPU, i7 processor with 16 gig of ram - couldn’t get it to work in Chrome. Updated Firefox and it ran first time.

I’m using an AMD Radeon 7560D Graphics chip in my HP computer from 2013, and it doesn’t work in any of the web browsers that I’m using…unless I enable WebGL 2.0 in “about:config” using Firefox v47. If anyone is having issues trying to use My Sketchup, try enable WebGL 2.0.

Have you updated your graphics driver since 2013, or do you run AMD Catalyst™ Control Center?