SU2017 New Install with Load Errors on Plugins

rbe

#61

I have similar problem with error loading plugins with using the free version of SketchUp 2017.

I noticed that 2 of them are only available for Pro version - Advanced Camera Tools and Trimble Connect.

As I am not really interested in any of the 5 problem plugins, I simply turned them off and prevented the Load Error message from appearing each time I run up SketchUp.

Did this in SketchUp via Window > Extension Manager, Disabled the problem plugins and applied changes.


#62

Trouble loading LibFredo6 in Sketchup Pro 17 on Mac, OS X 10.12.5

Process:

  1. Removed all Fredo files from ~Library/ApplicationSupport/Sketchup17/Plugins
  2. Opened Sketchup and verified that all the plugins were gone
  3. Downloaded New version of LibFredo6 from Sketucation Website:
    https://sketchucation.com/plugin/903-libfredo6
  4. Opened Sketchup & Extension Manager
  5. Installed LibFredo 6
  6. Quit & restarted Sketchup
  7. Checked the Windows menu: There was no LibFredo6 configuration option
  8. Installed fredoScale. Quit & restarted Sketchup. Started normally
  9. Installed RoundCorner via the Windows->Extension Manager menu option.
    LibFredo 6 was properly in the list
  10. Quit & restarted Sketch
  11. Received an error message that said I needed to install Version 5 or newer of
    LibFredo6 to use Round Corner.
  12. Both LibFredo6 and Round Corner were listed as Active in Extension Manager
  13. NO configuration option in Sketchup’s Windows menu item.

What have I done incorrectly?
How can I fix it?

Thanks
Dave

The Error Dialog contains this information:

Error Loading File Fredo6_!LibFredo6.rb
Error: #<ArgumentError: invalid byte sequence in UTF-8>
/users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:314:in block (2 levels) in manage_compatibility' /users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:313:inforeach’
/users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:313:in block in manage_compatibility' /users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:309:ineach’
/users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:309:in manage_compatibility' /users/daviddeitrick/library/application support/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/top_libfredo6.rbe:150:instartup’
/Users/daviddeitrick/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:63:in process' /Users/daviddeitrick/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:70:inmodule:LibFredo6_Loader
/Users/daviddeitrick/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Fredo6_!LibFredo6.rb:28:in <top (required)>' Error Loading File Fredo6_FredoScale.rb Error: #<NameError: uninitialized constant Fredo6::Traductor> /Users/daviddeitrick/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoScale.rb:41:inmodule:Fredo6
/Users/daviddeitrick/Library/Application Support/SketchUp 2017/SketchUp/Plugins/Fredo6_FredoScale.rb:25:in `<top (required)>’


#63

did you update Round Corner?

the current version requires LibFredo v7.6 and runs on my mac…

john


#64

Hi!
Did this issue ever get resolved?
I’m new in this forum, but I’ve used SketchUp since 2013. Would not say I’m an expert user in any way. SU helps me with my home projects and I get the results I need out of it.
I’ve been upgrading both hardware, Windows versions and SU over the years, but not until a week ago did I run into problems starting SU, when it reported the error “Failed to read RBE/RBS file” for the standard extensions. Up until then, I had been running SU 2017 Pro 64-bit on my new PC with Windows Home 10, 64-bit fine for about a month.
The problem with the extensions started spontaneously and I’ve tried, but failed, to accurately correlate this to any software installations or upgrades I might have performed since SU last worked. After having found this forum, I’ve tried to follow up on some of the (in my opinion) relevant suggestions, and, since the issue manifested itself on a previously working setup, I went through the changes performed in the OS.
I came to the conclusion Windows Update had installed a number of patches around the time it stopped working. This lead me to suspect a .Net Framework related issue, and since .Net Framework is integral in Windows 10, not separately uninstallable, I decided to revert my PC to the backup I had performed the day I started up my new PC. Now I’ve recorded all the steps I’ve taken to install software, patches etc.
Once I installed SU I was glad to find the load error gone and SU started fine. After this, I painstakingly tested SU start and checked .Net Framework version in between almost every installation step of drivers, software and Windows Update patches. SU is still working. Mind you, my PC is still at version 1511, indicating it’s still pre-Creators update.

I will try to keep track of the development of my Windows Updates and report to the forum if my SU starts reporting load errors again.


#65

When you installed SketchUp did you do it in the correct way ?
Any other way can cause weird and unpredictable problems down the line - just like this…

The correct way…
Find the SketchUp installer’s exe file [probably in your Downloads folder ?]
Select the icon, right-click > context-menu > “Run as administrator”

This is the ONLY proper way to install all apps in Win 10.

Being an admin and double-clicking on an installer’s exe file is NOT the same thing.

If you think you didn’t install SketchUp correctly [or even as a fall-back position!], then close SketchUp.
Run the installer exactly as explained above.
When prompted choose ‘Repair’…

Restart SketchUp and see if it improves…
It can do no harm.


#66

Hi!
Thanks for your reply! I can’t say with 100% certainty how I installed SU prior to this incident, but I suspect I did not right click and choose “Run as administrator”.

This time out, after the restore and having read the forum, I did install as admin.

Next step is to install the creators update and see what happens :slight_smile: I’ll continue to keep track of the system changes and I’ll let the forum know if SU extension load starts acting up again.

Have a nice day!


#67

Hi!
Windows 10 Creators Update just got installed, which has taken the PC to the same OS version level as when the extension load problem occurred (Windows 10 Home, 64-bit Version 1703 OS Build 15063.540). Logging in after the upgrade, I checked the .Net Framework version and it has been updated to v4.7.02046, Release 460798.

I’m happy to say that SU started without any load errors :smiley:

@TIG, this supports the theory that not using administrative privileges at install might work initially but will likely cause problems down the line.

So, to avoid possible future problems with SU, use the following procedure to install:

Have a nice day! :sunny:


#68

I still don’t understand how exactly did you get SU working - loading plugins?
I also have Win 10 Creators Update x64 and I’ve tried all that you’ve mentioned and others to no avail, reinstalled it several times in fact but it still keeps on complaining about Plugin loading and no, I don’t have any foreign characters in my path, have run installer and even SU as Admin, tried reinstalling extensions from warehouse, version 2017 Make and/or 2018 Pro (trial), nothing helps and I’m sooooo fed up, wasted hours on this BS :frowning:


#69

here is what i did to solve it.
find the Sketchup.exe file. usually located in the C:\Program Files\SketchUp\SketchUp 2018
right click on it and go to properties
click the compatibility tab
at the bottom you should see Run this program as an administrator.
click the check box next to it and click apply then click OK.
that should solve your problem


#70

That didn’t help. I’m running version 18.0.16795 Pro 2018 64-bit.


#71

It is not recommended that you set SketchUp’s exe to “run as administrator”.
This cause some unexpected issues…
For example you can no longer use drag-n-drop for files like images into the SketchUp window - because Windows Explorer always runs at the base permissions level, and such a program is prevented from affecting any programs running at a higher level - as SketchUp would now be !
I recommend you ‘unset’ that option…

The correct [and only!] way to install SketchUp is to do the following…

Close SketchUp if it’s open.
Find the relevant installer exe file - probably in your Downloads folder ? - if not download a fresh version.
Select the installer exe file.
Right-click > Context-menu >
"Run as administrator"
If it’s already installed you will be prompted to ‘Repair’ - choose that.
Otherwise choose to ‘Install’.
After it completes, restart and see what happens.

If it’s an existing installation, and the issues still appear, try doing the above steps but this time ‘Uninstall’ and then immediately ‘Install’…

Any installed User’s Plugins etc should not be affected by this process.

Running the installer exe for any complex application, in the newer versions of Windows, must be done in this way…
Double-clicking the exe or choosing to ‘Run’ it - even if you have admin powers is NOT the same thing…


#72

Yeah, I saw and followed your earlier post saying that. I’ve done that a half dozen times, still the same errors. I’ve uninstalled and reinstalled. I’ve deleted the SketchUp 2018 directories in Roaming and Local. Still the same errors.


#73

Exactly what errors are you getting?


#74

Error Loading File C:/Users/me/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/me/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/me/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/me/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.


#75

Do the following…
Open the Extension Warehouse from within SketchUp v2017.
Choose to update the 4 extensions = advanced camera tools, dynamic components, sandbox and trimble_connect extensions.

New versions will appear in your User’s Plugins folder…
Unfortunately the old-of-date versions might still exist in the ‘shipped’ folder.
These could overwrite the latest versions in your User’s Plugins folder…

To fix this, without closing OR restarting SketchUp, open your User’s Plugins folder:
C:\Users\YourUserName\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins
and find the recently updated 4 .RB loader files [starting with su_] AND their matching subfolders:
It’s hidden by default but can be made visible by changing your Folder-Options, or pasting the full [corrected] path in a Windows Explorer bar…
Copy and paste these files and subfolders into this folder.
C:\Program Files\SketchUp\SketchUp 2017\ShippedExtensions
Restart Sketchup to see what’s what…


#76

I just noticed that you said SketchUp 2017. I’m running 2018.

Extension Warehouse gives me only an Uninstall option for those extensions.
Extension Manager gives me an Update button, but a barred (circle with a slash across it) icon when I move my mouse over it.


#77

To do the same process in v2018 you should simply substitute 2018 where my example file-paths say 2017 !
Sorry, I didn’t notice the version variance…
But I did assume some nouse…


#78

I assume “nouse” is due to spell “correction” :wink:
Yeah, I did the s/2017/2018/g

Any other ideas on what’s causing it? At one point, I tried Windows 8 compatibility mode. It didn’t work either, so I turned that off.


#79

Any new ideas? I’m dead in the water.


#80

Do you have the latest RB/su_ folders in v2018’s ShippedExtensions folder and your own Plugins folder ?
Are the security permissions to these two folders set sensibly ?
If you rename the user Plugins folder - say as PluginsOLD - when SketchUp next starts it should copy the ShippedExtensions folder’s contents across into a new Plugins folder, which it will auto-create for you…
If that has worked, then either reinstall your own custom extensions/plugins into this new Plugins folder, or copy then over from the old version…