SU2017 New Install with Load Errors on Plugins

rbe

#1

I upgraded from 2016 to 2017. Upon install I receive a load errors dialog box. I’ve tried uninstalling all plugins and restarting but they still reappear. These are the ones in “shippedExtension” folder. I’ve also tried uninstalling through the extension warehouse and then reinstalling. Problem persists and the tools are not available.

I’ve tried repair and reinstalling sketchup 2017 program but the issue remains.
What do I need to do to get this working?


#2

Here is the load error text

‘’‘
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.
’’’


#3

When you say uninstall an reinstall, do you refer to reinstalling the old unsupported version or downloading the new versions that are compatible with SU2017?


#4

At this point, I’m trying to just get the sandbox tools to load.
using extension warehouse i uninstalled all plugins. Restart sketchup and the plugins are back with load errors.

I manually moved the files from the Program files…ShippedExtensions Plugins directory to a backup location and restarted sketchup with no load errors. Then used the extension warehouse to install sandbox tools. When I try to access the toolbar menu then the sandbox tools does not show up at all. Restart sketchup and I have load errors again for this plugin as posted above.

What am I doing wrong here?

Thanks,


#5

This is not only with Sandbox tools. It is the same for any extension. I used the extension warehouse to install Artisan (2017) and I receive the same error.

‘’'
Error Loading File C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/DM_artisan/artisan_load.rbe
Failed to read RBE/RBS file.

‘’’


#6

Sorry if I mis read your post but, there are two flavors of plugins, one that comes with the native install of SU and those that are installed as " non native plugins"
Usually those that are native start with su_
So the question is: Have you been able to install Su17 stand alone and do the native plugins install OK.
You should not have to do anything special to do a stand alone install although make sure you have all the other extraneous stuff you have added is removed. . There is a new extension new to me “RBE” but maybe that is part of 17 , I have yet to try that install.


#7

To my knowledge, the trouble is with all plugins, native and non-native. I have completely uninstalled 2017 multiple times and with a fresh install as soon as I launch the software I receive the load errors on the following:
sandbox tools
advanced camera tools
dynamic components
trimble connect
web textures

If i install a 2017 plugin from the extension warehouse then it will just be added to the list


#8

When you install SU do you Right Click on the exe and choose, Run as Admin?


#9

yes, i install as admin


#10

When you have uninstalled, have you physically removed the plugins folder?
You’ll find it at
C:\Users\YOUR USER NAME\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Plugins
By deleting this folder the reinstall will reset the plugins.


#11

Did not work.

Uninstalled SU2017. Deleted %appdata%/Roaming/Sketchup 2017/Sketchup/plugins

reinstalled SU2017

opened the program with load errors on native plugins

QUESTION:
is 2017 installer reading from previous Sketchup installations? Do i need to uninstall previous versions?


#12

No it isn’t. You should be able to keep older versions without problems.

Anssi


#13

doing this breaks SU’s ability to load any plugin/extension…

never move or delete the program files…

repair your instal and try again using the extension manager…

john


#14

I have done that in the past except I usually create a new plugin folder and then just rename it say like plugin_a for the “old” one. Have you taken a look at the SU17 native plugin folder and the user one aslo with windows explorer make sure there is no "extraneous " stuff hanging around? Also is SU17 showing up in the control panel add and remove program list.

I advocate when doing trouble shooting make sure you are dealing with known baseline so, would suggest you get the plugins you moved back to where they belong and the base line SU used when they did regression test before this 17 release. If you canont get Su17 to run as released then I would ask SU folks what the #### is going on.!
BTW does SU16 still run ok??
I maybe in left field big time but my memory tells me you have to have one of those shipped extension since it activates the plugin folder for the user plugins in or is it the utilities , make face?


#15

@nzbt Does the install path for SketchUp 2017 include non-English unicode characters within it? Are you able to use the shipped extensions that come with 2017 in 2016? To do this you can launch 2017, copy the shipped extensions and place them within the correct 2016 plugin path.

Lastly, feel free to send me an email with these 2017 Shipped Extensions and I will check them out on my side.

Thanks

Jon
jon@sketchup.com


SketchUp 2017 Checkup
#16

I only did this temporarily to see if it had any effect on my problem as a troubleshooting effort. It is currently installed exactly per the exe files.


#17

Will you not then have files with the same name??


#18

I will have the same file names but this will allow me to eliminate a few edge cases.

Jon


#19

Jon:
I am completely confused now.

I copied the plugin files from my appdata 2017 shipped extensions to my appdata 2016 shipped extensions (after putting the 2016 files in a subfolder named backup). launched 2016 and received a load error on the files. So I’m thinking there’s something wrong with the 2017 files. I decided i’d see if my 2016 files worked in the 2017 folder. so I backed up the 2017 files and copied my 2016 files into the correct directory. When I launched 2017 SU i get load errors on those files also. Now the real kicker is that I have moved my 2016 backup files back where they should be, and removed the faulty 2017 files. Launch 2016 SU and now I’m getting errors on 2016 that I did not have prior to attempting this.

I’m stumped and have now successfully broken both versions of Sketchup.

My C: does not have alot of capacity so I typically install all my programs to my D: During an install i replace the default install drive location from C to D. This has worked for previous versions of Sketchup without any issues. The program is installed in D:\program files\Sketchup\Sketchup 2017. There are no special characters in my user name either.

I did uninstall 2017 from D and reinstall at the default location on C but the problem with load errors persist. At this point, I’ve uninstalled and reinstalled the program at least 10 times, including downloading the installation file again.


#20

I was able to fix 2016 by deleting the 2017 files from both the appdata/roaming/plugin directory as well as the d:/program files/Sketchup/shipped extension directory. So 2016 su is working again. yeah.

Here are the load errors from 2017 when the 2016 files were installed in the 2017 directory

‘’’
Error: #<LoadError: 126: The specified module could not be found. - c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/lib/1.0/win64/init_openssl.so>
D:/program files/Sketchup/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:in require' D:/program files/Sketchup/SketchUp 2017/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:54:inrequire’
c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/main.rbs:107:in init_openssl' c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/main.rbs:1348:inmodule:TrimbleConnect
c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/main.rbs:15:in <main>' c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/boot.rbs:25:ineval’
c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/boot.rbs:25:in require' c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/boot.rbs:25:inmodule:TrimbleConnect
c:/users/davidn/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/su_trimble_connect/boot.rbs:11:in <main>' D:/program files/Sketchup/SketchUp 2017/Tools/extensions.rb:197:ineval’
D:/program files/Sketchup/SketchUp 2017/Tools/extensions.rb:197:in require' D:/program files/Sketchup/SketchUp 2017/Tools/extensions.rb:197:inload’
C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect.rb:35:in register_extension' C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect.rb:35:inmodule:TrimbleConnect
C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect.rb:8:in <module:Trimble>' C:/Users/davidn/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect.rb:7:in<top (required)>’
‘’’