SU 2017 Make Extensions Fail to Load RBE


#1

Hi all,
Long time SU make user here and never had a problem until a couple days ago. I was updating to 2017 on my laptop running Win 7 Pro 64 bit (Intel HD 4000 graphics card). It gives me the popup after the splash screen:

**Note, edit to remove some path information below. they are in C:\Users<user> ***
Error Loading File /AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File /AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File /AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.

I have read just about every thread on this problem and none of the fixes seem to work. I installed with Run as Administrator, have tried uninstalling and reinstalling several times, I cleaned my profile, deleted the files in AppData – nothing. The software runs just fine with no extensions after the message, but I do occasionally use dynamic components and sandbox tools.

Here’s the kicker – it runs fine on this same machine on a local account (non-domain). No errors or warnings – it just loads. Problem is that my Dropbox and all other programs are configured for the domain account, so I’d rather make it work here.

So it’s something about my domain profile that is inhibiting the unpacking/decoding of the RBE files? if so, where do I start looking for answers.

Same version of SU Make 2017 running on a Win 7 Pro machine at home with no issues.

Thanks all,
Anthony


#2

It sounds like a permissions problem: Sketchup cannot read or write to the Appdata folder in your domain profile. When a new user opens SketchUp for the first time, it would create its subfolders inside his/her Appdata folder and install the application plugins there. Your local account seems to have this enabled.


#3

It’s a permission issue.
You MUST install SketchUp correctly.

Here’s the correct way…

Log-in as your normal user account [having admin powers might be useful on other occasions, but it’s not essential]
Close SketchUp if it’s open.
Find the SketchUp installer exe file.
It’s probably in your Downloads folder - if not re-download the installer.
Select the installer exe file’s icon.
Right-click > Context-menu > "Run as administrator"
The process starts…
When prompted choose “Repair”.
When it completes restart SketchUp and see it it helps.

Very occasionally a “Repair” is insufficient.
Run the installer exe [using ‘as administrator’ again] - this time choose “Uninstall”.
Go to: C:/Users/USERNAME/AppData/Roaming/SketchUp/
It’s a hidden folder - but you can change your Folder-Options, or go straight to it by pasting the full path into a Windows Explorer address-bar…
Find and delete the ‘SketchUp 2017’ folder to clear everything out…
Then re-run the installer exe [using ‘as administrator’ again] - this time choose “Install”.
That should ensure that all copied over files have proper permissions…

Installing complex applications - like SketchUp - in all newer versions of Windows - require that you use the “Run as administrator” method.
Installing it in any other way will cause subtle, unexpected and unpredictable issue - like flaky folder/file permissions, shortcut creation failures across sessions etc…
Running an installer’s exe by double-clicking its icon will not install it correctly - even if you are logged-in as your normal user and that account has admin powers.
Also never install any apps like this whilst you are logged-in using the separate ‘administrator’ account - that will cause different, but equally unexpected and painful problems !

I think that the local-account is the only good way - a domain-account needs administrator log-in and that will produce the other issues…

You should always work on local copies of files anyway, so set up your system to sync those back to your other ‘cloud’ folders. and link to those local ones directly…


#4

So my installation was done as Run as Adminstrator as were subsequent repair and reinstall attempts. My domain account has full admin privlidges on this machine and for most software I don’t even need to Run as Administrator it just does the prompt for ctr-alt-del for anything like an install or configuration change. But I saw so many other people with similar problems here that I distinctly ran it as Administrator.

My local account also has administrator rights.

For reference, I tried just running SU2017 as adminstrator and it had the same problem with the plugins.

If I delete the AppData stuff for Sketchup 2017 it recopies all the stuff the next time I launch it. So it seems like the program has some ability to read and write to the AppData folder.


#5

Why can’t you install SketchUp [in the correct way] into your local system ?
Having it installed in other ways is prone to permission issues - perhaps insolvable !

Your other files - e.g. saved models, materials, components etc can be kept anywhere - however, you should work on local copies - even if these are synced to be save to the ‘cloud’…


#6

I guess I’m confused here. I read over your instruction list and that’s what I did.

Normal account, file in downloads folder. Installed via Run as Admin (also repaired via Run as Admin and uninstalled as Run as Admin).


#7

I just tried it again from both the local account and the domain account. Both times run as administrator.

Same effect:
Domain account fails at the Unable to load RBE file popup
Local account opens just fine. Weird.


#8

So installing via the local-account works.
But installing via a domain-account fails.

Q.E.D. use a local-account…


#9

No, which account installs the software has no effect on the outcome.

Installed on local account:
SU fails to load extensions on domain account (my primary)
SU loads fine on local account.

Installed from domain account:
SU fails to load extensions on domain account (my primary)
SU loads fine on local account.

But I need it to run on the domain account to have access to other files and SW I’m usually running (like Outlook and Matlab).


#10

So it’s running it in an account that is not local.
It’s not the same account in the domain !
So you should expect issues…

As far as I know you can’t run SketchUp on the domain-account [also installing it in that way is best avoided].
Why do you need contemporaneous access to Outlook, Matlab etc whilst using SketchUp ?


#11

Sometimes I tinker on SU while waiting for matlab runs to complete or while waiting on e-mails or shared meetings (through Outlook). Plus all my shared and backed-up folders only work through the domain.

Also, this has never been an issue before. It wasn’t an issue for 2015 Make, 2016 Make, or 2018 Pro on this same machine installed from the domain account. It only became an issue when I decided not to keep 2018 Pro and just keep 2017 Make.


#12

Another data point.

I just reinstalled 2018 Pro from the domain account, Run as Administrator (as I installed it before about a month ago). It installed fine, but now the same “Unable to load RBE” error is appearing in 2018 Pro as well. it was not doing that last week before I uninstalled it.

So something is weird with my domain profile. Not sure what might have jacked it up. Any idea what OS modules or profile-related things would affect the reading/decoding of the RBE files? Any registry entries to look at?


#13

There is also something weird with your version 2018, Where did you bought it?


#14

Both the 2017 Make and 2018 Pro were downloaded from Trimble’s website.

Same installer used for 2018 Pro a few weeks ago (which worked fine) and yesterday (won’t load plugins).


#15

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.