Load errors

Error Loading File C:/Users/VasilisPC/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/VasilisPC/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/VasilisPC/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/VasilisPC/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.
what should i do i do have redownloaded it but nothing

This is odd. These are SketchUp’s own extensions and loads just fine for millions of users.

What SU version are you using? How long have you been using it? Have you always had this issue? If not, when did it start?

what do you mean su version where can i find this
also i did had it from the begining

I faintly remember reading about a similar issue that was due to not installing SketchUp correctly on Windows. Did you install by logging in as your normal user (not Administrator), right-clicking the installer and choosing “Run as Administrator” from the menu? If not and you can find the installer, you can fix things by do the above and choosing “repair” from the options offered by the installer.

2 Likes

I have the same problem since last night. I’m using Sketchup for more than 10 years and this is the first time of this annoying problem!
I did the recommendations above and didn’t work. :pensive:

I have a very similar issue today. Any fix for this at all? Trying the repair function when running as administrator hasn’t worked.

What error message are you getting exactly?

Does the error look something like this?

Error: #<IOError: The required, staged c extension file, “C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/ams_Lib/libraries/stage/win64/2.5/ams_lib.so”, is missing!>

C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/ams_Lib/extension_manager.rb:199:in `block in require_all’

C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/ams_Lib/extension_manager.rb:196:in `each’

C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/ams_Lib/extension_manager.rb:196:in `require_all’

C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/ams_Lib/main.rb:129:in `<top (required)>’

C:/Program Files/SketchUp/SketchUp 2019/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:59:in `require’

C:/Program Files/SketchUp/SketchUp 2019/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:59:in `require’

C:/Users/Chris.000/AppData/Roaming/SketchUp/SketchUp 2019/SketchUp/Plugins/MSPhysics/main_entry.rb:7:in `<top (required)>’

C:/Program Files/SketchUp/SketchUp 2019/Tools/extensions.rb:197:in `require’

C:/Program Files/SketchUp/SketchUp 2019/Tools/extensions.rb:197:in `load’

Because I’m having the same issue. Somehow it doesn’t appear to affect anything but it’s annoying.

And I’ve installed correctly and even did the “repair” also. So I’ll be following this thread for a solution.

@c_j_ryan have you tried updating Antons AMS lib and Msphysics?

2 Likes

No, but I will.

Or I’ll remove it from my extensions as I hardly ever use it.
Thank’s for the tip Box.

It turns out that MSPhysics and the Lib files were up to date, I uninstalled them, restarted SU and still got the error messages. This seems to be a carry-over from a post I made a month or so ago about “invalid paths” that I was never able to resolve. I’m going to re-open that, so I don’t hi-jack this thread.

Thanks though.

Any solution to this?

I don’t think that MSPhysics has be reworked to suit v2019, so you will get error messages when it tries to load the compiled code.
You need to uninstall it from v2019, and the ams_Lib stuff etc to clean up…

I’m having similar errors.

Error Loading File C:/Users/ … /AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Cadman_3DWarehouse/cm_3dwh_tools.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/ … /AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/Cadman_Draw_CL/cm_circum4.rbe
Failed to read RBE/RBS file.

Everything have worked fine in SketchUp Pro 2017, 2018 and 2019 until last few windows 10 updates (can’t think any other reason). Besides these errors I can’t install new extensions (.rbz) to any of these SU versions. This is not related only these two plugins, several others give also same error.

I have been trying to install as admin, run as admin etc. previously provided solutions. No solution so far. @TIG I have tried some of your methods from this and sketchucation-forum - unfortunately these haven’t worked for me so far.

I can’t install rbz-files from store or from files in 2017, 2018 or form 2019. Strange behaviour since everything worked just fine few Windows updates ago.

I just wanted to tell about my situation in hope that might help someone to find answer.

In your final paragraph you list various ‘tries’… but none that actually say the correct method…
Can I suggest that you ‘Repair’ your three SketchUp installations as follows…
Whilst logged into Windows as your normal user-account [whether or not this has some admin-powers is of no importance], ensure SketchUp is closed.
Now find the appropriate SketchUp installer’s exe file - probably in your Downloads folder ?
Select its icon, right-click > context-menu > “Run as administrator”
When prompted choose “Repair”.
Installing in any other way will cause permission issues with files and folders.
So never double-click an installer’s exe file to ‘Run’ it, it’s not the same - even if you have some admin-powers.

If you have previously messed around with the SketchUp.exe file in the Programs subfolder check to see that its Properties > Compatibility is NOT set to always ‘Run this program as an administrator’ - which in itself will cause issues, e.g. when its elevated permissions will clash with Windows Explorer’s lesser powers - e.g. blocking drag-n-drop functionality…

You could then also try reinstalling the problem extensions from their RBZ files, in case their files/subfolders etc have skewed permissions resulting from earlier installation errors…

1 Like

That last sentence in @TIG s comment… Few things to note. I have SketchUp Pro 2017, 2018 and 2019 installed on my system. All these have been working properly until few weeks ago. All of them stopped working at same time. There were no new installations or updates to any of these SketchUp versions. There weren’t also any plugin installations or updates to them that matter. All Installations and usage of the programs have been done with admin rights. There isn’t also no permission issues with user or relating folders.

After these errors I followed yours and few others repair instructions without success.

Luckily I have opinion to use SketchUp Pro 2019 in other computers so I have time to wait answer. Only downside is that I can’t install 2017 or 2018 versions to other computers and so I lose many plugins that work properly only with these versions.

How ever I’m very interested to find out what prevents loading or installing RBZ files in all these SketchUp versions.

Could be a Windows update which has compromised user-permissions on SketchUp’s files and folders, or your user-files/folders - e.g. Plugins…

As you do have a working PC and a troublesome one, can I suggest that you get Properties > Security for the Plugins folder on both PCs and compare the settings…
Typical path is:

C:\Users\YOUR_WINDOWS_USERNAME\AppData\Roaming\SketchUp\SketchUp NNNN\SketchUp\Plugins

NNNN will be the SketchUp version - e.g. 2019
[this folder is hidden by default, but accessible if full path is pasted into a Windows Explorer dialog]

‘Full’ is typically set for all permissions for all those accessing that folder…

PS: Also check this folder:

C:\Users\YOUR_WINDOWS_USERNAME\AppData\Local\VirtualStore

In case Windows is over zealously sidelining files…

@TIG Thank you for quick answer.

I have already previously checked Appdata\Roaming\SketchUp XXXX permissions in my SkechUp versions. In all computers that I use I cross checked permissions and settings are same, nothing to fix there. VirtualStore -folder permissions are also in order.

Even though the error messages show pathstrings with forward slashes, sometimes “behind the scenes” backslashes get used in the paths instead, which can lead to issues as Ruby sees backslash and it’s following character(s) as an special escape sequence.

We’ve had numerous issues recently especially with pathstring that contain a "\u" (which is a escaped unicode character) … ie … if the “U” in “users” is lowercase in a path …

"C:\users\%USERNAME%\AppData\Local\Temp"

… has no problem used in Windows FileExplorer address bar, but Ruby double quoted string interpolation sees the "\u" as the start of a unicode escape and would case a SyntaxError (which if suppressed,) a string that does not point at a valid file location.


@jpvikholm What character does you username begin with ? If it is one of a special few characters such as “r”, “n”, “u” etc. this can cause issues in pathstrings that use backslashes.

@TIG I also see a weirdness in the use of "\cm" as begins the Cadman’s filenames, ie …

filepath = "Somepath\SomeFolder\cm_circum4.rbe"
#=> SomepathSomeFolder
#=> _circum4.rbe
filepath.inspect
#=> "SomepathSomeFolder\r_circum4.rbe"

The escape sequence "\cm" is transcoded to "\r" which is carriage return.

@DanRAthbun Greetings. My username is “Jukka-Pekka Vikholm”. As mentioned this haven’t caused problems previously. I will create new account to this computer, test SketchUp installation and get back in few moments.