2017 - errors loading plugins

2017
error
sketchup
plugin
rbe

#1

Just installed 2017 Make, still in 30-day Pro trial period.

On launch, I get these error reports:

Error Loading File C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.

All the files exist in the locations given, but SU won’t load them. I’ve downloaded afresh and re-installed several times with no variation or improvements. The Checker found no problems.

2016 ran fine with no problems like this at all.

What can I do to fix this? I need to use the Sandbox Tools plugin, in particular.


#2

This is indicative of SketchUp not being properly installed.
I guess you double-clicked on the installer’s icon or ‘ran’ it ?

The correct way is to ‘Run as administrator’…

You can probably fix it without having to uninstall and reinstall.
Here’s how…
Close SketchUp.
Find the SketchUp installer exe file - it’s probably in your Downloads folder.
Select the icon, right-click > context-menu > ‘Run as administrator’…
When prompted choose to ‘Repair’…

This should fix permissions and get SketchUp running properly - at least with that problem sorted.
There might also be Graphics Card [settings] issues… but you’ll know if you have those soon enough…


#3

Thanks, but I did install as Administrator, several times. I also tried ‘Repair’ with the same zero result.

I’ll uninstall, clean up the Registry, and try again.


#4

SketchUp copies its ‘shipped’ files [those listed in the error message starting with su_…] into your Plugins folder [if they don’t exist or they are not the latest copies]… and then loads them.
It might be that the initially copied files have permission issues, and reinstalling may not help because those in your Plugins folder are not affected by the re-installation process, and have not changed contents either.
Also, even a full uninstall will leave them behind inside your Plugins folder.

So can I suggest you try this…

Close SketchUp.
Open your Plugins folder [ C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins ]
Find all RB files in it with names that start with “su_” AND ALSO all subfolders with the same names.
Manually delete them all.

With SketchUp installed using ‘Run as administrator’, launch SketchUp.
You should now see the ‘shipped’ contents recopied into your Plugins folder, and hopefully their permissions issues are now side stepped ? They should load OK ??

Report back…


#5

Alas, it made no difference.

So then I completely uninstalled, deleted the entire profile left behind, then reinstalled (as administrator) again, and it still made no difference.

Completely deleting SU Make 2016 also made no difference.

I’ve checked the file and folder permission settings, but everything is fully accessible.

I’ve also installed several other plugins. Ones with .rb files install fine, but .rbe files do not. This suggests to me that file permissions aren’t the problem.

I’ve seen a suggestion that having non-latin characters in one’s account name might be the problem, but I don’t have non-latin characters in my account name.

I can’t find any mention of the “Failed to read RBE/RBS file” error in the knowledge base, but I’ll keep looking.

Many thanks for your suggestions, all the same!


#6

Aha, I found a couple of related threads. So far, no resolution published.


#7

I have read elsewhere that this one can (perhaps?) fix this by downloading the latest version of Advanced Camera Tools from the Extension Warehouse. But (I’m quoting from memory) this may only apply to SU 2016 problems with this plugin.

If Sketchup is otherwise loading, you could just try disabling it in the Extension Manager and see if that stops the error message.

And/or install the latest version?


#8

Let’s go back a few steps - the error is in reading the su_shipped RBE - e.g.
C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Let’s check it exists…
Open the Ruby Console and paste this in + [enter]

File.exist?("C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")

Does it return true or false ?

Can you get it to run manually ?
Open the Ruby Console and paste this in + [enter]

Sketchup.load("C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader")

Note the final .rbe is omitted with the ‘load’ method !
Any messages back ?
Does it load ?
Try with some others like
C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe


#9

File.exist?(“C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe”)
true
Sketchup.load(“C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader”)
File load error (C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe): Failed to read RBE/RBS file.
false
Sketchup.load(“C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus”)
File load error (C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe): Failed to read RBE/RBS file.
false

No joy.

How does one report a bug?


#10

Can you select one of the working RB files and right-click > context-menu > Properties > Security
and note the Permissions of each of the users listed [with names]…
Then do the same for one of the RBE files that is not loadable.
And finally for the su_subfolder containing that RBE file.

On my PC all three have the same users and permissions set up.
And of course I have no issues with loading anything either…

There must be some differences in your particular Seuirity/Permissions set up preventing success…


#11

Alternatively, you could try

File.readable?("C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")

and

File.readable_real?("C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")

#12

File.readable?(“C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe”)

true

File.readable_real?(“C:/Users/David/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe”)
true


#13

There are no differences in users or permissions between SandboxTools (won’t read) and Utilities (works fine).

I don’t think it’s a file access problem. I suspect it’s a file encoding problem.


#14

The readable tests shows your RBE files are readable.
On my PC [and on thousands of others] those files are read and load just fine, but for some obscure reason on yours they do not load.
This suggests an error in the file de-coding on your PC - which brings us full circle - as this is indicative of issues with SketchUp.exe - perhaps due to an initial mis-installation… but there can be other causes…

So let’s now consider issues with the supporting Microsoft C++ Libs.
This has been suggested in another thread …
The fix for a crashing issue was to reinstall the C++ libraries:
This was likely to be related to a bad version of the C++ distributable libraries being installed on a particular PC.
If you have version 14.0.24210 installed, that is a likely culprit [mine is 14.0.24215].
This was believed to be a “bad” version of the C++ libraries which caused SkethcUp.exe flakiness, and also wreaked havoc with other programs as well.
The suggestion was to Uninstall any 14.0.xx versions of the libraries - using Control Panel > Programs and Features

  • and then to reinstall SketchUp again - downloadable from: http://www.sketchup.com/download/all (this version re-installs the right libraries)
    It looks like that a distributable which was updated mid-December may be causing weird issues…

While this might not fix your particular issue, it can do no harm…


#15

Thanks, I’ll give it a go.


#16

Well, that didn’t make a blind bit of difference. In fact, nothing I’ve tried so far has.

Looks like I’ll have to give up on SU 2017 and go back to 2016, if I can re-install it.


#17

I have tried all of the things that dmore has, and have also had no success. I have the full version of Sketchup Pro 2017, but I didn’t install it until after the creator update for windows 10. Permissions are all good, all these things happen:

File.exist?("C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")
true
Sketchup.load("C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")
File load error (C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe): Failed to read RBE/RBS file.
false
Sketchup.load("C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader")
File load error (C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe): Failed to read RBE/RBS file.
false
File.readable?("C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")
true
File.readable_real?("C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe")
true

Some plugins load just fine, but none of the ones starting with su_, and I’ve manually set the file permissions to be as permissive as possible to all users and administrators on that folder as well as the install folder (default location on C drive). I’m a software developer, and I’ve got the various latest versions of .NET and the C++ libraries, etc. I don’t know Ruby terribly well, though, and when I open the rbe files in notepad++ all I see is data that’s clearly serialized. So it seems to be having some sort of trouble deserializing, or otherwise causing an issue with executing whatever it finds inside.

I would suspect the .NET version 4.5.2 not being available on my machine as the culprit, since I have mainly 4.6 and so forth on there. However, I do have 4.5.2 Multi-Targeting Pack, and then the SDK for 4.6, 4.6.1, and 4.6.2. Along with multi-targeting packs for them (there are actually two per version – ENU and nothing specified). Deserialization in .NET can be flaky if it’s super version specific and actual objects are being serialized via automated methods versus by explicitly overriding the serialization methods and then just using simple types. I tend to roll my own serialization for that very reason.

A number of plugins work fine, though, like 1001 engineering, the 3D Connexion mouse driver, most everything by ThomThom, and a few other things.

Things that do NOT work, in addition to the default sketchup plugins that people are routinely having trouble with, is the demo of Profile Builder 2, the demo for playup tools, and the eneroth townhouse system beta.

I did install it as administrator originally, I have repaired it as administrator, I’ve uninstalled and reinstalled as administrator, I have not migrated from another computer or version of sketchup (although an expired version of 2016 pro trial was on this machine), I have manually verified all the permissions are fine in the install location and appdata/roaming location (used to be a network admin, I propagated the permissions down and all that jazz), and everything else I can think of. When deleted, the always-included files get added back.

I get the errors:

Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.

Unless I disable them. Disabling them in any combination doesn’t seem to work, unless they are all disabled.

Unless there’s a third folder tree that might have permissions issues, to me it looks like a very specific version of .NET is required or else this thing goes bananas. And specifically, anyone who installs this after already having Visual Studio 2016 or the Windows 10 Creator Update installed is going to be locked out of these particular plugins. Unless there’s some other voodoo I’m missing. :wink:


#18

Honestly, the fact that these two don’t work is what bugs me the most:

Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/DM_ProfileBuilder2/pb_load.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/User/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ene_buildings/main.rbe
Failed to read RBE/RBS file.

I even tried going back to the 2016 version of sketchup, but I don’t have a license for that (just 2017). Blah.


#19

When you installed SU2017, did you right click on the installer and choose Run as administrator? Logging in to the computer as administrator or having administrator privileges is not the same. Failure to install with Run as administrator from the context menu create all sorts of weird problems. To make sure it is installed correctly, find the installer and use Run as administrator. Then choose the Repair option.


#20

Yep, I did, and yep, I know.

I’ve done that, as well as a full uninstall and reinstall with run as administrator on. I’ve also manually added more permissions to the two relevant folder trees that I’m aware of (the install location for sketchup, and the roamingdata location where other sketchup data and plugins are located).