Sketchup Pro 2021 Windows Error Loading default extensions

User is receiving “Failed to read RBE/RBS file errors” from the four default Trimble extensions as soon as he tries to open or create any project.

Following tips from other posts with the same issues he has performed the following actions:


Uninstalled SU 2019 and 2021

Deleted any program files I could find, including those in C:\Users\Work PC\AppData\Roaming by deleting entire “SketchUp” folder

Did search on C drive for anything “SketchUp” – no program files left.

Restarted my PC.

Downloaded SketchUp from link provided by Educandi.

Ran the installer as Administrator by right-clicking.

SU installation completed. Did not run SketchUp initially.

Instead, first checked the AppData Roaming folder where there has been the “SketchUp” folder containing the extensions/plugins. Result: it’s empty (no SketchUp folder)

Now running SU for first time by double-clicking on SU desktop icon. Accepting T+Cs.

Sign In pop up appears and I click Sign In.

Web browser pops up and I sign in with my Trimble credentials.

SU starts after credentials confirmed.

I select a blank new project. Load errors appear.

image

Roaming folder now contains a SketchUp folder.

Inside that folder are now the plugins which SU cannot read and therefore creates the load errors.

image

It appears as if that folder gets populated automatically through the web. Something in my license / account setting must tell SU to insert those plugins every time I start SU.

Even if I uninstall those plugins either through the Extension Manager or by deleting the files directly in the folder, when I re-start SU, they are back but SU cannot read them.

Also tried uninstalling the plugins using Extension Manager before installing them again using Extension Manager – same load errors appear.


I note that none of the other posts with these symptoms contain a fix, most are closed after lack of activity. Is there a fix for this problem? Any suggestions on next steps?

Thanks

Geoff Powell, educandi

The shipped extensions are in this folder:

C:\Program Files\SketchUp\SketchUp 2021\ShippedExtensions

They get unpacked if there are missing. If you don’t need those features you could delete the copies of the extensions in that folder, as well as in the roaming folder. Then they will be gone.

But, the actual problem is that RBE files are failing to be read. I know that in some cases the problem only shows for non-admin users, you could try doing a run as admin on SketchUp itself, and see if the errors still show up.

Someone else who had the problem found that cloning their current user gave a new user that didn’t have the problem. See this post:

Shouldn’t have to buy software to solve a problem with installing Sketchup and as stated in that clip “it’s still unclear what actually was causing the problem” and “it seems that some other things are broken after cloning that user profile”

Latest information from user…

I actually originally had SU 2019 and then installed SU 2021 – I basically skipped the 2020 version. I have already uninstalled the 2019 version.

Casting my mind back, I think I kept getting those load error messages with the 2019 version too. They just started to appear out the blue after around one year of not having any issues. They then kept coming up every time I ran SU but I just ignored them.

However, I’d like to get to the bottom of this issue now, as I think that something doesn’t seem right. Also, I’m keen to start using one of the plugins that are not working, which is the Sandbox one, as this enables me to create organically shaped objects.

System info…

How did the test of running SketchUp as admin go?

Waiting for feedback on that. Information above is from yesterday’s suggestions & questions.

#1 Running the SU 2021 .exe file as administrator: Problem persists

#2 Permissions in Plugins folder: Same as yours

This has WORKED: Deleted files in “Shipped Extensions” folder before deleting the same in the “Roaming – Plugins” folder.

Upon running SU subsequently, the load error messages are gone.

HOWEVER, I then installed Sandbox from Extension Warehouse. Upon re-start of SU, there is a load error again (see below) – even if run as Administrator.

Interestingly, I also installed another random plugin from Extension Warehouse (TrueBend) and that works fine (not coming up in load error pop up).

Judging from this, it seems to be an issue with those particular plugins (Sandbox, Dynamic Components, …).

There must be a reason why those particular plugins don’t run on my PC – maybe they are missing a particular environment / codec something along that line?

At least I know how the get rid of those pesky load errors for the time being.

TrueBend does not use RBE files, I think that any extension that does use RBE will fail. So far my guess is that there is a system security setting that prevents the decryption code from working.

I have asked the developers about this in the past, I will see if any of them have more ideas about the problem.

Latest feedback from user:


I created a local user in Windows and allocated Adminstrator rights. When logged in as this new user and I start SU, it loads fine with the previously problematic plugins loaded and working. I even don’t have to start SU as an Administrator for it to work.

I also did not have to re-install SketchUp for this new user. There was a SU desktop shortcut when logging on as the new user so I just double-clicked on that.

That suggests to me it must be down to Windows settings but I would not have a clue which ones to adjust to make SU work in my original user account.

Whilst I am glad that I managed to solve the problem like this, it is frustrating, as not all programs and files have been carried over to this new user. So every time I want to use SketchUp, I now have to switch user. Not sure if there is a way of migrating everything over to this new user account … I appreciate that’s no longer a Trimble related issue though.

From what I could gather reading through various forums, there does not seem to be a proper fix to this issue. People have just worked round it like myself with some even deciding to format their harddrive and install everyting again from scratch.

Just some food for thought directed at Trimble:

Whilst I appreciate SketchUp’s versitality and ease-of-use, this issue makes me a bit nervous. This is because I don’t know what potentially could cause SU to no longer be able to read those extensions again in future.

As mentioned before, SU worked fine initially and then developed those load errors. As I did not pay much attantion to this when it first happed (did not need those extensions at the time and just wanted to get an assignment finished), I failed to correlate the event to a potential cause such as Windows updates etc.

I hope Trimble will try to get to the bottom of this and maybe issue some official recommendations, a guide to fixing the issue or a software patch.

I am going to see how I am getting on having this dedicated user account for working with SketchUp. If it is too cumbersome, I may decide to wipe my drive and install from scratch like some others.


Seems to me like there’s a glitch in the Sketchup software somewhere which is intolerant of a particular Windows setting or configuration and not a new glitch as it’s been around for quite a while (at least since Sketchup 2019) and a few people have been tripped up by it. My suggestion would be for Trimble to buy my customer’s PC from him and start testing to get to the bottom of this issue. In this case we have a technically proficient user who can and is willing to rebuild his computer to solve the problem, someone less technically proficient would probably just demand a refund and go elsewhere.

The Windows setting you are referring to is a “corrupt Windows user account”. Creating a new one is the “repair”. This is not unheard of. Google will produce many results of this happening.

It even might be a registry setting altered by another application, like Google earth.
They share a history, I believe.