SU2017 New Install with Load Errors on Plugins

rbe

#21

Thanks for the additional information. I would not expect the Trimble Connect Extension to work going 2016 to 2017 so we will hold off on that for now. I am actively looking into this and will let you know as soon as I have more information.

Jon


Sandbox extension trouble?
#22

Finally loaded su2017,
added all the 2017 plugins into a place holder plugin folder in 2017 user location [ Note :I orginally installed su2017 in my D solid state drive but at first glance I did not see “user” folder so deleted Su 2017 and reinstalled on C drive;
,copied all the my 2016 user plugins into 2017 user location by folder method vs individual file sa I noted above.
restarted su and got number of load errors similar as shown in nzbt post .
However, many of those plugins were reporting issues they did not pass checks Trimble has implemented in this 2017 latest release.
Look at extension manager and you have three options of class of plugin you will load.I selected for this check lowest #3 not wanting to get side tracked with plugin issues.
My bottom line to date: SU working ok, loading plugins ok, make sure your plugins are up to date; make sure install of drive other than C gives you the correct file tree. Needs recheck here


#23

I’m not sure if my comment will be useful but I have noticed a similar problem with one of my rb files where it appeared that when transferring files between plugin directories the odd line feed got inserted in the text file which affected the parsing of the file. When I corrected the .rb file by deleting the errant line feed the problem was solved. I realise that this will not apply to .rbs files.


#24

Did anyone ever figure this out? I have uninstalled/reinstalled everything, and I still get the same error about not being able to load the embedded plugins.


#25

Did you select the SketchUp installer exe file’s icon, right-click > context-menu > “Run as administrator” ?
If its currently installed choose ‘Repair’.

Installing it any other way can cause issues with permissions, so perhaps this is affecting your loading etc…


#26

Yes I did. The only thing I am doing a little differently is installing on my D drive, which I noticed that mac7595 also did. Is there a possible problem with that?


#27

Open the Ruby Console and paste this text in + enter.
Sketchup.find_support_file(“ShippedExtensions”)
What does it return ?
C:/Program Files/SketchUp/SketchUp 2017/ShippedExtensions
or
D:/Program Files/SketchUp/SketchUp 2017/ShippedExtensions
??
That folder contains the su_ files which are copied over into your Plugins folder…

Now this…
Sketchup.find_support_file(“Plugins”)
Returning something like
C:/Users/YOUR_WIN_USERNAME/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins
??

Open your Plugins folder and check that the su_ files and their subfolders are there ?


#28

In my case, I had a problem with my Windows installation which had to do with encryption errors. The solution for me was to reinstall windows which did solve my issues. The Sketchup support team was successful in diagnosing this which solved other issues I was having with other software packages like Adobe Creative Cloud. I’m very thankful for their help.


#29

Thanks. I’ll try this tonight when I get home. For what it’s worth, I tried the install today on my work computer (Windows 10) on the D drive, and I didn’t get the error. So I don’t think the D drive is the issue.


#30

Sketchup.find_support_file(“ShippedExtensions”)
D:/Program Files/SketchUp/SketchUp 2017/ShippedExtensions

Sketchup.find_support_file(“Plugins”)
C:/Users/lloyd/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins

Both folders look fine. (sigh)


#31

Can you also check the Properties > Security permissions for both of these folders…
SketchUp needs to be able to read from the Shipped… folder and copy its contents [su_… files/subfolders] into the Plugins folder, then load those scripts which in turn use the contents of their subfolders…


#32

Both directories have full permissions enabled to all users.


#33

If you delete the su_ files and folders from Plugins, does SketchUp fully copy them over from the Shipped… set ?
If so what are the permissions of those copied files, subfolders etc


#34

Yes, it copies these folder, and it looks like all of the permissions are full control.


#35

@ChrisFullmer ???


#36

Yeah, I have the same problem described here and none of these solutions have worked either. It may not be a universal problem, but it appears that there is an unresolved issue here for many users. For what is worth i have both C++ versions 14.0.24215 and 14.0.23026 on my windows 7 64 bit system (as this issue has been quoted as related in other posts).


#37

Persistent errors on 2017 install. Running exe install as admin has been tried multiple times, permissions on su shipped extensions are allowing full control and still i get this on start.

Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/enscape/loader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/o.calderon/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.

Help!


Installation is exiting
#38

Close all applications.

Uninstall both of these C runtimes from the Control Panel > Add or Remove Programs.

Reboot Computer

Go to Part 5 of the pinned post:
Important Update on a few Potential SketchUp 2017 issues on Windows
and get the help links to reinstall the latest C Runtime and dotNET libraries direct from Microsoft.
(You can also see previously pinned post 2017 not launching.)

Reboot Computer

Reinstall SketchUp 17.2 (by right-clicking installer and choosing “Run as administrator”.)


#39

sorry Dan, but already tried this solution. My .Net library happens to be a more current version than the one advertised in that post. and i did the direct download from Microsoft on the C runtime libs. i’ll try it one more time and report back.


#40

I am finding that if your .Net version is newer than the one Sketchup 2017 needs (mine is 4.6.2) then you are out of luck. .Net won’t install an earlier release of itself…