SU2017 New Install with Load Errors on Plugins

rbe

#41

Hmmm,… then perhaps SketchUp has issues with newer .NET versions ?


#42

Confirming now, tried the stepts layed out in the solution posted. No go. still doesn’t work. Shipped extensions are not loading.


#43

@mchandler or @jon would this possibly work:

  1. Uninstall the newer .NET version & reboot.
  2. Install .NET 4.5.2.
  3. Re-Install SketchUp 17.2.
  4. Then upgrade .NET to newer version.

:question:


#44

There is a bunch of shotgun debugging going on here. Is there anywhere we can get more details about why we get the “Failed to read RBE/RBS file” messages? More diagnostic information would really help narrow down why we are failing. It may be an uninstalled dependent assembly, but unless we have more details about what happens during the loading of a plug-in, we’re just taking potshots in the dark.


#45

@rflloyd If you are asking me, tell me what info to gather and i’ll happily supply it. Otherwise i am just guessing at your meaning.


#46

The error simply says unable to read. What specific OS operation was the software attempting to do? Simply open a file for reading? Or is it trying to load an assembly/executable? What is the actual exception code coming back from OS? This might help figure out why it is not loading.

The software knows a lot more about what is going wrong, but if there is no way to improve the verbosity of the error reporting, then the details we need are just getting trashed.

I would think this would be meaningful to whoever is in charge of the Plug-In manager. Do we know who at Trimble this is?


#47

As he said above, @jon is aware of the issue, and is looking into it.

The message box means that the SketchUp code is trapping the error (which is better than the application crashing.)

I’d guess (because we’ve seen some other SketchUp error message boxes on file errors) that it is a CFileException, but do not know what the error code is. (Perhaps check your WER reports in Event Viewer ?)

I believe the core startup routine (where it iterates the “Plugins” folder and loads extensions,) was attempting to read the RBE encrypted file(s) into memory in prep for decrypting it, so they could subsequently be loaded into SketchUp’s Ruby process.

There have also been some reports that the shipped extensions are not getting copied to the users %AppData% “Plugins” folders (from the “ShippedExtensions” staging folders in SketchUp %ProgramFiles% path. Ie, the application binary directory.) This is usually due to a permissions issues resulting from installer issues, most usually not being run as administrator.

Errors with this step in the SketchUp startup routine are not new to v2017. They also occurred under certain circumstances in v2016 (when RBE was first “rolled out.”) If I remember, one hiccup had to do with special (or unexpected) characters in the username which is used in all %AppData% path strings. (I thought that one was fixed.)


#48

I was just opening sketchup and the message that it can’t read the shipped extensions pops up. It appears to work fine after that but without any of those extensions loaded.

Omar


#49

So far we are getting very few of these exact reports and we are completely unable to reproduce this in our testing. Can you help with answering a few questions?

What version of Windows?
What is your install path for SketchUp?

Also, we had seen this same issue previously for users who were logged into windows on a guest account. We had fixed that version of this problem, but perhaps there is some other setting on your user account that is causing problems? Do you know if you are admin, or if you are logged in as a Guest, or some other similar type account that does not give you full user rights?

Chris


#50

@ChrisFullmer, He’s on Win7 Pro.
And take note he has a newer version of .NET installed than most people do.


@penumbradesign, I’d recommend running Checkup 17.2 and post the .sulog archive here in this thread.


I’ve seen situations where the normal user account had gotten corrupted (somehow.)
An easy test is to create a new user account (name it “Test”) and then try to run the problem application after logging into this test account. (You can always delete the test account at any time later.)


#51

Windows 10 Pro Version 1607 (OS BUILD 14393.693)

D:\Program Files\SketchUp\SketchUp 2017\

Based on above comments, one thing that might be a factor is that this is a new computer, and I copied my account over from an old (Windows 10) computer using a windows transfer utility. One strange thing that came out of that was that my user account name is Bob, but it points to C:/users/rlloyd through a link. And this is an administrator account.


#52

Yesterday I had a French user with loading errors with my plugin. On their machine the user name included a space and also a French character.

Windows 10 and Sketchup 2016

I copied a 2 line file called loader.rb into the plugins folder
require 'sketchup.rb’
require_all(‘c:/users/public/documents/sketchup’)

And then I created the folder ‘c:/users/public/documents/sketchup’ and moved the plugin into the newly created folder.

When I started up Sketchup everything worked.

At home I duplicated the folder naming but I couldn’t get it to error out.


#53

Windows 7 enterprise 64bit
My credentials have admin rights in the computer
Install path is C:\Program Files\SketchUp\SketchUp 2017 (default path)
.net version is 4.6.x

Omar


#54

posting result of checkup and log file.SketchUpLog.sulog (156.5 KB)


#55

Windows 7 or 10 do not exposed the elevated admin user rights when you log in.
Check either the w7 or w10 forums.
The install instructions for SU usually tell to run as admin but that does not even put you at the root level.


I have not checked that link lately hope it is still good. There is similar one in w10 forum also


#56

Seems like too many machinations to make the thing work, doesn’t it?


#57

Get grumpy with malevolent hackers, virus/spyware-coders, etc for this file permissions stuff. The OS is trying to ensure a responsible person is allowing changes to the OS.

Did you try creating a new user account to test if file permissions were corrupted in one’s user account as @DanRathbun suggested? This stuff does happen - not often, but it does happen. And IF this is the problem, it’s possible to identify and reset file permissions on the affected file. I found this article which helped one SU-user who was getting a Windows error message about inadequate file permissions on Windows OS files which prevented him from running SU.


#58

ok, reporting back. since my last post i had our IT group refresh my profile. that appears to have done the trick. @ChrisFullmer a thanks for the suggestion.


#59

I too have these issues after a new install I get the same errors loading plugins. I have checked the locations and the files are there and should load but will not.

Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/builder/builder-code.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/dtaylor/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/su_webtextures/webtextures_loader.rbe
Failed to read RBE/RBS file.

Thanks, Dave


#60

There are several similar reports - search the forum’s posts.

One thought, did you install SketchUp by selecting the installer’s exe file icon, right-click > context-menu > 'Run as administrator’
If not, then lots of unpredictable flakiness can result.
Running it by double-clicking the icon is NOT sufficient to make proper installation - even if you have admin-powers…

You probably don’t need to uninstall and reinstall SketchUp…
Firstly try this.
Close SketchUp
Run the installer as administrator.
When prompted choose ‘Repair’.
Any better ?

If not then you need to [using Run as Admin’ again] try ‘Uninstall’, then immediately ‘Install’.
Any better ??