SketchUp (desktop version) thinks you don't have an Internet connection

Since about a month ago there has been an increase in the number of forum posts and support requests, where SketchUp is showing a message about how you need to have an Internet connection to do that feature. The features affected would include Add location, Generate Report, 3D Warehouse, and Extension Warehouse. It also would prevent you from being able to add a Classic license, or use an existing Network license. Some extensions may be affected too, if they rely on having an Internet connection (to check the license for example).

The problem doesn’t affect version 2019.3 and later, but could affect 2019.0, 2019.1, and 2019.2. It definitely affects 2018.

The issue appears to be the URL that SketchUp uses to test whether there is an Internet connection. For 2019 and later you can read this article to see how to edit the URL that is used:

https://help.sketchup.com/en/sketchup/cant-connect-web-tools-3d-warehouse-extension-warehouse-add-location-and-licensing

Look for the part that includes "OnlineTestURL": "",

The suggested URL in that article is for cases where you have an Intranet, and can use that as a way to test for a connection. The URL used in 2019.3 and later defaults to bing.com. If you wanted to make an earlier version of 2019 match the 2019.3 version, you would change the line to be like this:

"OnlineTestURL": "https://www.bing.com",

If the line doesn’t appear in the Preferences section, go ahead and add the whole line.

For SketchUp 2018 the URL is stored in a different file. On Windows the file is here:

C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US\i18n.dat

The “en-US” part may need to be changed for other languages. You can edit that file with Notepad, and you will see this line:

ONLINE_TEST_URL=http://www.google.com/ncr

Edit that line to change the address that is being used:

ONLINE_TEST_URL=https://www.bing.com

SketchUp should then be able to see that you are online.

For Mac users, use the Go menu in Finder, Go to Folder… and paste in this path:

/Applications/SketchUp 2018/SketchUp.app/Contents/Resources/Content/Resources/en-US/i18n.dat

Again, the “en-US” part may need to be changed. On Mac you can edit that file with TextEdit.

Many people reporting the problem have seen success when making this change.

One reporter did have to ask IT to whitelist the alternate URL that they had used. bing.com in their case.

Some people have had a permissions issue in modifying the .dat file. An easy solution is to right-click on Notepad, even in the Start menu, and use the run as administrator option. Then it seems to be able to edit the file and save changes.

There has been one report where https://www.bing.com did not work, but https://www.bing.com/ did. There should be no harm in using https://www.bing.com/, so you could try that first anyway, even if you weren’t going to see that problem.

A second person reported needing the trailing /, but only on a Windows 7 machine. So, both reports of needing that are from Windows 7 users.

5 Likes

btw, an online check which:

  • uses a URI with a deep link ("google.com/ncr") instead of a less error-prone domain only
  • doesn’t check with a second or third domain if the first one fails
  • cannot be configured by the user via the program settings (e.g. if blocked by a firewall or proxy)
  • uses an unsecured connection instead of the secured one (SSL/TLS)
  • does use the resources of another company instead of the own.

doesn’t seem to be a failure save implementation at least.

2 Likes

It did have some imperfections.

I’m not sure what the reason for the recent increase is, but two possibilities are that Google altered how /ncr works, or macOS and Windows are now both blocking ‘http’. At least for some users.

Do you have a typo here? Should the file path be SketchUp 2018 (not 2016)

Could you also note in your original post that this issue can also affect extensions that require internet access for license activation and other online activities. As a developer, we typically use the command Sketchup.is_online to test whether there is a valid internet connection but the issue mentioned prevents this command from giving the correct result.

1 Like

Thanks, I had copied that from an older post. I fixed it.

I added a note about extensions as well.

For what it’s worth, this worked for me with SketchUp Pro 2018 on a Mac with macOS 10.14.6 to allow the Generate Report function to start with the online version of the function. (However, no actual report could be generated - but I’ll post that elsewhere.)

I have MAC 0S 10.13.6 and Sketch-up Pro 2018 commercial licence. I have tried editing the i18n.dat file as suggested here but this hasn’t worked.

When in Sketchup going directly to 3D warehouse by selecting the link under “window”, it goes to 3D warehouse with me logged in, and I am able to download directly into my model, yet when I click on the “Account” icon bottom left of the Sketchup window, it still says there is no internet connection.

I have tried all sorts of stuff suggested on other sites too, like checking the default browser is up to date. Opening Bing.com, then 3D warehouse first in the default browser, before opening Sketchup. Restarting etc etc.

Please help. I need to get some accurate shadows in my model before Stacy gets sunburn!

2 Likes

I see the thing you’re talking about, only I’m signed in at the moment. I will try ideas to see what fixes that for me. If I can get to sign out and in again, then it should work for you too.

For me, when I changed the URL to bing.com I then got a message in the welcome screen about not being able to reach the license server. But, when in a document I was able to sign out, and then sign in again. After that I could close SketchUp and reopen it, and the license server was found ok as well.

So, it’s worth being sure that you edited the right line in the right file. Make sure SketchUp is closed, then in Finder’s Go menu, Go to Folder…, paste in this text:

/Applications/SketchUp 2018/SketchUp.app/Contents/Resources/Content/Resources/en-US/i18n.dat

Edit the dat file, and change what is likely to be line 13 to be this:

ONLINE_TEST_URL=https://www.bing.com

Save the file and reopen SketchUp. See if the sign in now works.

1 Like

Ok thats worked now, but in notice that online is spelt “ON_LINE” above but in your recent reply “ONLINE”. The later which is now working.

2 Likes

Interesting, thank you! I took my advice from another article, I’ll try to track that down, though it may not still be online. I think that most people will have only edited the URL part, and so didn’t hit a problem.

I will edit my post to say ONLINE instead.

1 Like

It didn’t work for me in 2018 sketchup pro …though it did for a brief period and then stopped working. Find it very strange…
(OS - Win10).

After editing “i18n.dat”, everything works except report generation. Someone solved the reports issue?

try if

ONLINE_TEST_URL=https://www.sketchup.com/

helps.

2 Likes

Someone else reported today that the last thing they needed to do was to ask their IT to whitelist bing.com, though I’m not sure if that was for generate report reasons in particular.

errpr

How do I get permissions?

Make sure SketchUp is closed, then copy that file to your desktop. Make the changes and save the file, then move it back to the original folder, replacing the file that is there.

1 Like

Thanks, what I had to do was run notepad as administrator and then navigate to the folder to open that .dat file, that way it saved it

Thanks for the update. Did that then fix the Internet error?

Yup, all fixed. :+1:

Still, only the warehouses are working with bing.com (or other try). Reports are not.
First, a window pops up:
obraz
After clicking OK, the templates manager starts.
After pressing Run, a window pops up:
obraz
After pressing OK it hangs on generating the report.