SketchUp and macOS Sierra



Hello supporters
Still getting old version V16.1.1451 instead of 16.1.2418
Does anybody have a correct link to the newest version?
LayOut doesn’t starts at all under macOS Sierra with old SU version



I tried again this a.m. and instead of clicking on the check for update links within Sketchup, I went directly to the Sketchup download page via Safari. I finally got t he correct version downloaded.


as always, download from here.


This url works !



nothing different than above, direct download by:

SU Pro macOS EN :
SU Make macOS EN :


Is this M2 release only Mac?
Why version munber is not 16.2.xxxx ?
Is there any release notes?


I cannot thank you and the rest of the team enough, and just in time, I had another LayOut file that needed re-labeling. Launch, edit, save, close, launch…was getting tedious :laughing:


@genki_tt don’t worry, you’re not missing anything on a PC, there were incompatibilities that made SU and LO difficult to use with the latest macOS update. It’s not new functionality, it’s just getting the old functionality back.


seems that the recent build of macOS v11.12 ‘Sierra’ has currently an issue with wide screen resp. WQHD resolution displays driving them with max. FullHD only.


Same issue persisting


Having frustrations with the text thing - so wish I’d read your announcement!
Is there a way to fix the RTF parsing?


Having issue with Send to Layout being greyed out in Sketchup and not exporting ketchup model. Running Sketchup Pro for Mac version 2418. Shortcut in toolbar is greyed out as well as in file menu. Any ideas??


has the model been saved first?



Yes sir


Sierra has introduced some new security features that do some weird quarantine things with applications. In certain situations, it’s possible that it’s running SketchUp from a temporary “secure” location instead of where it’s actually installed, which means that it can’t find LayOut for the “Send to LayOut” feature.

To see if this is the issue that you’re seeing, do this:
When you see the issue, launch the “Activity” (in Applications/Utilities). Select the running, then press the Info button. Under the “Open Files and Ports” tab, there you can see whether SketchUp is launched from a randomized location or from where you actually installed it.



That seems to be the case Marc. Any info on when or if a fix will be available.


Ugh. I already updated to MacOS and now I am getting crashes when opening text boxes. I am in serious trouble with this. Any word on a fix?

Crash report attached.Crash.txt (4.6 KB)


yes, see above.


Haha. I guess I should have kept reading. Yeah, the maintenance release seems to have fixed it. Thanks SU team!