SketchUp and macOS Sierra

mac

#61

We’re working on a few ideas to fix the temporary location issue, but nothing solid yet.


#62

When will the LayOut bug be fixed, roughly? This year next year? Also experiencing no start up on LayOut and “application not responding”.


#63

Have you applied the maintenance update mentioned earlier in this topic? It fixes most of the Sierra compatibility issues.


#64

I did not see the maintenance update mentioned earlier (embarrassing!). I appreciate the heads up, Slbaumgartner. That did the trick!


#65

Is it safe yet to upgrade to MacOS Sierra and not have SU problems?


#66

Did you read the previous posts in this topic? There is a maintenance release that fixes most of the issues with SU under Sierra so there should not be outright crashes or severe failures. There are a few remaining problems mentioned, the most serious being that sometimes Sierra’s new security mechanisms may prevent SketchUp from being able to find Layout to launch it.


#67

Thanks, I’m new to SU and the forum and I guess I didn’t realize how current the previous post were. Sorry


#68

I’m having the same issue here. macOS 10.12 (16A323) and Sketchup Pro 2016.1.2418. The zoom control is terribly sensitive.


#69

Please fill out the details in your profile about the specific mac you are running. This will help Trimble to understand whether these problems are general or associated with particular hardware (e.g. 5k display).


#70

Zoom control in SU can be problematic when the background is empty. It behaves completely differently depending on whether your cursor is over an entity or over thin air. It can make navigation very tricky.


#71

Thank you - I’m aware of that. This zoom behavior was introduced with the latest version SketchUpin combination with macOS Sierra.


#72

I am having the same issue with Layout being greyed out when in SketchUp Pro. Tried the Activity Monitor but I am unclear as to how to tell where Sketch Up is launching from or how to fix it. Running Sierra 10.12 and Sketch Up 16.1.2418. What are my options?


#73

just installed the new OS sierra. but after that, my sketchup pro 8 is not opening.
can any one help,
regards,
Simon


#74

[quote=“architectsimon, post:73, topic:26490, full:true”]…OS sierra vs. sketchup pro 8…
can any one help,[/quote]

yes


#75

I have the send to layout issue, but I also have an issue with no scolling features being available or shown in layout itself; Both vertically and horizontally. Anyone else have this issue?


#76

Here’s an update on the issue where “Send To LayOut” is greyed out, and sometimes the dock icons can turn into question marks.

We’ve talked to Apple - this issue is a side effect of some security improvements that they made in Sierra. For most users, you’ll just have to wait until we can get another bug fix out the door. If you’re an advanced user, start reading up on “app translocation” and the quarantine xattr “com.apple.quarantine”. In theory, deleting the quarantine flag will stop the translocation system from running SketchUp from a temporary location.


Several Sketchup Bugs
#77

Hi Marc,
How long will it take to get the bug fix done? “app translocation” ad “quarantine matter” sound like it would take me way too long to research and understand a fix. But in the meantime I have big projects in process that require Layout today. Are you really telling us that there is no current way to fix the issue at all and that we simply can’t use Layout?
-Derek


#78

@derekb, you could recursively remove all of the quarantine flags from SU v16 using Terminal.app using the following code…

sudo find /Applications/SketchUp\ 2016 -xattrname com.apple.quarantine  -exec xattr -r -d com.apple.quarantine {} \;

sudo [superuser do] will ask for an admin password…
find will search the SU folder for any ’ -xattrname com.apple.quarantine’ and pass them to ‘xattr’ for it to remove the flags found…

I’m not running Sierra but this code works on El Capitan and older…

john


#79

Hi John,
Thanks for spelling it our for me, much appreciated. It worked and Layout is accessible again!
-Derek


#80

LayOut still runs if you run it by hand, right? Instead of using “Send To LayOut”, save your SketchUp file, run LayOut, and then do a File->Insert to import the SketchUp model.

-m