OS X Yosemite testers?


#1

I’ve heard a report that SketchUp Make isn’t working on OS X Yosemite (10.10) and am looking for any other beta testers who have used it and can confirm if its worked for them or not. I’m unable to reproduce the issue personally.


#2

I hope you are wrong.


#3

Sketchup Make 14.1.1283 works on OSX Yosemite here – no problems


#4

Thanks for checking and reporting back @tbd

I can handle one-offs. We can’t reproduce it in the office and I just wanted some sanity. Nothing to see here, move along.


#5

I have started to encounter issues with SketchUp 14.1.1283 with Yosemite 10.10 just today. Sample report follows. Layout is working fine and I can open the model from within Layout to SketchUp, after making a change I closed and saved the SketchUp model. Now when I open the model directly in SketchUp I started having the issue. This is on a MacBook Pro and I will see if the crash happens on my MacPro this evening.

Process: SketchUp [609]
Path: /Applications/SketchUp 2014/SketchUp.app/Contents/MacOS/SketchUp
Identifier: com.sketchup.SketchUp.2014
Version: 14.1 (14.1.1283)
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: SketchUp [609]
User ID: 501

Date/Time: 2014-09-08 13:20:42.281 -0400
OS Version: Mac OS X 10.10 (14A329r)
Report Version: 11
Anonymous UUID: 6766CE50-940F-9D06-01C7-9C47C5C001B9

Time Awake Since Boot: 550 seconds

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000008

VM Regions Near 0x8:
–>
__TEXT


#6

I have found that under Yosemite opening the outliner seems to crash SketchUp with my existing files. Am going to try starting a new model from scratch and see if I can replicate the problem…


#7

I have been running Beta 4 on a separate partition on my MBP and have found consistent crashes in SketchUp 14.1.1283. Would be happy to contribute bug reports. Same models run fine under SU and Mavericks.


#8

Our internal tests haven’t had any problems with it yet. I’ll alert the QA team to this thread so they can check in on it. If they need beta testers perhaps they can reach out to users through Private Messages here.


#9

After one more week of testing I can confirm that crashes in Yosemite have to do with the outliner. I tried several different models and the crashes are outliner related. Would be happy to beta test if needed.


#10

Thanks mk11, I let the QA team know since they’re the one’s that handle beta testing. At the very least they’re now aware of your issue and will start testing. Depending on if they can reproduce it and if what they’re doing with Beta testing right now they might reach out to you for more information. It’s odd that Outliner would have any sort of functionality change with Yosemite vs what was in Mavericks. Do you see this in every file? When performing certain operations (such as deleting, moving, renaming) and do similar actions in the Components browser not get the same result?

My best guess is that the type of modal dialog that is Outliner is different than the inspectors used by the other tools.


#11

Yes, there’s a known crash in the Outliner on Yosemite - Yosemite has some SDK changes and is stricter about some types of memory access. There’s no work-around for this other than to leave the outliner closed.

-marc


#12

Marc - I assume this will persist in the full release of Yosemite!? Will there be a fix or are you suggesting Mac users do not upgrade to Yosemite in order for SU to work? Not using the outliner is not really an option.


#13

I have no idea what any timelines are for fixes but I’m sure this isn’t the type of issue that will have no better answer than “don’t use that.”

We’ll do some digging and hope that Apple will address it in an update on their end so it doesn’t break all historical versions of SketchUp. Good that we know about it though, @Marc is definitely one of the best brains to have pursuing the issue. (c:


#14

@jody - thx for the reply.


#15

Hi guys
I have big problems on Maverick
starting to work on existing files, the system is asking me a password to let ATOS doing something (something related with a debug) and immediately Sketchup crash
we are running Sketchup on a pro-version (the last update) an it is a serious problem cause we cannot literally work
any idea about that?


#16

NOte, I was talking about Yosemite, sorry


#17

Just a short Updated.
we’ve followed this topic


and it helped us to solve temporary switching off the "OUTLINER"
but note: we cannot absolutely use the outliner, that is not a comfortable thing…


#18

I think I’ll try to get some warning signs up around here to encourage staying on Mavericks for the time being. The outliner definitely doesn’t work in Yosemite, this is a known issue with the only solution being to turn off the Outliner. It’s possible other things may turn up as well. If you’ve already installed then you may wish to try to roll back, if you’re on the fence then we discourage upgrading for the time being.


#19

the problem is the production…
we’ve done it, and we cannot loose more time on it…


#20

Hi-

The “atos” permissions dialog is a side effect of SketchUp crashing, not the cause. Yosemite has stricter permissions about the BugSplat crash reporter, so this “atos” dialog appears before the Bugsplat dialog does.

We’re monitoring the crash reports that come in from Yosemite and working hard to address them.

Thanks,
Marc