Sketchup 2023 Bug Regarding Floating Trays on a Second Monitor

DxDiag.txt (169.8 KB)

1 Like

Couple of things to check out
That report makes it look like one of your displays is connected via the integrated GPU - and the drivers in use are from 2021.

Latest intel drivers are here

Does your 2060 have dual displayports?
If so, just double check both monitors are connected via the same GPU (and not plugged into the motherboard) - there are often issues with 2nd displays and multiple rendering devices.

Intel UHD 620

Been using SketchUp 2023 at least every work day, more or less 9 to 5 since release 21 days ago.

This blackness has only just happened once to me now.

There is a driver update available that was released Feb 8th which I am installing now – let’s see if I get the blackness again…

The 2060 has a 1x displayport and 1x HDMI.

My “main monitor”, monitor 1, that had the SU modelling window on is connected to the HDMI port.

The 2nd monitor that had the blacked out tray is connected to the displayport.

The 3rd monitor is daisy chained off monitor 2.

Monitor 4 is connected to the onboard graphics via displayport.

1 Like

It could be that windows is making bad decisions for you - I suspect those black boxes are because those areas are rendered in OpenGL on a different device to the main screen- you could always check that SketchUp is being specified to run on the 2060 always.

This screen is in the windows settings

I think there is an equivalent setting in the NVCP also
EDIT : Lots of monitors! :smiley:
That makes sense, I thought I was reading something wrong when I saw so many monitors

Can you use the HDMi port on the Nvidia card rather than the intel one?

1 Like

Good call Adam – I forgot to update System>Display>Graphics for SketchUp.

For me it hasn’t been a problem.

And if it happens again it’s easy to resolve within my workflow – I have shortcuts to toggle my floating trays on / off – turn off black tray and turn back on the black has gone.

For sure it’s more of a problem for others.


Yeah it sounds like you’ve got a handle on it.

Computers are hard.


That’s news to me – how did you work that out…?

Curious, in Settings>Updates it seems to suggest that I’m not on a preview build, i.e. there is an option to join…

ignore me, that’s my mistake. 22621.1.ni_release.220506-1250 is the preview version , which isn’t what you have

DxDiag MWDS 20230310.txt (127.0 KB)
Thanks for the tip on getting this info.
The tray/toolbar issue is in Layout as well. Mine doesn’t display black it just cannot be placed correctly and moves intendant of my actions. That is to say, if you grab it with the mouse on the header, the moment you leave the native display the cursor position on the header changes dramatically and, in many cases, the tray/toolbar is lost - not visible on any display. The only way to recover (in the case of a tray) is to create a new tray and assign the missing tray feature. I just tried to video capture this but the trays do not appear on the screen (I think this is a limitation of the X-Box app).

87.3% of all percentages are made up on the spot.

1 Like

Actually it’s 87.3481501% to be exact. :wink:

1 Like

Clearly Timble is not going to do anything about this.

What or who is Timble?

The developers have promised a fix. It might come sooner or later.

I find it unacceptable that Timble’s devs did not release a fix on a sunday monday at half past midnight too.

how dare they. That wouldn’t happen with Thimble.

Haha… My Nimble apologies… The matter has been dragging for more than the weekend. We wait with bated breath. :sweat_smile:

when it comes to fixes, companies usually belong to one of two famillies :

  • some will push incessant little fixes, fixing one thing, breaking another, and basically once or twice a week you’ll have to do a minor update. this is prevalent on phone / tablet apps, as they can easily do it in the background at night. You’ll see the same thing if you own a PC, every other day, I’ll have the orange / red dot telling me I should install some new update again. all the time. and it surely does break things, WIN updates, then it needs a sound card update, then a video card update, until then you’ll have weird artefacts onscreen… it’s an endless circle.
  • some will, unless mega breaking bug, wait a bit and give you packages. video game style. or macOS. Sure, you’ll have to wait a month or two, but a big chuck will be solved at once. Video games have solved the wait issue with open betas and test servers, other softwares have not crossed that line yet.

Both are frustrating. I tend to prefer the second. Having bugs is frustrating, discovering a new broken thing just because you just fixed another bug is really maddening.

Yours looks fairly straightforward and I can’t see anyhting that really stands out.
You might want to see if you have a bios update, as one of the more recent ones enabled some new GPU functions.

One Thing I had read about was that certain programs with overlays can cause black artifacts to appear.

It might be a long shot, but perhaps ensure that nvidia experience’s overlay is disabled and xbox game bar , steam and Xbox game bar all have their overlays turned off.

As mentioned previously, the floating tray/tool issue is also present in Layout. Currently I have three trays open but they do not appear on any screen. I have to repopulate the default tray and then reassign the various new trays with their various features. when these tray decide to vanish; repeat above. I have attached a screenshot of the previous setup with the red line as the screen break. This issue is making Sketchup / Layout nearly impossible to use.