Sketchup 2021 crashes when opening file

Hi,

I recently installed Sketchup Pro (with liscence).
It worked for two days but the program now crashes everytime I open a file…

It’s really annoying as I have deadlines to work to…

Thank you for your quick help!

Best wishes,

Justine

hello, not sure if it will solve the problem, but can you try this :
start sketchup (without opening a file)
go to window > preferences > general
uncheck “notify me when problems are fixed”
close sketchup and open your file again.

Hi,

Tried it but the box was already unchecked…
Thankd for the help anyway!..

are you trying to open existing files that have worked in previous versions?

Yes…

in the new version, sketchup fixes problems that can be found upon opening. when you say it crashes, what does it do ?
is it just not responding or do you have a bug splat ?

can you attach your file (with wetransfer, dropbox…) so we can try opening it ?

what you could also try would be drag/dropping your file in sketchup for web, it will import your model as component, download it as 2021 version and try to open it again

Hi Paul,

The program crashes an I get a bugsplat.
Here is the wetransfer link of the file that I would like to open.

Thanks!

it opens fine here on desktop version and in sketchup for web.
Perhaps @colin will be able to tell more about the bugsplat ?
if you sent the report, of course

Yes, it does open… But as soon as I delete something it crashes :frowning:

Justine,

When I delete anything SketchUp does not crash.

Running cleanup at the moment - it’s taking some time…

cleanup ran for about 20 minutes

Screenshot 2021-03-22 150915

Screenshot 2021-03-22 150935

Lately, the most occurring bugsplat on Mac is that it wasn’t installed and that you are clicking on the disc image on the desktop or have an icon in the dock that refers to that.
Check this post:

Hi, I did all the steps… still crashing… I’m also not a 100 % sure what they mean in step ‘6’ ? Do I have to delete de dmg file in the download folder? Or what do they mean with ‘eject the disk image’?

rightclick on it and choose ‘remove’ will ‘eject’ the disc-image (it’s not a real diskette, anymore)

Using V-Ray?

There is a known issue with older materials that crashes SketchUp. Check the material editor for errors and replace those:

Yes I do use V ray and Podium as a plug in. I dowloaded version 2020 and this works… Will stick to that for now. Thanks for you help anyway!