Can’t open file - SketchUp immediately crashes

I’m having an issue opening a file I’ve been working on, on the desktop version of SketchUp pro 2020. When I open SketchUp and select the file, SketchUp immediately crashes and closes down. I can open other files so it must be an issue with this particular file. I’ve also tried opening the file on the web version but no luck here either. Any advice would be greatly appreciated. I’m quite new to SketchUp pro but I’ve been working on this file for a week with a deadline coming up on Friday, I’m desperate to access it.

I sometimes get this kind of thing happening and I am also on a Mac. It seems to be more common on that platform.

If you can upload the file, you may well find that a PC user can open it just fine. How much use that is to you, I’m not sure, but it might be.

Do you have a Time Machine backup? Go back to a version of the file that was working. Losing the most recent changes is better than losing the whole file.

If you post your file someone might be able to open it, but it might just be corrupted.

I’m not actually sure how to restore an earlier version? I can’t see an option anywhere.

I would love to try this but unfortunately I don’t own or have access to a PC.

Apartment.skp (1.9 MB)

Hi McGordon, I have attached the file (hopefully correctly). Is there a reason it would become corrupted suddenly? I was working on it fine one minute, and the next minute it just crashed, never to be opened again!

This is assuming you actually have a Time Machine backup. Open the folder containing your file in the Finder, then click on the time machine icon in the menu bar. If the icon isn’t there, open System Preference -> Time machine and tick the option “Show Time Machine in Menu Bar”. Then click the icon in the menu bar and choose “Enter Time Machine”.


Click the arrows or dates to go back in time to find the version you want then click restore. Then click ‘keep both’ in case you want to keep the latest corrupted one.

No, but it might tell you if the file was corrupted or not. I usually find that PC users can open my files even when I can’t. It narrows it down to a Mac compatibility issue.

Try this.
ApartmentBox.skp (1.8 MB)

1 Like

SketchUp said there were some errors, which it fixed. Try this:


Apartment gm.skp (1.8 MB)

1 Like

Here’s the good news for you.

Screenshot 2020-03-18 at 08.45.04

1 Like

Maybe a bug in SketchUp? Problem with Catalina (I’m on Mojave 10.14.6)?
Hardware Problem? I had bad RAM once that corrupted images.

You fixed it?!! Thank you so much!! Can I ask how you did that so I can do the same in future?

You managed to open it? Well done! Now you will see all my messy work! :joy:

I just opened the file. The only difference I can see is that you’re on macOS Catalina and no one else here is. By the way, your profile says iOS, that should be macOS.

I promise that I looked away from the screen and just uploaded it.

It’s funny isn’t? You and I are both on Macs and using SU2020. With your setup, the file crashes. With mine, it immediately identifies a problem and proceeds to fix it. How can that be? It’s a rhetorical question because it is one of the Great Mysteries of the universe. A totally logical thing that yet has no discernible logic!

So it’s maybe an issue with Catalina? Thanks for the heads up, I have now changed this in my profile.

Its a work in progress, that’s all I’ll say :see_no_evil:

I don’t see anything wildly wrong with your model. It’s a bit odd to divide it up so much and to end up with so any tags, but maybe you have a reason for doing it that way.

Annoyingly I only updated to Catalina last week ready to download SU2020, thinking it would all run better! However, prior to this, I was using Yosemite so very outdated!

My honest answer? I still have no idea what I’m doing with SU! I need to be able to show each elevation when presenting to clients, so my thoughts were if I divide every elevation into tags like this, I could immediately drop the South walls and windows for example, and then screenshot the view. It takes me hours to do all of this. Is there a better solution which I’m blatantly missing?