File on SU2020 won't reopen after crash

Hi All, I have been working on the attached model with SU2020 Pro for the last couple of days. The file crashed while I was doing a simple ‘extruding’ operation and now won’t reopen. As soon as I double click on the file Sketchup crashes again. I tried deleting and renaming the file but won’t work.
I am stressing as I have a deadline in 24h.
Have you had this issue before and how did you solve it?
I attached the file. thanks in advance for your help.
2403_Existing model.skp (3.0 MB)

Capture d’écran 2024-03-17 à 17.31.35

some lines and faces were causing issues.
it opens fine in 23 once sorted, I re-saved it in 20, it should work now.

2403_Existing model 2.skp (3.0 MB)

1 Like

Thank you Ateliernab! very much appreciated, life saver!
In case it happens again, do you know whether there is a way of solving the issue in house without having to rely on other people opening the file with a newer version of the software?

It opens easily in the web version, so you could use that to check it and resave/download a copy.
You can use Open Newer Version to convert it to your year.

uhhh Luke is on a mac so no Eneroth for him.
The mac alternative is s4u Save As SketchUp I suppose.

but yeah, like Box said, online version will give you a 21+ file, all you need is to transform it back to 20

1 Like

Thank you All for your kind replies. I downloaded ‘Save as’ but it doesn’t let me open it. See error message. Do you know how to get around this?

the very first time you open it, right click on it, press alt (option), you’ll see the menu change, and choose open.

it’s a mac os security thing, and the right click + option is the way to go around it. il allows you to open any app from anywhere.

(once it’s open, you’re fine, it joins the whitelist, no need for that manœuvre)

the worked and I managed to back save the file. Thank you very much for your help ateliernab! :star_struck:

1 Like

I would also suggest opening the Preferences dialog, go to the General panel …
and enable both options under the Check for Problems group.

Thank you Dan, I have done as you suggested!