SketchUp 2021 Crashing and won't reopen

I have had SketchUp Pro 2021 crash on two different Mac computers now (while I was trying to use the bucket tool, both times) and then when I try to reopen the file that crashed or even just the program, it makes me send the bug splat report and then closes without actually ever opening the file. Over and over again. I have tried reinstalling the program and restarting my computer and nothing works. Is it a Mac problem?

After you submit a BugSplat, SketchUp automatically tries to reopen the file you last had open. It’s a kindly feature because usually the crash was from something else and this lets you pick up again where you were. But sometimes the crash was due to a fatal flaw in the file. In that case SketchUp will crash again immediately. Try deleting the file or renaming it so that SketchUp can’t find it and see if that helps. I know that on Windows you can force SketchUp to open with no file by holding space (shift?) as you launch it, but I don’t know whether that works on Mac.

@martidiehl Would you be willing to share the offending file before deleting it (as @slbaumgartner suggests)? We would probably want to investigate this kind of problem!

Here is the file that keeps causing the crash–

Shields SketchUp.skp

If after a crash SU2021 won’t open again. Even with an empty file and all plugins disabled. You can try to delete the plist file. I had the same problem twice during beta testing and deleting the plist file fixed the problem.

You will need to set the permissions on that file so that anyone with the link can download it.

Has this been resolved? I have the same problem. I renamed the file I was working when it crashed. I deleted every plist file I could find with Sketchup in the name. I deleted and reinstalled the app. I still can’t open it. I am on a MAC.

One nice feature on Mac is that you can select text anywhere, right-click and choose Services, then if it is a valid path you can select Show in Finder. Try that on this line:

~/Library/Preferences/com.sketchup.SketchUp.2021.plist

That is the right PLIST file to delete. Make sure to have closed SketchUp first.

I was on a screen share with someone a few days ago, who was having the crashing issue. I had hoped to test the PLIST deleting idea, but it turned out that SketchUp was being run from within the wrong folder, and the folder was also set to be invisible. When I put things into the right location (meaning, a visible SketchUp 2021 folder inside Applications), we couldn’t make the crashing issue happen. So I wasn’t able to do the PLIST test.

Colin,

Thank you for your help. Unfortunately I don’t know whether deleting the plist file did the trick or not. I put sketchup in a visible folder inside applications and was able to start it with no more problems.

Thank you again,

Doug

Ha! Wouldn’t it be nice if the location was the important part.

Can you say where SketchUp was before you moved it?

It would be funny if the incidental thing I mentioned was the real issue.

Sorry, Colin, but I don’t know where it was before I moved it.

The good news is I used SketchUp for several hours last night with no problem! :slight_smile:

We were looking at an issue this evening, and may have figured out what is actually going on.

When you moved SketchUp into Applications, do you remember having to enter an admin name and password?

Yes, I think it did.

I’m experiencing the same issue, tired to use an application removal app to remove cache, plist. It seems to work for a little bit until it crashes in either 5 minutes, 30 minutes or in a few hour, not sure which part of the operation is causing the app to crash…

I’m have the same problem. Sketchup crashs as soon as I launch it. The first times, deleting the plist fixed the problem and allow me to work again. But now, I don’t have the plist file any more and sketchup can’t launch…

I know what I do to crash it: I display the color window and click on the last Tab, the one with the brick icon -> sketchup closes immediately. I have never been able to used colors on my model since I installed Sketchup 2 week-ends ago.

Thanks.

1 Like

I have the same issue. I even uninstalled 2021 and reinstalled. Also tried to rename the file.
I still can not open skp 2021. It just crashes.

Same Problem, I also uninstalled it and reinstalled and it will not open just crashes.
I went back to using my 2020 Pro I need it for work and I can’t wait days or weeks for Trimble to replay to my support ticket.

Did you send in the bugsplat report? I can’t find any from your email address.

Also, exactly when does the crash happen? Do you see the welcome screen appear, and fill in?

Yes I’ve been sending all of them in. Here is a snap shot of it.

image005.png

This is the message I get when I send it in.

Perla Arquieta ASLA PLA

205 Ruth Ave. Venice, CA 90291

http://www.parquieta.com/

https://portfolium.com/Parquieta

image003.jpg

image004.jpg

All of the crashes seem to be in the Visual Studio code. If you open the add or remove programs control panel and search for C++, one of the results is the 2015-2019 redistributable. Click on that, then on Uninstall, and Yes, to get through to the installer for those libraries.

Soon you get a choice to uninstall, but there is also Repair. Try doing a repair, and then see if SketchUp opens ok.