M1 MacBook Pro Crash on Open

Every time I try to open sketchup it crashes. Any ideas?

-------------------------------------
Translated Report (Full Report Below)
-------------------------------------

Incident Identifier: 5BCAC881-46C4-42AF-9A8C-A24F08E32561
CrashReporter Key:   1D82CB88-CA7D-8C1A-8527-EED0963AE6C6
Hardware Model:      MacBookPro18,3
Process:             SketchUp [50503]
Path:                /Applications/SketchUp 2021/SketchUp.app/Contents/MacOS/SketchUp
Identifier:          com.sketchup.SketchUp.2021
Version:             21.1 (21.1.331)
Code Type:           X86-64 (Native)
Role:                Default
Parent Process:      launchd [1]
Coalition:           com.sketchup.SketchUp.2021 [188905]

Date/Time:           2021-11-20 11:40:24.8097 -0800
Launch Time:         2021-11-20 11:40:24.7831 -0800
OS Version:          macOS 12.0 (21A344)
Release Type:        User
Report Version:      104

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000001, 0x00007ff7ffda3af0
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: SIGNAL 5 Trace/BPT trap: 5
Terminating Process: exc handler [50503]

Triggered by Thread:  0

Application Specific Information:
rosetta error: /var/db/oah/279281322164224_279281322164224/322eab648708fa32de9d6d33b2dee81e7f15e6f145ee70bdaeb8067630542fb0/SketchUp.aot: attachment of code signature supplement failed: 1


Thread 0 Crashed:
0   runtime                       	    0x7ff7ffda3af0 0x7ff7ffd87000 + 117488
1   runtime                       	    0x7ff7ffda3b38 0x7ff7ffd87000 + 117560
2   runtime                       	    0x7ff7ffd9a438 0x7ff7ffd87000 + 78904
3   runtime                       	    0x7ff7ffd9b510 0x7ff7ffd87000 + 83216
4   runtime                       	    0x7ff7ffd9ac8c 0x7ff7ffd87000 + 81036
5   runtime                       	    0x7ff7ffd8aac0 0x7ff7ffd87000 + 15040
6   dyld                          	       0x2017fc000 ???


Thread 0 crashed with ARM Thread State (64-bit):
    x0: 0x0000000000000000   x1: 0x0000000000000003   x2: 0x000000000000003c   x3: 0x000000000000002c
    x4: 0x0000000000000303   x5: 0x0000000000000000   x6: 0x0000000000000000   x7: 0x0000000000000000
    x8: 0x00007ff7ffdc2000   x9: 0x0000000000000000  x10: 0x0000000000000000  x11: 0x00007ff7ffdc294b
   x12: 0x0000000000000000  x13: 0x0000000000000000  x14: 0x0000000000000000  x15: 0x00007ff7ffdaa828
   x16: 0xffffffffffffffe1  x17: 0x00000000ffffffff  x18: 0x000000030610106b  x19: 0x00007ff7ffdb82e1
   x20: 0x0000000306101720  x21: 0x0000000101502000  x22: 0x0000000000000004  x23: 0x0000000101502000
   x24: 0x0000000000000003  x25: 0x0000000000000001  x26: 0x0000000306100b80  x27: 0x00000002018701b8
   x28: 0x0000000306109950   fp: 0x00000003060ff960   lr: 0x00007ff7ffda3ae8
    sp: 0x00000003060ff940   pc: 0x00007ff7ffda3af0 cpsr: 0x60000000
   far: 0x00000003060ff978  esr: 0xf2000001 (Breakpoint) brk 1

Binary Images:
    0x7ff7ffd87000 -     0x7ff7ffdb6fff runtime (*) <70e45ce2-97b7-333e-8cad-dad5f9ff28e9> /usr/libexec/rosetta/runtime
       0x2017fc000 -        0x201863fff dyld (*) <134d41a3-bae2-31f3-bc21-cdd091ced449> /usr/lib/dyld

Error Formulating Crash Report:
dyld_process_snapshot_get_shared_cache failed

EOF

-----------
Full Report
-----------

{"app_name":"SketchUp","timestamp":"2021-11-20 11:40:24.00 -0800","app_version":"21.1","slice_uuid":"5c1c638e-646c-38e1-9f40-0435bc8a022d","build_version":"21.1.331","platform":0,"bundleID":"com.sketchup.SketchUp.2021","share_with_app_devs":1,"is_first_party":0,"bug_type":"309","os_version":"macOS 12.0 (21A344)","incident_id":"5BCAC881-46C4-42AF-9A8C-A24F08E32561","name":"SketchUp"}
{
  "uptime" : 610000,
  "procLaunch" : "2021-11-20 11:40:24.7831 -0800",
  "procRole" : "Default",
  "version" : 2,
  "userID" : 501,
  "deployVersion" : 210,
  "modelCode" : "MacBookPro18,3",
  "procStartAbsTime" : 14802090149225,
  "coalitionID" : 188905,
  "osVersion" : {
    "train" : "macOS 12.0",
    "build" : "21A344",
    "releaseType" : "User"
  },
  "captureTime" : "2021-11-20 11:40:24.8097 -0800",
  "incident" : "5BCAC881-46C4-42AF-9A8C-A24F08E32561",
  "bug_type" : "309",
  "pid" : 50503,
  "procExitAbsTime" : 14802090499535,
  "translated" : true,
  "cpuType" : "X86-64",
  "procName" : "SketchUp",
  "procPath" : "\/Applications\/SketchUp 2021\/SketchUp.app\/Contents\/MacOS\/SketchUp",
  "bundleInfo" : {"CFBundleShortVersionString":"21.1","CFBundleVersion":"21.1.331","CFBundleIdentifier":"com.sketchup.SketchUp.2021"},
  "storeInfo" : {"deviceIdentifierForVendor":"98D7B424-27C4-51F9-A500-B5B9EC27A3E2","thirdParty":true},
  "parentProc" : "launchd",
  "parentPid" : 1,
  "coalitionName" : "com.sketchup.SketchUp.2021",
  "crashReporterKey" : "1D82CB88-CA7D-8C1A-8527-EED0963AE6C6",
  "wakeTime" : 2772,
  "sleepWakeUUID" : "87F8E137-A001-4A13-8495-C0D3EDD7394B",
  "sip" : "enabled",
  "isCorpse" : 1,
  "exception" : {"codes":"0x0000000000000001, 0x00007ff7ffda3af0","rawCodes":[1,140703126141680],"type":"EXC_BREAKPOINT","signal":"SIGTRAP"},
  "termination" : {"flags":0,"code":5,"namespace":"SIGNAL","indicator":"Trace\/BPT trap: 5","byProc":"exc handler","byPid":50503},
  "asi" : {"runtime":["rosetta error: \/var\/db\/oah\/279281322164224_279281322164224\/322eab648708fa32de9d6d33b2dee81e7f15e6f145ee70bdaeb8067630542fb0\/SketchUp.aot: attachment of code signature supplement failed: 1"]},
  "extMods" : {"caller":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"system":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"targeted":{"thread_create":0,"thread_set_state":0,"task_for_pid":0},"warnings":0},
  "faultingThread" : 0,
  "threads" : [{"triggered":true,"id":9360883,"threadState":{"x":[{"value":0},{"value":3},{"value":60},{"value":44},{"value":771},{"value":0},{"value":0},{"value":0},{"value":140703126265856},{"value":0},{"value":0},{"value":140703126268235},{"value":0},{"value":0},{"value":0},{"value":140703126169640},{"value":18446744073709551585},{"value":4294967295},{"value":12986617963},{"value":140703126225633},{"value":12986619680},{"value":4316995584},{"value":4},{"value":4316995584},{"value":3},{"value":1},{"value":12986616704},{"value":8615559608},{"value":12986653008}],"flavor":"ARM_THREAD_STATE64","lr":{"value":140703126141672},"cpsr":{"value":1610612736},"fp":{"value":12986612064},"sp":{"value":12986612032},"esr":{"value":4060086273,"description":"(Breakpoint) brk 1"},"pc":{"value":140703126141680,"matchesCrashFrame":1},"far":{"value":12986612088}},"frames":[{"imageOffset":117488,"imageIndex":0},{"imageOffset":117560,"imageIndex":0},{"imageOffset":78904,"imageIndex":0},{"imageOffset":83216,"imageIndex":0},{"imageOffset":81036,"imageIndex":0},{"imageOffset":15040,"imageIndex":0},{"imageOffset":0,"imageIndex":1}]}],
  "usedImages" : [
  {
    "source" : "P",
    "arch" : "arm64",
    "base" : 140703126024192,
    "size" : 196608,
    "uuid" : "70e45ce2-97b7-333e-8cad-dad5f9ff28e9",
    "path" : "\/usr\/libexec\/rosetta\/runtime",
    "name" : "runtime"
  },
  {
    "source" : "P",
    "arch" : "x86_64",
    "base" : 8615084032,
    "size" : 425984,
    "uuid" : "134d41a3-bae2-31f3-bc21-cdd091ced449",
    "path" : "\/usr\/lib\/dyld",
    "name" : "dyld"
  }
],
  "vmSummary" : "ReadOnly portion of Libraries: Total=800K resident=0K(0%) swapped_out_or_unallocated=800K(100%)\nWritable regions: Total=38.0M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=38.0M(100%)\n\n                                VIRTUAL   REGION \nREGION TYPE                        SIZE    COUNT (non-coalesced) \n===========                     =======  ======= \nSTACK GUARD                       56.0M        1 \nStack                             8176K        1 \nVM_ALLOCATE                       13.0M        4 \nVM_ALLOCATE (reserved)            17.1M        3         reserved VM address space (unallocated)\n__DATA                              80K        3 \n__DATA_CONST                        48K        1 \n__LINKEDIT                         240K        4 \n__TEXT                             608K        2 \nmapped file                        5.9G       27 \n===========                     =======  ======= \nTOTAL                              6.0G       46 \nTOTAL, minus reserved VM space     6.0G       46 \n",
  "legacyInfo" : {
  "threadTriggered" : {

  }
},
  "trialInfo" : {
  "rollouts" : [
    {
      "rolloutId" : "607844aa04477260f58a8077",
      "factorPackIds" : {
        "SIRI_MORPHUN_ASSETS" : "6103050cbfe6dc472e1c982a"
      },
      "deploymentId" : 240000066
    },
    {
      "rolloutId" : "60da5e84ab0ca017dace9abf",
      "factorPackIds" : {

      },
      "deploymentId" : 240000008
    },
    {
      "rolloutId" : "5fc94383418129005b4e9ae0",
      "factorPackIds" : {

      },
      "deploymentId" : 240000162
    },
    {
      "rolloutId" : "5ffde50ce2aacd000d47a95f",
      "factorPackIds" : {

      },
      "deploymentId" : 240000076
    },
    {
      "rolloutId" : "601d9415f79519000ccd4b69",
      "factorPackIds" : {
        "SIRI_TEXT_TO_SPEECH" : "6194416d2171a2330e561f02"
      },
      "deploymentId" : 240000322
    },
    {
      "rolloutId" : "602ad4dac86151000cf27e46",
      "factorPackIds" : {
        "SIRI_DICTATION_ASSETS" : "6164895c201f677a9a4cb9e8"
      },
      "deploymentId" : 240000271
    }
  ],
  "experiments" : [

  ]
},
  "reportNotes" : [
  "dyld_process_snapshot_get_shared_cache failed"
]
}


can you verify rosetta ?

What does that mean?

SketchUp 2021 is not compiled for Apple’s new processors, unlike other software and despite the fact that they have been around for over a year (developer kits). So you have to check that the “Roseta” emulator is properly installed and working to launch old programs like SketchUp.

2021.1.2 is working ok on my M1 iMac and M1 Max MacBook Pro.

Not that I think it will make a difference, but is there a reason you are on macOS 12.0 and not 12.0.1? It may be that it’s still in beta, I’m not sure, but checking to see if there is a macOS update waiting for you could be worth a check.

When you try to open SketchUp again, do you get a BugSplat window? If you do, please send it in, that might help to show what’s going on.

Meanwhile, you could do a test where in Finder you use the Go menu, Go to Folder… to go here:

~/Library/Application Support/

Rename the SketchUp 2021 folder, and try SketchUp again. If it then works one of the support files had problems.

I updated the Mac OS and it works now!

Thanks!

I have the same problem, but I am on MacOS 12.1. I have a brand new M1 Max Macbook Pro and installed Sketchup 2022.

It never opens and just shows “Application Not Responding”.

I’ll attach the crash report as a file. Here is a snippet:

SketchUp-2022-01-28-130634.ips.zip (7.5 KB)

It says 2017 in the report…
Have you migrated another mac?
Perhaps it is trying to start an older version.
Make sure you launch from within finder >apps and not by clicking an existing icon on the dock.

Ah, sorry. Yes, I have an old installation of 2017, which is working fine though. If I start 2022 nothing happens and the icon in the dock shows:

I assumed the crash report was for that.

Here are all the relevant errors during launch of Sketchup 2022:

How was it installed? It looks like an access issue.

I just downloaded the latest version and installed it the normal way.

Could it be connected with the old 2017 installation? That was installed on my old Mac which I migrated to the new M1 Macbook Pro.

I can try completely removing it and installing again. Is there a proper uninstaller?

I guess that is not the answer @MikeWayzovski is expecting…

proper way on Mac is to move it to the trashbin, then empty the trashbin. (on Mac, deleted files don’t get removed, they just get flagged. Old links may still be active if not emptied)

The binary in your crash is located in a private folder, which usually means that macOS has quarantined the app. Most common cause of that is if you ran SketchUp from the disk image file, or some other unconventional location.

It would be worth copying the SketchUp 2022 folder from the disk image to Applications, then eject the disk image. Remove any SketchUp 2022 icons from the Dock, those are likely to be pointing to the wrong place.

Empty trash, then go into Applications, SketchUp 2022, and open SketchUp. All being well macOS will ask if it’s ok to open the application, that will help show that it’s being reconsidered, and isn’t still opening the one that is in quarantine.

1 Like

Okay, just completely removed Sketchup 2017 and 2022, downloaded 2022 again, installed into Application folder (as before).

Exactly the same happens:

Uploading: Screenshot 2022-01-31 at 19.03.13@2x.jpg…

I am not sure what else to try now.

ps: one thing that just came to mind: I can see that there is some access to Addressbook and Calendar that is being requested by Sketchup and not granted. Not sure why it would need that, but okay. I have a Mac that is managed by my employer (but its my own device) and has Cybereason ActiveProbe and some certificates installed. Could it be that this is restricting the app access to the Addressbook and Calendar? Just something that came to mind for a hint. Although, I have to say that I have 220 other things in my application folder, from brand new software to really old stuff and they all run fine.

Try these steps:

  1. Open Terminal (it’s in Applications/Utilities).
  2. Copy this text, and paste it into the Terminal window, and press Return:

xattr -d com.apple.quarantine /Applications/SketchUp\ 2022/SketchUp.app

That should take SketchUp out of quarantine, and hopefully fix the crashing.

1 Like

:sunglasses:

It worked, thank you @colin.

Hello guys!

I saw you managed to help seltzdesign to solve his prolem. Maybe we can find a solution to mine. I m really running out of options here.

I tryed uninstaling, it docent show the rosetta check in info etc.

I attached the crash report.
Crash Report.txt (18.7 KB)

You are running 2021, so there is no option to choose Rosetta, it is the only option.
Have you tried to launch StyleBuilder?
Does that work?