Sketchup 2021 closes on open of file with no bugsplat

I have upgraded to Sketchup 2021 which worked fine for a few weeks.

I am now having issues with Sketchup closing on opening of a saved file with no bug splat.
I found a work around which was to open a new blank file and then open the saved file I want.
This has stopped working in most cases now.

I wondered if it was an issue with old 2020 saved files. So i have tried to open more resent saved files that had been created in 2021, but same issue.

I have uninstalled and reinstalled 2021 but no luck at sorting the issues.

Following other chats I have been able to gain access to a file and did a save as and used the CleanUp3 plugin to tidy the file and saved, but again I could not open again.

Some files do open but 90% dont.

The only thing I can think of is it is a plugin issues, so I am going to look into this.

Any help would be greatly appreciated.

1 Like

Do you use style(s) with Sketchy edges?

No special styles in use.

It has gotten worse now.
I was finding the only way I could load models was to open a new file, then open an old 2020 file that had not been saved into 2021, and then I could open the 2021 saved files that I wanted.

hello, if you paste this %AppData%\SketchUp\SketchUp 2021\SketchUp in an explorer window and (temporarily) rename the plugin folder (into anything else) & restart sketchup, do you still have the issue ?

Hello there, I am having the same type of issue with the latest Sketchup pro 21. After signing in I chose a template and either nothing happens or I get a Bugsplash with no detail. I reinstalled 5 times.
I made sure the correct graphic card is running an up to date. This is very frustrating. Any help would be great!

Thanks Paul, on my end I don’t see any pugin folder there. I see Classifications / Components / Materials / Styles / Templates / Tutorials

Bonjour François, essayez de créer un nouveau compte d’utilisateur et lancez SketchUp depuis sa session voir si le problème persiste

Thanks for this Paul, but when i copy this into the file explorer nothing is found. I’m not the best with computers

Thanks Paul for your advice. I tried that, I even tried to start with a “clean boot” and I am still unable to access the program after I click on a template. Same if I try to open a skp drawing. I have used sketchup for 15 years on all sorts of computer and I have never seen this before. Really a mystery…

You may be using SketchUp 2020, which would mean you look here instead:

%AppData%\SketchUp\SketchUp 2020\SketchUp

What monitors do you have? Do you get different results if you run on only one monitor?

Hi Colin I have nothing else than my mouse plugged in… I tried unplugging it as well… Today it’s been a week without being able to use the program. I received a few tips from the SketchUp assistance but nothing that they suggested actually worked.

Are you in New York? If you are, several of us are talking about your case. I’m going to see if we can do a remote screen sharing session at some point. I’m not in support anymore, but I would try to join in on that.

Do you have any custom styles? Internally we fixed something today, and it relates to styles, not just sketchy styles. The one that we just fixed does have a work around, but first let’s see if you are using styles at all.

1 Like

This is correct Colin. I am based in NYC. Good to hear that they are taking care of my case.

1 Like

I am having some problems with SketchUp 2021 shutting down unexpectedly and I am using sketchy styles. It doesn’t happen often but enough to be annoying. What do I do?

The specific issue to do with styles is with SketchUp 2021. If you are using SketchUp 2020 the problem shouldn’t be happening for you. Would you be able to upload a small example file, that includes the styles that you do use?

Colin

Here you go. This is not the file that is causing the issues and it really hasn’t happened in the last week or so. The original file is about 21 MB but I made this one smaller. I am using SketchUp 2021, I guess I need to update my profile.
The sketchy style I am using is actually one of the winners from a few years ago from the Style Builders Competition. I have modified it a bit for my use.
I am also using a MAC, a MacPro 5,1 with an upgraded graphics card and processors and plenty of Ram. I am using 2 Apple Cinema Monitors a 30" and 23".

Thanks for the response.

Lets try a smaller file

John

SampleFileHouseProject.skp (4.36 MB)

Colin, I have no custom styles I can’t even access my functions- Whenever I click on a templates it crashes. Tim from Sketchup team sent me a few recommendations about the GPU drivers to be updated we made a clean install with as Admin, no luck. I have no diplay other than my laptop. Today I have a new message saying:
“SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the AMD/NVIDIA card.”

I am absolutely sure that the Nvidia Geforce 1060 is my default I’ve even specifically put sketchup.exe in the graphic configuration to work exclusively with NVIDIA. and I am still unable to use sketchup while I can use Lumion and Rhino for hours with no issues… please guys if you have any thoughts let me know. This is so frustrating at that point…

I am having the same issue with sketchup 2021. I installed it on my laptop about a month ago. It was working like normal through mid April. Today, it will not let me open a sketchup file without the bugsplat error report. Any help would be greatly appreciated.