SketchUp 2021 Crashing and won't reopen

Windows is having the same crashing problem. Just purchased Sketchup Pro 2021. I received the same BugSplat notification then it crashes and kicks me completely out.

I’m having the same issue. I downloaded SketchUp as a student with a paid subscription. I used the program this last week and today I went to open it up and it crashed. It continues to crash every time I attempt to open. Any recommendations in laymen’s terms as a first time sketch up user? This is the error message I receive.

This is the known problem that we released a fix for, but you need to install things in the right way.

You have the right DMG downloaded, but I think that SketchUp isn’t in the right place. Do these steps:

  1. Make sure SketchUp, LayOut and Style Builder are closed.
  2. Go into Applications and find the SketchUp 2021 folder. Drag it to Trash. Empty Trash.
  3. In Downloads you have SketchUpPro-2021-0-1.dmg, double click on that to mount the disk image.
  4. In the disk image window, drag the SketchUp 2021 folder on to the Applications alias, to set the folder copying.
  5. After the copying is finished, go to Finder’s File menu, and Eject the disk image.
  6. Go into Applications, and into the new SketchUp 2021 folder. Open SketchUp.

If at that point you see two blue SketchUp icons in the Dock, one will have a dot under it, to show that it’s open, and the other won’t have a dot. Drag the one that doesn’t have a dot away from the Dock, to remove the icon. You can move the one with the dot under it to somewhere else on the Dock, if you want to.

Try those steps and see if you can now go into a new document and choose the Carpet, Fabrics, etc entry from the Colors palette.

Thank you for the reply, I followed your directions and repaired Microsoft C++ 2015-2019 redistributable, restarted my computer, and when I tried to run it, it still crashed. See below

Perla Arquieta ASLA PLA

205 Ruth Ave. Venice, CA 90291

http://www.parquieta.com/

https://portfolium.com/Parquieta

image003.jpg

image004.jpg

Thanks, I added a link to your 14 bugsplat reports to your support case.

How do I get to my support case?

Perla Arquieta ASLA PLA

205 Ruth Ave. Venice, CA 90291

http://www.parquieta.com/

https://portfolium.com/Parquieta

image003.jpg

image004.jpg

Thanks so much Colin! I’ll try this and see how it works.

You did already reply to the case, to give the screenshots. You could reply again to check on its progress, but support does have a backlog of other cases from before when yours started. I moved to another team a few weeks ago, leaving my remaining colleagues with even more cases to share between them.

Okay, thank you!

Perla Arquieta ASLA PLA

205 Ruth Ave. Venice, CA 90291

http://www.parquieta.com/

https://portfolium.com/Parquieta

image003.jpg

image004.jpg

im really angry about the constant crashing and cant be bothered always sending bug splat reports…i’m using a mac too…i am paid pro user this is really not acceptable…

Could you send in the next one that happens? Or tell me an exact time and date for the last one you sent in?

If you have sent in any before, what details did you enter? I can’t find any crashes under your name or email address, but if you can remember what message you sent I can search for that instead.

Having an issue where my files crash after the welcome screen.
I have sent a few bugsplat reports, reinstalled everything, updated windows, updated graphic drivers.
Not sure what else there is I can do without some help.

Tried to find a contact number for faster response, but there doesn’t seem to be one available.
My company has several pro subscriptions and I asked IT for the serial number, but there doesn’t seem to be in the emails.

I’m have the same problem. Sketchup crashs as soon as I launch it. The first times, deleting the plist fixed the problem and allow me to work again. But now, I don’t have the plist file any more and sketchup can’t launch…

I followed all the adwices but nothing worked. I even can send the report properly
COuld you please help me?

Have you sent in any bugsplats? If you did, when was that, and did you add your name or email?

If you didn’t send in a bugsplat, do send one in next time.

Yes I did, and finally did work
Crash #113524

Thank you

Mine finally worked, I am dealing with a VPN and accessing files from work, so my file path for certain templates and components we linked to an external drive that isn’t on my home network. This may have been the first issue, but I couldn’t open SketchUp to change that file path, it always crashed before I could even see the preferences tab.

In my case Nathan sent me this and it worked:

  1. Quit SketchUp (and LayOut)
  2. Go to Add/Remove Programs and uninstall the Microsoft Visual Studio C++ 2015 and above Redistributables (there may be a 32-bit and 64-bit version)
  3. Right click and re-run the SketchUp installer as an administrator. Once prompted choose repair (you can download it here if you need it: https://www.sketchup.com/download/all)
  4. Start SketchUp

This should get that library reset so that SketchUp can get running for you. Please let us know if you are still seeing any issues.
Regards,
Nathan
The SketchUp Team at Trimble Inc

Having the same issue again 3 week later???
Nothing is working this time

I am having the same problem on PC

Nothing has ever been done about my issue and I would like to take advantage of the promo code I received but my Sketchup 2021 still is not working.

I can see that James has been trying to help figure out your issue. He mentioned trying to get help from QA, and I will try to help him with that.

The special offer shouldn’t be a problem, though of course it would be nice if SketchUp worked at all!

Has SketchUp 2021 worked on any machine you’ve tried?